Jump to content


Photo

XenDesktop/XenApp servers become randomly unresponsive.

Started by David Desjardins , 18 April 2017 - 08:16 PM
3 replies to this topic

David Desjardins Members

David Desjardins
  • 4 posts

Posted 18 April 2017 - 08:16 PM

Hi guys,

We have been using XD7.7 with PVS since October now. Since a couple of months, we are running into unexpected behavior where the server and sessions become unresponsive. The frequency of the issue is about one random server a month (we have a total of 4 servers).  While the issue is occurring the server will not let you logon -- the logon process hangs while loading your profile, we can't logoff any active users, existing sessions become unresponsive. In the director, we start to have users stucked with "Application not running" sessions.

We are able to log in with VSphere console (after couple of minutes), but not via RDP. 

 

I can't find anything useful in the Event log, no error in systems/apps/citrix beside this one:

"ICA Connection request denied because the current user, domain\username, is not the owner of the Session, domain\username". Where domain\username was the username of an account on our network

 

Additional info:

OS: Windows 2012 R2, fully patched.

VDA Version: 7.7.0.6111

There is no memory/CPU peak, either on VMWare or from data collected with a perfmon.

 

Any help would be really appreciated.

 

Thanks,

 



Carl Stalhood CTP Member

Carl Stalhood
  • 11,954 posts

Posted 19 April 2017 - 01:36 AM

Same problem in VDA 7.13? You can upgrade the VDA without upgrading the Controllers.

David Desjardins Members

David Desjardins
  • 4 posts

Posted 19 April 2017 - 12:36 PM

Hi Carl,

I did that yesterday, as I was out of idea. (We tried several thing, from removing SCEP, to patching every single software apps possible.)

 

Usually, this is happening once every 2-3 weeks. 

 

I'll keep you post if that did the trick, I've seen someone having this issue on a different post, but he was in version 7.6.

 

Server were installed following your guide and best practices (back in October), so while I have the opportunity to speak with you, thanks a lot for that ! It was really helpful ;0)



David Desjardins Members

David Desjardins
  • 4 posts

Posted 20 April 2017 - 07:21 PM

Are you aware of any change with VDA version 7.13 that would afftect Printer auto-creation?

Since we migrated our VDA to 7.13, every computer that does not have a printer connected on a server where UPS is installed does not get his printer auto-created. This worked fine prior to migration.