Jump to content


Photo

Office 2016 - Server 2016 - "Feature ID not registered"

Started by Cedric Brady , 12 August 2017 - 10:34 PM
2 replies to this topic

Cedric Brady Members

Cedric Brady
  • 17 posts

Posted 12 August 2017 - 10:34 PM

I'm using latest App Layering ELM v4.4 for VMware, with Windows Server 2016 Packaging Machine, with a new OSLayer version (3rd) for August 2017 Windows updates and also including AppLayering MachineOS Tools v4.4.

 

I created a new Office 2016 AppLayer version as well for their August 2017 updates as well, using the new August 2017 Server2016 Packaging Machine.

 

After deploying the updated disk image to PVS, the Office 2016 installation gives a "Feature ID not registered" error message, when I log in via console and doesn't open.  If I go to the application path directly it works but it recommends that I run repair on the install.  IF I run Office application as published application through Citrix, I get the same error message.  

 

I have basically the same setup with Windows 10 2016 LTSB, and there are no issues with Office as well as the latest updates, and I followed the same update procedure for both OSs.  I deleted and recreated the updated August 2017 OS layer and Office 2016 app layer and after deployment the same thing happens.

 

If I change the template to the August 2017 OS LAyer for Server 2016, and the July2017 App Layer for Office and redeploying to PVS, everything works fine. So it seems like there is an issue with the August 2017 Office updates breaking the behavior.

 

Can anybody else reproduce?



Rob Zylowski Citrix Employees

Rob Zylowski
  • 82 posts

Posted 15 August 2017 - 10:50 PM

Hi Cedric how many times have you tried to create the layer?  Did you run ngen update for both 32 and 64 >net before finalizing the layer?

 

It seems that that error is most often seen with a corrupted install but I have never seen it specifically with layering.

 

Rob



Cedric Brady Members

Cedric Brady
  • 17 posts

Posted 15 August 2017 - 11:01 PM

I have tried building the layer a few times now, I even tried rebuilding the OS Layer as well. I ran the ngen update for both .NET frameworks for both the os layer and the office layer and rebooted again before finalizing both.

 

As I said, I followed the same exact steps with my Windows10 image as well, and it works fine, just Server 2016.