Jump to content


Photo

Storefront 3.8/3.11 still asks to install Citrix Receiver

Started by kpapaso136 , 27 July 2017 - 12:03 PM
7 replies to this topic

kpapaso136 Members

Kevin Papasoglou
  • 17 posts

Posted 27 July 2017 - 12:03 PM

Hello community,

 

I'm trying to figure out a small issue about Citrix Receiver deployment within Storefront for which I need to ask for help.

 

The setup is the following:

 

NetScaler 12.0 Build 41.22

- NetScaler Gateway configured with clientless access enabled

- Allows access to Citrix applications and NetScaler bookmarks

 

Storefront 3.11

- "Manage Receiver for Web Sites - Deploy Citrix Receiver - Deployment option:": Use Receiver for HTML5 if local Receiver is unavailable

- "Manage Receiver for Web Sites - Deploy Citrix Receiver - Allow users to download HDX engine": disabled

- <storename>Web/web.conf: pluginAssistant enabled="false"

- <storename>Web/web.conf: protocolHandler enabled="false"

 

Client:

- Internet Explorer 11

 

The problem is that after login at NectScaler and the "Loading your Apps" loading screen the user is still asked to install Citrix Receiver (see attachment). This issue was already occurring with Storefront 3.8 but didn't change with the upgrade to 3.11. Did I miss something? Even changing to "Always use Receiver for HTML5" doesn't change anything.

Does anyone have an idea what is missing to disable the deployment query? Thanky ou!

 

Best regards,

Kevin



kpapaso136 Members

Kevin Papasoglou
  • 17 posts

Posted 27 July 2017 - 12:08 PM

Lost the attachment:

Attached Thumbnails

  • rcvr_install.jpg


Markus Lundberg Members

Markus Lundberg
  • 8 posts

Posted 27 July 2017 - 12:44 PM

Try to add the storefront URL in trusted sites in the client web browser. 



kpapaso136 Members

Kevin Papasoglou
  • 17 posts

Posted 27 July 2017 - 01:04 PM

Hello Markus,

 

Thanks for your response. Adding the site to trusted sites unfortunately didn't change the behavior. Even if as we have many clients connecting not managed within our infrastructure, we are not able to enforce this setting.

 

Thanks!



Jack Tu Citrix Employees

Jack Tu
  • 108 posts

Posted 27 July 2017 - 02:06 PM

Hi,

You can disable receiver detection by the following methods.

 

Use a text editor to open the web.config file for Receiver for Web. This is typically located in the C:\inetpub\wwwroot\Citrix\storenameWeb\ directory, where storename is the name specified for the store.
 
Change <protocolHandler enabled="true" platforms="(Macintosh|Windows NT).*Chrome/((4[2-9]|[56789][0-9])|\d\d\d)(?!.*Edge)" skipDoubleHopCheckWhenDisabled="false" />
 
to
<protocolHandler enabled="false" platforms="(Macintosh|Windows NT).*Chrome/((4[2-9]|[56789][0-9])|\d\d\d)(?!.*Edge)" skipDoubleHopCheckWhenDisabled="false" />

 

Hope it helps!

 

Regards

Jack Tu :)



kpapaso136 Members

Kevin Papasoglou
  • 17 posts

Posted 27 July 2017 - 02:11 PM

Hi Jack,

 

Thanks for the reply but as mentioned in the initial post I already tried this one out but it didn't help. Looks like Storefront is ignoring the parameters. :(

 

Regards,

Kevin



Simarpreet Singh Citrix Employees

Simarpreet Singh
  • 38 posts

Posted 07 August 2017 - 12:22 PM

Hi,

 

Try uninstalling the Citrix Receiver using Receiver cleanup utility https://support.citrix.com/article/CTX137494 and then install the latest version of Receiver. 

 

Also, make the following changes: 

 

1. Internet Options -> Security -> Local intranet -> Sites -> Add Xenapp Site here
2. Open gpedit.msc (Local Group Policy Editor)
3. Computer Configuration -> Administrative Templates -> Windows Components -> Internet Explorer -> Compatibility View
4. Disable "Turn on Internet Explorer Standards Mode for Local Intranet"
5. Enable "Use Policy List of Internet Explorer 7 sites" and add your domain to the list. i.e. yourdomain.com

6. gpupdate /force

 

Regards,

Simarpreet Singh



kpapaso136 Members

Kevin Papasoglou
  • 17 posts

Posted 10 August 2017 - 12:54 PM

Hi Simarpreet,

 

Maybe we have a misunderstanding here.

The issue is more related to persons accessing the applications from devices which are not controlled within our infrastructure. Thus we neither have control of any of their locally installed software (such as Citrix Receiver) nor Internet Explorer settings. Anyway, this should not matter. What I try to achieve is to disable the Receiver deployment screen "Install Citrix Receiver to access your applications". From what I see I assume the changes in the Storefront configuration or web.conf file are being ignored no matter what they are set to and Storefront always offers the Receiver deployment. The desired behavior is that Storefront does not offer Receiver deployment when it's not detected on the client and finally falls back to HTML5 according to the setting "Use Receiver for HTML5 if local Receiver is unavailable".

 

Regards,

Kevin