Jump to content


Photo

Azure MCS

Started by Morne Botha , 17 July 2017 - 12:37 PM
1 reply to this topic

Morne Botha Members

Morne Botha
  • 7 posts

Posted 17 July 2017 - 12:37 PM

I hope someone can assist with this.

 

We have the latest version of Xendesktop running in Azure RM.

 

But when i try and update MCS it fails with the following Error.

 

Task Information:
Start Date: 17 July 2017
Start Time: 10:14 AM
Finish Date: 17 July 2017
Finish Time: 11:52 AM
State: Failed
Master image: XDHyp:\HostingUnits\*.*T\image.folder\*.RG.resourcegroup\(VHD Name).storageaccount\vhds.container\(VHD-NAME).vhd
 
Terminating Error:
An error occurred while preparing the image.
Stack Trace:
   at Citrix.Console.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeTask.CheckForTerminatingError(SdkProvisioningSchemeAction sdkProvisioningSchemeAction)
   at Citrix.Console.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeTask.WaitForProvisioningSchemeActionCompletion(Guid taskId, Action`1 actionResultsObtained)
   at Citrix.Console.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.PublishProvisioningSchemeImageTask.RunTask()
   at Citrix.Console.PowerShellSdk.BackgroundTaskService.BackgroundTask.Task.Run()
 
DesktopStudio_ErrorId : ProvisioningTaskError
ErrorCategory : NotSpecified
ErrorID : FailedToCreateImagePreparationVm
TaskErrorInformation : Terminated
InternalErrorMessage : Error: creating virtual machine failed. Exception=System.TimeoutException: AzureWriter timed out while retrying operation
   at Citrix.AzureFacade.Throttling.AzureThrottle.RetryUntilTimeout(Func`1 doWork, Nullable`1 retryInterval, Nullable`1 timeout)
   at Citrix.AzureFacade.Management.VirtualMachineManager.Create(AzureResourceGroup resourceGroup, String machineName, AzureMachineSize machineSize, AzureVirtualHardDisk osVhd, IList`1 dataDisks, AzureNetworkInterface networkInterface, IDictionary`2 metadata, String licenseType)
   at Citrix.AzureRmPlugin.MachineCreationAPI.AzureRmPlugin.CreateMachine(ConnectionSettings connectionSettings, HostingSettings hostingSettings, ProvisioningSettings provisioningSettings, MachineCreationRequest machineCreationRequest)
 
 
So the environment is as Follows.
 
All Citrix Applications is the latest.
But because the problem with the Black screen when opening Apps we have to Run the VDA on Server 2012 R2.
 
Any ideas


Morne Botha Members

Morne Botha
  • 7 posts

Posted 21 July 2017 - 07:33 PM

Ok problem was resolved .

 

So i think the problem was in the copy that i did with powershell.

Deleted the image from Azure storage Explorer.

 

Recreated it again .

 

 

Now it is working