Jump to content


Photo

"Cannot Complete your request" changing to HTTPS

Started by Damian Thompson , 14 July 2017 - 04:20 PM
7 replies to this topic

Best Answer Carl Stalhood , 17 July 2017 - 01:22 PM

In 3.0:

 

If the Base URL is https but you don’t have certificates installed on your StoreFront servers (aka SSL Offload) then you’ll need to run the following commands on the StoreFront servers. See No More Editing of Hosts File at Citrix Blog Post What’s New in StoreFront 3.0.

 

& "C:\Program Files\Citrix\Receiver StoreFront\Scripts\ImportModules.ps1"

Set-DSLoopback -SiteId 1 -VirtualPath /Citrix/StoreWeb -Loopback OnUsingHttp

Damian Thompson Members

Damian Thompson
  • 68 posts

Posted 14 July 2017 - 04:20 PM

Hi,

I have 2 test environments, one 7.13 and one 7.6.

I converted the 7.13 one to HTTPS with StoreFront 3.9 without issues.

I think I followed exactly the same process for the other environment 7.6 with a StoreFront 3.0.1 but when I try an access it from a web browser it comes up with an error "Cannot Complete your request"

To add a bit more, it is a simple setup, internal only with no Netscalers or anything.  I have created a self signed certificate the same as I did in the other environment with a friendly name and created a DNS entry just as I did in the other environment.

If I out it back to HTTP still using the friendly name it works fine.

Anyone any ideas?

Thanks in advance



Carl Stalhood CTP Member

Carl Stalhood
  • 12,078 posts

Posted 14 July 2017 - 05:00 PM

Did you enable loop back and set it to OnUsingHttp?

Damian Thompson Members

Damian Thompson
  • 68 posts

Posted 17 July 2017 - 06:47 AM

Hi Carl,

Thanks for your response.

Where would I find this setting please?

Thanks



Damian Thompson Members

Damian Thompson
  • 68 posts

Posted 17 July 2017 - 09:22 AM

Hi,

I have checked the Web.Config file and it has the following:

 

loopback="On"

loopbackPortUsingHttp="80"

 

Should this be changed and if so, what to?



Carl Stalhood CTP Member

Carl Stalhood
  • 12,078 posts

Posted 17 July 2017 - 12:58 PM

In 3.5+ :

 

  1. On the left click the Stores node.
  2. Right-click the store and click Manage Receiver for Web Sites.
    7be25f942788fd1a029addfa0864ebcd.png?w=8
  3. Click Configure.
    760d7ff586615cf8a93cc0ef8a196a1c.png?w=8
  4. On the Advanced Settings page, change Enable loopback communication to OnUsingHttp. Click OK, and then click Close.
    4ba9ea0ed1b423cd1e1bb43ff59901ac.png?w=8


Damian Thompson Members

Damian Thompson
  • 68 posts

Posted 17 July 2017 - 01:14 PM

Hi Carl,

I am not seeing the same screens or options.  The StoreFront I have an issue with is version 3.0.1.

Thanks



Carl Stalhood CTP Member

Carl Stalhood
  • 12,078 posts

Posted 17 July 2017 - 01:22 PM

In 3.0:

 

If the Base URL is https but you don’t have certificates installed on your StoreFront servers (aka SSL Offload) then you’ll need to run the following commands on the StoreFront servers. See No More Editing of Hosts File at Citrix Blog Post What’s New in StoreFront 3.0.

 

& "C:\Program Files\Citrix\Receiver StoreFront\Scripts\ImportModules.ps1"

Set-DSLoopback -SiteId 1 -VirtualPath /Citrix/StoreWeb -Loopback OnUsingHttp


Best Answer

Damian Thompson Members

Damian Thompson
  • 68 posts

Posted 17 July 2017 - 02:58 PM

Thanks Carl,

You highlighted something in your response.  I had imported my SSL certificate but realised I had done so into my User Store rather than the computer store. Once I imported it into the Trusted Root Certificates in the Computer store it all works.

Thanks again.