Jump to content


Photo

Disabling just the onboard microphone

Started by Nick Panaccio , 12 July 2017 - 06:45 PM
4 replies to this topic

Nick Panaccio Members

Nick Panaccio
  • 11 posts

Posted 12 July 2017 - 06:45 PM

Is it possible to disable just the onboard microphone on a client's device when connecting to a VDI desktop? We had an issue with one of our apps (Dragon NaturallySpeaking) where using a headset or microphone plugged into the client will pass audio through both this headset/mic and the onboard/built-in microphone on the laptop. This in turn causes Dragon to try and switch between these microphones during dictation, causing all sorts of issues.

 

I have tried setting up "Client USB Device Redirection Rules" to deny all audio devices except for our three approved microphones, but the onboard microphone (Realtek HD Audio, showing up in Citrix as "Citrix HDX Audio" for both input and output) always maps in the user's session. I've tried a dozen rule sets so far, some of which are listed below:

 

----------------------------------------------

DENY: Class=01
ALLOW: VID=047F PID=C022
ALLOW: VID=0554 PID=1001
ALLOW: VID=0D8C PID=0008

----------------------------------------------

DENY:
ALLOW: VID=047F PID=C022
ALLOW: VID=0554 PID=1001
ALLOW: VID=0D8C PID=0008

----------------------------------------------

DENY: VID=10EC #This is the onboard mic's VID

----------------------------------------------

DENY:

----------------------------------------------

 

I figured that last one would deny everything, but nope. This is driving me up the wall. So far, the only way I have been able to prevent the onboard microphone from mapping in the VDI desktop is to disable "Client Microphone Redirection", but that disables all microphones.

 

Can anyone point me in a better direction to try and sort this out?



Jordan Ferguson Members

Jordan Ferguson
  • 11 posts

Posted 17 July 2017 - 12:58 PM

Couldn't you just disable the playback options you don't want described. Also not sure if you have looked into this but we had this with a speech program and under the microphone, there is a playback advanced and I had to unchecked the allow applications to take control of this microphone. 



Nick Panaccio Members

Nick Panaccio
  • 11 posts

Posted 19 July 2017 - 06:30 PM

It didn't even dawn on me until after I created this thread that the reason I can't disable this is because it's not a USB device, but rather the internal sound card. I did look into the Advanced options, but no configuration made a difference for us. This version of Dragon seems to have issues figuring out which microphone it should be using even though the microphone you select is hard-coded into the configuration files.

 

For now, the only solution that seems to allow us to disable the internal microphone is the SoundVolumeView app from NirSoft, which supports command line functions. I basically wrote a small batch file that disables the internal microphone, leaving the plugged in USB headset the only recording device in the session. Not an optimal solution by any means, but it at least functions properly.



Corey Tracey Members

Corey Tracey
  • 149 posts

Posted 19 July 2017 - 07:42 PM

Have you tried disabling microphone redirection?  We had this issue on Linux thin clients and Dragon Nuance on Non Persistent VDI machines



Nick Panaccio Members

Nick Panaccio
  • 11 posts

Posted 20 July 2017 - 11:26 AM

Have you tried disabling microphone redirection?  We had this issue on Linux thin clients and Dragon Nuance on Non Persistent VDI machines

 

We did, but since we had all of our providers setup their headsets using the Mic-In input, disabling microphone redirection basically eliminates all of their headsets. This is what we get for listening to Nuance and using Mic-In instead of USB when configuring their profiles, I guess.