Jump to content


Photo

VDA agent 7.14.1

Started by Anders Eriksson , 26 June 2017 - 11:49 PM
19 replies to this topic

Anders Eriksson Members

Anders Eriksson
  • 86 posts

Posted 26 June 2017 - 11:49 PM

Hi,

 

Seen the same behavior on multiple Windows 2012 R2 servers, where I before the upgrade did run the VDA cleanup tool. 

 

After reboot and new VDA agent install (7.14.1) it refuses to install the Citrix Universal Printer part (UPSClient_x64)

 

See attached error, this actually pops up twice, reckon its one for each printer (Citrix Universal and XPS)

 

Anyone experience the same?

 

 

 

Attached Thumbnails

  • UPS.JPG


Anders Eriksson Members

Anders Eriksson
  • 86 posts

Posted 27 June 2017 - 02:42 PM

Hi,

 

More issues, now 2 static Windows 2012R2 servers with the exakt same issue. After vda update no Citrix applications is possible to launch

Cant launch any applications/desktop since Citrix gpos cant be loaded

 

CseEngine.exe stopped working

 

 

Attached Thumbnails

  • cseengine.JPG


Anders Eriksson Members

Anders Eriksson
  • 86 posts

Posted 27 June 2017 - 11:04 PM

Managed to fix the issue with CseEngine.exe by following this old article.

 

https://support.citrix.com/article/CTX133567

 

Seems atleast the users can login again, but alarm is triggered and CseEngine going up and down.

I have cleaned all Citrix gpos and registry, but doesnt help



Miroslav Blasko Members

Miroslav Blasko
  • 396 posts

Posted 28 June 2017 - 07:57 AM

hi, do u have the same issue like me here?

 

https://discussions.citrix.com/topic/387278-xa714-first-touch-errors/



Anders Eriksson Members

Anders Eriksson
  • 86 posts

Posted 28 June 2017 - 09:33 AM

Hi,

 

I see this error on all servers that been upgraded to the latest vda agent.. CseEngine keeps going up and down, crashing constantly. I have not heard any users complain though, but this does not seem stable.

 

We have monitors on all Citrix services and this causing a spam of trigger alarms.

 

Check_services - CitrixCseEngine: stopped (critical)

 

 

Yes, and exactly the same event trigger with Citrix UPM

Attached Thumbnails

  • cseengine.JPG
  • upm.JPG


Anders Eriksson Members

Anders Eriksson
  • 86 posts

Posted 28 June 2017 - 09:52 PM

Checked eventviewer again, also have these error

 

The print spooler failed to regenerate the printer driver information for driver Citrix XPS Universal Printer for environment Windows x64. Win32 system error code 2114 (0x842). This can occur after an operating system upgrade or because of data loss on the hard drive.

 

The print spooler failed to regenerate the printer driver information for driver Citrix Universal Printer for environment Windows x64. Win32 system error code 2114 (0x842). This can occur after an operating system upgrade or because of data loss on the hard drive.



Christoph Kolbicz Members

Christoph Kolbicz
  • 46 posts

Posted 30 June 2017 - 11:41 AM

i have seen the same error after VDA uninstalling and reinstalling. we went back to a version before the uninstall and then i did an inplace update and the error did not happen anymore. 

 

i tried a lot of things to fix this, but i did not find a solution. seems uninstalling vda and installing 7.14+ will break the printer subsystem.

 

CitrixCseEngine crash might be related to citrix session printers - are you using them?



Anders Eriksson Members

Anders Eriksson
  • 86 posts

Posted 30 June 2017 - 11:52 AM

Ok, I will try a inplace upgrade instead. You installed 7.13 agent and then 7.14.1 again?

Yes, we are using alot of session printers. Some users have more then +50 printers assigned.

 

We now also have issues with AX2009 and AX2012 aswell, where some forms are being placed in background and not as the main windows visible. So alot of issues since the upgrade from 7.6. Im very frustrated that is always something that stops working when updating nowadays. I find it strange that not more users reported issues, since the recommended path is to run the cleanup VDA agent.

 

Will try the "fix" for myself later on, thanks for the tip!



Miroslav Blasko Members

Miroslav Blasko
  • 396 posts

Posted 30 June 2017 - 12:00 PM

u dont have to try it.

 

I did test upgrade and also clean install (2012r2 and also 2016)

 

the issue persist !

 

And it is related to session printers.

https://discussions.citrix.com/topic/387278-xa714-first-touch-errors/

 

It is issue of 7.14 version...need to be fixed by citrix



Christoph Kolbicz Members
  • #10

Christoph Kolbicz
  • 46 posts

Posted 30 June 2017 - 12:16 PM

i think in the end i installed clean 7.14.1 and the printer issue did not happen anymore. i had first 7.13 and uninstalled it and then i had the exact same issue with the printers after i installed 7.14. 

 

the engine crash is described in the link of miroslav "the Citrix Group Policy Engine service crashing when citrix GPO mapping more than 15 session printers. I mapping less then 15 session printers for the same user everything is ok."

 

there are so many issues with citrix atm. its really annoying. 



Romain BODELOCHE Members
  • #11

Romain BODELOCHE
  • 37 posts

Posted 12 July 2017 - 05:25 PM

Same issue on Windows 7 x86  after upgraded to 7.14.1

 

I tried to cleanup the VDA but same error with CseEngine.exe crashing



Romain BODELOCHE Members
  • #12

Romain BODELOCHE
  • 37 posts

Posted 13 July 2017 - 12:10 PM

I have tested the vDisk on XD 7.14 site and the engine is not crashing anymore.



Anders Eriksson Members
  • #13

Anders Eriksson
  • 86 posts

Posted 13 July 2017 - 07:45 PM

Still ongoing case with citrix, I have sent procdump and waiting for fix. Though 2 days now and I havent heard anything back. 

 

Br Anders



Romain BODELOCHE Members
  • #14

Romain BODELOCHE
  • 37 posts

Posted 17 July 2017 - 07:39 AM

Hi Anders,

 

I have solved the CseEngine.exe crashing issue in my environnement.

It was caused by a citrix profile policy.

I modified the exclusion directories list by removing directories which are included by the default exclusion list (ex : AppData\Local\Temp).

The engine is not crashing anymore on all catalogs.

 

This issue had not happened with 7.13.

 

BR



Miroslav Blasko Members
  • #15

Miroslav Blasko
  • 396 posts

Posted 17 July 2017 - 08:56 AM

Hi Romain,

 

can u be please more specific.

 

What exactly have u removed or added in to exclusion directories?

thanks



Romain BODELOCHE Members
  • #16

Romain BODELOCHE
  • 37 posts

Posted 17 July 2017 - 09:14 AM

I exactly removed the directories below in the exclusion list :

 

AppData\Local\Packages
AppData\Local\Temp
AppData\Local\Microsoft\OneNote
AppData\Local\Microsoft\Office\15.0\Lync\Tracing
AppData\Local\Microsoft\Terminal Server Client
AppData\LocalLow
AppData\Local\Google\Chrome\User Data\Default\Cache
AppData\Local\Google\Chrome\User Data\Default\JumpListIcons
AppData\Local\Google\Chrome\User Data\Default\JumpListIconsOld
AppData\Roaming\Sun\Java\Deployment\cache 
AppData\Roaming\Sun\Java\Deployment\log 
AppData\Roaming\Sun\Java\Deployment\tmp

 

These directories are included in the default list.



Miroslav Blasko Members
  • #17

Miroslav Blasko
  • 396 posts

Posted 17 July 2017 - 10:42 AM

post deleted



Anders Eriksson Members
  • #18

Anders Eriksson
  • 86 posts

Posted 17 July 2017 - 11:19 AM

Thanks alot, will try the same. The issue with the session printers (if more then 15) assigned. Does it also solves this issue?

Since im still having a ongoing case with Citrix. But main issue is the crasching CseEngine.exe.



Miroslav Blasko Members
  • #19

Miroslav Blasko
  • 396 posts

Posted 17 July 2017 - 11:39 AM

sorry to say that...but deeper testing revealed that this has no impact on my issues. :-((



Anders Eriksson Members
  • #20

Anders Eriksson
  • 86 posts

Posted 17 July 2017 - 01:13 PM

Ok, I will try the solution later this evening. Im updating when I applied the test.

Last status regarding the case with Citrix is gflag with procdump, sent in the latest dump Friday 14/7.

If this still not working with the above, im forced to go back to VDA 7.13 where the issue dont exist.

Not sure if it gives some other issues, but the issue with CseEngine and UPM, included with session printers causing alot of disturbance in our environment.

 

 

_________________________________________________________________________________________________

 

Neither did it work in our environment, I dont even use the default exclusion list. I have configured my own Exclusion list - Directories.


Edited by Anders Eriksson, 17 July 2017 - 10:46 PM.