Jump to content


Photo

HTTP POST with file attachment( multi part) is blocked by net scalar

Started by chanda M , 20 June 2017 - 05:31 AM
5 replies to this topic

chanda M Members

chanda M
  • 1 posts

Posted 20 June 2017 - 05:31 AM

Hi,

 

We are using Netscalar as a load balancer and HTTP Proxy for our application. After configuring Netscalar file upload is not working in our application.

 

We are trying upload file from JSP, so calling servlet witrh HTTP POST request, this request has file as attachment, such requests are getting re-directed to welcome page and we are getting 302 Response from HTTP.

 

Kindly suggest if there are any special configuration required to allow such requests.

 

Please find attached Screen shot which shows The HTTP request details.

 

Normal HTTP post are working, if it has file attachment then it is not working.

 

 

Regards,

Chanda



Carl Stalhood CTP Member

Carl Stalhood
  • 12,347 posts

Posted 20 June 2017 - 11:46 AM

Is Web App Firewall enabled?

 

When attaching, click "Add to Post".



aangelop Members

Andrew Angelopoulos
  • 36 posts

Posted 11 October 2017 - 08:16 PM

I'd like to piggyback off this as well. A Similiar issue, not the post body size. But turning off the AppFW or multipart/form-data lets me upload. Clicking the streaming checkbox doesn't help, but I think that might be a bug in PHP. 

 

Anyway, is there a way around this other than ignoring all multipart/form-data?

 

Thanks!

 

Andrew

NS 11.1.53.13.



Paul Blitz Members

Paul Blitz
  • 4,036 posts

Posted 12 October 2017 - 11:09 AM

The docs state: Large File Upload Failure
Jan 11, 2017

When you encounter large file upload failures, ensure that you check the following:

     – Misconfigured appfw postbody limit

     – Enabled file upload scanning leading to increased processing time

     – Hitting system limits

•    Since release 11.0,  the streaming flag can be enabled on per profile basis to avoid buffering by executing the following command:

     - set appfw profile <profile name> -streaming on

• Ensure that the backend server supports chunked requests.

 

Whilst risking asking granny how to suck eggs, are any of those relevant to you?



aangelop Members

Andrew Angelopoulos
  • 36 posts

Posted 12 October 2017 - 05:27 PM

Wow... doesn't look like my post is here (from my POV). Perhaps a dupe now... but just in case. 

 

Thanks, Paul, I actually found that piece there.

 

I used the streaming checkbox (which offered no solace at all! lol! and actually made the whole app a little wiggy) and still could not find where this setting is? "Enabled file upload scanning leading to increased processing time" 

 

Either it is staring me in the face and I am missing it, or its one of the NS buried features.

 

As far as system limits, I set aside a 1.1GB for the post body and not using anywhere near all the mem.  There seems to be some kind of possible bug (not sure if it is the issue) between chunked data and Apache 2.4 and PHP-FPM. Not sure if that is in play here, but I failed to mention it yesterday.

 

Thoughts? Going to be continuing my testing today, though most of the AppFW is in learn mode still 

 

We all suck eggs on occasion. 



aangelop Members

Andrew Angelopoulos
  • 36 posts

Posted 12 October 2017 - 05:33 PM

Wow... doesn't look like my post is here (from my POV). Perhaps a dupe now... but just in case. 

 

Thanks, Paul, I actually found that piece there.

 

I used the streaming checkbox (which offered no solace at all! lol! and actually made the whole app a little wiggy) and still could not find where this setting is? "Enabled file upload scanning leading to increased processing time" 

 

Either it is staring me in the face and I am missing it, or its one of the NS buried features.

 

As far as system limits, I set aside a 1.1GB for the post body and not using anywhere near all the mem.  There seems to be some kind of possible bug (not sure if it is the issue) between chunked data and Apache 2.4 and PHP-FPM. Not sure if that is in play here, but I failed to mention it yesterday.

 

Thoughts? Going to be continuing my testing today, though most of the AppFW is in learn mode still 

 

We all eggs on occasion.  (blocked for agreeing with you on eggs)

 

Edit: Oh, duh... Exclude Uploaded Files from Security Checks..... 

 

Nope that setting didn't help either....