Jump to content


Photo

Local App Access in XenApp 7.6

Started by Byron Zhao , 19 May 2017 - 06:01 PM
8 replies to this topic

Byron Zhao Members

Byron Zhao
  • 10 posts

Posted 19 May 2017 - 06:01 PM

Hi,

 

In our branches, we have some training videos stored locally. I am trying to set up local app access in our 7.6 XenApp farm so that when users click on the URL that is defined in the blacklist, it will bring up the local IE to access to the local videos files to play locally. 

 

In our 7.6 XenApp farm, we publish full desktops. And TWIFullScreenMode=1 and ConnectionBar=0 were defined in the default.ica file so that when branch users launch it, they will have the seamless desktop expanding the full screen over their dual monitors. However, the blacklist URL is not able to bring up the local IE.

 

If I connect to the same storefront server, but a different site that is using the default.ica file, I am able to bring up the local IE when the link has the blacklisted URL. 

 

All the documents I researched about local app access says local app access is designed for full screen. In my case, it seems it doesn't work with TWIFullScreenMode=1. Are there any other ways to enable full screen expanding to dual monitors while local app access still works? 

 

Thanks a lot for any help.

 

Byron

 



Deepanshu Soni Citrix Employees

Deepanshu Soni
  • 94 posts

Posted 22 May 2017 - 10:07 PM

Hello Byron,

 

I have some articles for you, they will explain you Local App Access, Content and URL redirection.

 

Please let me know, if the help.

 

https://support.citrix.com/article/CTX106094

https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-6/xad-build-new-enviroment/xad-laa-intro.html

https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-6/xad-build-new-enviroment/xad-laa-intro/xad-laa-config.html

 

Thanks.



Byron Zhao Members

Byron Zhao
  • 10 posts

Posted 23 May 2017 - 02:33 AM

Thanks Deepanshu. I will give it a try tomorrow and will let you know.



Byron Zhao Members

Byron Zhao
  • 10 posts

Posted 23 May 2017 - 07:12 PM

Never seen the first article, and I did give it a try by adding the following registry key, but the behaviors are the same, not working in seamless full window, but works in the full window with connection bar.

 

HKEY_LOCAL_MACHINE \SOFTWARE\Citrix\SFTA\ValidSites

 

Already read the second and third articles, but went through them again. Following the third article, and verified I did these:

1) CitrixReceiver.exe /ALLOW_CLIENTHOSTEDAPPSURL=1

2) C:\Program Files\Citrix\ICA Client\redirector.exe/regIE

3) Created HKEY_LOCAL_MACHINE\SOFTWARE\wow6432node\Citrix\Client Hosted Apps\Policies\Session State\Terminate

4) Added Local App Access and URL blacklist

5) Make sure the IE plugin in both VDA and client are enabled

 

The only thing I haven't done is add icaclient.adm to local group policy, since I am not able to locate icaclient.adm. Struggling to find it in the Internet now.

 

Will provide updates once I find it.

 

Thanks

 

Byron

 

 



Deepanshu Soni Citrix Employees

Deepanshu Soni
  • 94 posts

Posted 23 May 2017 - 07:54 PM

Byron,

 

You can locate the file at %SystemDrive%\Program Files (x86)\Citrix\ICA Client\Configuration folder on any Windows PC on which Citrix Receiver for Windows is currently installed

 

For Receiver 4.x it is renamed as receiver.admx and receiver.adml(language file)



Byron Zhao Members

Byron Zhao
  • 10 posts

Posted 23 May 2017 - 08:43 PM

Deepanshu,

 

I found the receiver.admx file, however, my Windows 7 local group policy editor is not able to recognize the .admx file. I thought OS after Vista should be able to recognize it... but ...

 

Any help would be appreciated.

 

Thanks

 

Byron



Deepanshu Soni Citrix Employees

Deepanshu Soni
  • 94 posts

Posted 23 May 2017 - 09:14 PM

Make sure you copy receiver.admx and paste it to C:\Windows\PolicyDefinitions\

and copy receiver.adml and paste it to C:\Windows\PolicyDefinitions\en-US

 

You can find the information in : https://support.citrix.com/article/CTX121613

 

Thanks

 

Deepanshu



Byron Zhao Members

Byron Zhao
  • 10 posts

Posted 24 May 2017 - 08:36 PM

Thanks Deepanshu, and I am able to load the template now. 

 

However, after I made all the changes like those in the articles (at least I think), it still doesn't work in seamless full screen. I tried to look for logs that may tell me what is going on, had no luck.



Byron Zhao Members

Byron Zhao
  • 10 posts

Posted 28 August 2017 - 09:08 PM

Finally I was confirm by tech support that in order to use Local App Access, I have to turn on the Connection bar. Without the Connection Bar, Local App Access would not work.