Jump to content


Photo

Storefront Version Compatibility

Started by Andrew Sharp , 19 April 2017 - 12:29 PM
1 reply to this topic

Andrew Sharp Members

Andrew Sharp
  • 4 posts

Posted 19 April 2017 - 12:29 PM

Good Morning

 

I'm currently in the middle of a Citrix migration project at my company. Basically we're moving from XA6 to XD7.11. One hurdle that seems to keep messing us up is getting storefront and F5 to work correctly. Currently we run XA6 through the F5 for load balancing without any issues. As we test our XD7 deployment we have an issue where going through F5 yields a "cannot complete request" error upon trying to authenticate. I've looked through all of the citrix e-docs i can't find the solution. I've tried many of the suggestions i've found on this forum but unfortunately none have resolved our issue. 

 

At this point it's being considered that there is a version incompatibility between our F5, Storefront, and XD versions. We've reviewed the most recent F5/Citrix iApp config doc and on paper it doesn't appear our combo is supported.

 

F5 - LTM 11.5 HF6

Storefront 3.6

XD 7.11

 

One thing i'm wanting to try is installing an older version of storefront to see if that changes anything. Now finally my question. Is it allowed/supported/compatible to install an older version of storefront than what is packaged with our XD install? Meaning if i were to stand up a new Storefront 2.6 server and configure it to communicate with our XD 7.11 environment, would that even work? We have an F5 upgrade scheduled for later in the year that i have a feeling might resolve the issues we're seeing, but in the mean time i'm trying to exahust all other possible options. Any feedback is greatly appreciated.

 

Thanks

Andrew



Nathan Joseph Members

Nathan Joseph
  • 95 posts

Posted 19 April 2017 - 07:34 PM

The F5 upgrade will probably help, as they note that BIG-IP LTM v12.0 or v11.6 HF6 is needed for SF 3.x support.

 

That being said, I know of XD 7.9 environments that have functioned with SF 2.6, so I see no reason why XD 7.11 wouldn't. That being said, it is probably not a configuration that Citrix will provide extensive support for, given what is outlined in https://support.citrix.com/article/CTX200356