Jump to content


Photo

Mac OS Sierra 10.12.4, Receiver 12.5

Started by joe agemy , 03 April 2017 - 09:32 PM
11 replies to this topic

joe agemy Members

joe agemy
  • 5 posts

Posted 03 April 2017 - 09:32 PM

So I work at a Hospital help desk and once in a while we will get callers calling from home (mostly on the weekdend) regarding launching Citrix applications on their Mac laptop. Citrix applications are launched via a Citrix portal. Users will log into the designated hospitals Citrix page (once logged in, NetScaler is in the web address), and then they will see a list of applications they can launch via using the Citrix Receiver. Today, I had a lady call in using Mac OS Sierra 10.12.3. No matter what I tried, I could not get the .ica files to actually open in Safari nor Chrome. Here is the workflow and results:

  1. Logged into Citrix portal hospital page
  2. Clicked on the designated icon, which launches an .ica file. A small little spinning wheel would begin under the icon, followed by the, Citrix "Starting application," window.
  3. Finally after a few seconds, that "starting application" window would disappear, and on the takbar on the bottom of the page, the Citrix Viewer icon would show up. It would start bouncing up and down and then suddenly, a very tiny looking taskbar would flash next to the Citrix Viewer icon at the bottom (on the taskbar) and then go away.
  4. I never got any error messages, the .ica (or maybe the Citrix Viewer) would not launch the .ica file to allow access to the application.

She is currently using MacOS Sierra 10.12.4 and Citrix Receiver for Mac 12.5.

 

Any ideas what's going on!?

 



Dustin Norman Citrix Employees

Dustin Norman
  • 352 posts

Posted 04 April 2017 - 12:00 PM

Hi Joe,

 

Can you enable Session Logging, repro the issue and post the log file? You can enable Session Logging by opening Receiver preferences, switching to the Advanced tab and changing the Session Logging dropdown to Full.

 

Thanks,

Dustin



Tom Gamull CTP Member

Tom Gamull
  • 22 posts

Posted 04 April 2017 - 12:35 PM

Are you sure it's not the same issue here (which was a security plug-in setting)? http://discussions.citrix.com/topic/375649-receiver-v12-no-longer-integrates-with-safari/



Dustin Norman Citrix Employees

Dustin Norman
  • 352 posts

Posted 04 April 2017 - 12:46 PM

Hi Tom,

 

The fact that Joe states that the "Starting application..." window appears and the Citrix Viewer icon shows up makes me believe it's not this same issue. If it was the same issue, then the Citrix Viewer wouldn't even start. Good thought though.

 

Dustin



joe agemy Members

joe agemy
  • 5 posts

Posted 04 April 2017 - 02:22 PM

Hey guys, thank you so much for the responses.

 

I have made sure, within Safari, that all those above plug-ins, Citrix, Java, is all set to allow.  I've literally tried everything I can think of!  The odd thing is, once the Citrix Viewer icon pops up at the bottom of the screen, I can see the log-in box pop up REAL small next to the viewer, but then it just goes away.

 

As a workaround, I've been able to get her in through using the Citrix Receiver Google Chrome add-on, but once she is inside of her program, it is only pulling network printers, and she is trying to print to her local printer (she works from home and has a printer that is set up on Wifi).  



joe agemy Members

joe agemy
  • 5 posts

Posted 04 April 2017 - 09:45 PM

On another side note, how often does Citrix update the Mac version?  Is another one due up soon?  Unfortunately, the only other option I can think of is the user to Dual Boot her Mac with Windows!



Dustin Norman Citrix Employees

Dustin Norman
  • 352 posts

Posted 05 April 2017 - 12:37 AM

Joe,

 

Did this work previously with an older version of Receiver for Mac or is this a new user? Is the user launching a published application or a desktop? Are there any other apps/desktops that the user can launch? If so, does the same thing happen with those?

 

Dustin



joe agemy Members

joe agemy
  • 5 posts

Posted 05 April 2017 - 02:35 AM

Dustin,

 

From the information I gathered, around a month ago, she updated her MacOS to Sierra 10.12.3.  I am not sure which MacOS she had or which Receiver version she had before that (I believe it was 12.3 or 12.4). Ever since she updated her MacOS, is when it stopped working for her in Safari and also Chrome.

 

So basically at the hospital, we have a main hospital Citrix page that we log into with a username and password.  After that, while it loads the next page, I do see NetScaler within the address bar.  After the log-in page loads, and the next screen loads, we get to a webpage that has a list of applications that can be launched.  Here is a screenshot of a similar looking page (sorry for the long link):

 

https://lh6.googleusercontent.com/uW0Xr8I_EhLcOF0TnJaP0yeLbUYL77OgZYsuEd4rPT3bX-4nFHK4g-_Hos6-Ds6EofnrEZVH8ExMTuTj_FdcRtKmayeU1BZNRFTX04nd6kSefkNtt-T40OP9TDbPug

 

After the user clicks on an application, is when the "starting application" black window will pop up and then where the issues start.  I don't know if this will help, but if you stay logged on the webpage too long, it will time out and on the time out page, it has a Citrix XenApp logo.

 

I'm not too familiar with how Citrix environments are set-up (as I am only tier 1 help desk), but I hate to not give any form of resolution to the lady other then, "get a windows PC."  That will not work in this situation!

 

Granted, she can load everything fine via the Google Chrome Citrix Receiver add-on, but that defeats the purpose of her being able to print to her home local printer.



Nicholas Kozell Members

Nicholas Kozell
  • 2 posts

Posted 05 April 2017 - 05:10 AM

It's very possible that her recent update has the Safari browser blocking flash, I believe xenapps require flash to run. I haven't had the chance to try this yet but you may be able to enable flash on a site by site basis. https://helpx.adobe.com/flash-player/kb/enabling-flash-player-safari.html

Good luck!

Ady Hewitt Members
  • #10

Ady Hewitt
  • 2 posts

Posted 05 April 2017 - 05:13 PM

Had the same issue . 

 

My fix was that the citrix plugin was not enabled for the site i wanted to use . 

 

I also enabled flash for that site as well . 

 

Dont know if this will help but its worked for me 



joe agemy Members
  • #11

joe agemy
  • 5 posts

Posted 07 April 2017 - 09:12 PM

Sooo finally, I made some progress...

 

First off, I had to install Receiver 12.3.  When I had Receiver 12.5 installed, I would always give me the error, "You have not chosen to trust VeriSign Class 3 public primary certification authority/cn.  I checked on my Windows PC, the certificate needed for the website, and then, on her Mac Sierra 10.12.4, I downloaded the certificate and imported it to her key-chain.  Still gave me the same error....What's surprising though was that either Receiver 12.2 or 12.3 DID NOT give the certificate error.

 

Another thing I realized is that none of the applications in a specific folder will launch correctly!  Ones that are not in the folder launch just fine!  Thinking back a few months ago, I had another incident where a user, on a Mac, was trying to launch the SAME icon with the exact same issue!  He had a Windows PC to use so that really wasn't a big deal it wouldn't launch on his Mac.

 

Last question...what I do notice is that when I click on the icon that does not launch, and the Citrix Viewer pops up, if I close the Citrix Viewer, a quick blue, "Windows Server 2012 R2" window pops up and goes away.  Would there be anything on her Mac I would need to download, plug-in or configure for the Windows Server thing?

 

I think, in the end, there is just something wrong with the icons in the specific folder!  Luckily, with access, she can use another icon, that DOES launch and she get what she needs.



Donsha Jackson Members
  • #12

Donsha Jackson
  • 4 posts

Posted 20 April 2017 - 04:58 AM

Hello,                                         

 

I also work for a hospital and am trying to log into my workstation. I am on macOS Sierra Version 10.12.4 and just installed the newly released Java 8 Update 131; and now I am unable to remote into my desktop at work.  Now, Java just spools and the Citrix receiver does not pop up but gives the following 'Application Error:'

 

SecurityException: attempted to open sandboxed jar https://remote.dekalbmedical.org/Citrix/AccessPlatform/Clients_common/Java/JICA- coreN.jar as a Trusted-Library

 

I downloaded both the latest Java 8 Update 131 and the Receiver 12.5 for Mac - Centrix

 

If anyone have any ideas of what can be precluding the Java and Centric receiver software to pop-up, please let me know.