Jump to content


GE Centricity TWAIN Scanning & Webcam issues - XenApp 7.8

Started by Tom Swift , 20 March 2017 - 10:16 PM
2 replies to this topic

Tom Swift Members

Tom Swift
  • 170 posts

Posted 20 March 2017 - 10:16 PM

Having some issues with an application from GE named Centricity Practice Solution version on 2012 R2 and XenApp 7.8


Error when trying to scan using TWAIN scanner (either Fujitsu or Xerox) - Works using TWACKER

- Tried copying TWAIN_32.dll from C:\windows to c:\users\testuser\windows -- fails to scan


Access to WebCam doesn't work either, where camera screen shows black and you click take picture and it does, but you can't preview the picture.  Tried testing using YAWCAM but having problems running YAWCAM on 2012 R2 (works on 2008 R2).


Reached out to GE and opened a ticket because it supposedly works with TWAIN but so far we're guessing Centricity is an application that's not Terminal Server aware and has issues scanning using TWAIN scanner.

Natalie Martorell Citrix Employees

Natalie Martorell
  • 5 posts

Posted 21 March 2017 - 09:47 PM

Hi Tom, 


I've seen Centricity webcam issues before, try reproducing your issue with a 7.12+ or 7.6.3000 LTSR test VDA, it should work properly on those versions.

Tom Swift Members

Tom Swift
  • 170 posts

Posted 24 March 2017 - 10:34 PM

This fixed TWAIN scanning...



c:\Program Files (x86)\Kryptiq Corporation\Document Management\Indexing Client\indexingclient.exe.config
Find the elements: add under the appsettings element and modify:
<add key="EnableLoggingForScan" value="false" />
Change the value to true
<add key="EnableLoggingForScan" value="true" />
Save the file and relaunch the indexing client from that server.