Jump to content


Photo

Unable to open Citrix Studio when one DDC is offline

Started by Paul Tanner , 20 March 2017 - 07:23 PM
6 replies to this topic

Paul Tanner Members

Paul Tanner
  • 2 posts

Posted 20 March 2017 - 07:23 PM

I am currently standing up a new 7.13 environment to test some new features.   We will be migrating to it within the next 3 - 6 months.   I am having an issue where if a certain delivery controller is offline I cannot open up Studio on the other 3 controllers.   We have a total of 4 (2 in each site).   I have rebooted everything, including th DB, and still cannot get it to open.   Any suggestions?



Andreas Schulz Members

Andreas Schulz
  • 37 posts

Posted 21 March 2017 - 05:10 AM

What do you mean with "Unable to open Studio"?

Any (error) messages?



Joe Deller Citrix Employees

Joe Deller
  • 145 posts

Posted 21 March 2017 - 10:40 AM

Hi Paul,

 

this could be a number of things, it would be useful to know what error message / event log messages you are seeing.  It could be one of the required site services is not running on the other controllers.

 

One thing to try would be to take down 2 of the remaining controllers, leaving a single one up, then reboot that.  If that is OK and you can start studio, then bring up the others.

 

One controller is the primary, if it goes down, there should be an election and an event log message showing this.

 

Are sessions still brokered by the other controllers ?



Paul Tanner Members

Paul Tanner
  • 2 posts

Posted 21 March 2017 - 12:49 PM

I did notice that if all 4 DDCs are in the primary zone then I have no issues opening up Studio when any of them are offline.  If I move 2 of them to a satellite zone and power off the 2 that remain in the primary zone I cannot open Studio on either of the DDCs in the satellite zone.   Is this intended? 

 

The Studio application sits at the "Expand" window and eventually opens up with an error about the configuration service.  I have tested the DB connection from the satellite zone and have no issues connecting. 

 

"The Delivery controller address has changed

 

Reenter the Controller address or enter a new address

 

Existing controller address

Localhost"

 

 

I am also not seeing any event about an election process.



Joe Deller Citrix Employees

Joe Deller
  • 145 posts

Posted 21 March 2017 - 03:08 PM

Unfortunately at the present time, there must be at least controller up in the primary zone. 

The config logging service is dependent on the primary zone being available.  There was a change made somewhere around 7.8  due to performance issues (config logging is quite "chatty") with studio in a secondary zone that had more than a certain amount of latency back to the database.

 

I'll have a look to see if there are any plans to improve on this.



William Fulmer Members

William Fulmer
  • 131 posts

Posted 14 October 2017 - 03:48 PM

Unfortunately at the present time, there must be at least controller up in the primary zone. 

The config logging service is dependent on the primary zone being available.  There was a change made somewhere around 7.8  due to performance issues (config logging is quite "chatty") with studio in a secondary zone that had more than a certain amount of latency back to the database.

 

I'll have a look to see if there are any plans to improve on this.

 

 

Joe - any update on this?



Joe Deller Citrix Employees

Joe Deller
  • 145 posts

Posted 16 October 2017 - 09:55 AM

Hi William,

 

unfortunately not, this is in the issues database as a customer reported problem, but isn't currently targeted for any release, as part of a review last week.

If people raise a support ticket, that might bump the priority.