Jump to content


Photo

Published Desktop won't go to full-screen mode on dual screens

Started by Cindy Vickers , 16 March 2017 - 10:28 PM
3 replies to this topic

Cindy Vickers Members

Cindy Vickers
  • 5 posts

Posted 16 March 2017 - 10:28 PM

Hello,

 

We have an intermittent issue in our new XenApp 7.7 environment.  We use Dell thin clients running Windows 7 Standard Embedded 32-bit and Citrix Receiver 4.4.1000.16.  Our user logon to Hosted Shared Desktops running Windows Server 2008 R2.

 

When moving from a thin client with one monitor to a thin client with dual monitors the session doesn't maximize across the two screens every time and instead the session seems to be in Windowed mode instead of full-screen mode with scroll bars down the bottom and side.  The mouse click is also out of alignment and when clicking the actual click is processed in a different spot in the session. 

This is not a thin client issue as I replicated the issue on two desktops connecting to our storefront.

As a workaround users are able to use a Shift and F2 and the screen maximizes across the two screens and they can work again.

 

I have tried the following:

Tested with Citrix Receiver 4.5 - same issue

Increased the Display memory limit from default 65536KB to 98304KB - no change

Found this article that describes our issue:

https://support.citrix.com/article/CTX138197

'If users start a desktop session in full-screen mode and the Desktop Viewer is disabled, scroll bars might appear when plugging in a second monitor'

Added reg key as per document on thin clients but no change:

 

HKEY_LOCAL_MACHINE\Software\Citrix\ICA Client

Name: ProcessWM_SETTINGCHANGE

Type: DWORD

Value: 1

 

Suggestion in article says if this doesn't work then also add this reg key but I didn't know what value to set:

 

HKEY_LOCAL_MACHINE\Software\Citrix\ICA Client

Name: MonitorLayoutUpdateDelay

Type: DWORD

Value: 0 to 4 (default value is zero)

 

Any suggestions? 

 

 

 

Attached Thumbnails

  • Dual screen scroll bars.png


See tricks10 Members

See tricks10
  • 376 posts

Posted 17 March 2017 - 07:48 PM

r u using storefront or WI ?

 

perhaps this is applicable.

https://support.citrix.com/article/CTX139762

 



Cindy Vickers Members

Cindy Vickers
  • 5 posts

Posted 18 March 2017 - 09:58 AM

Thanks for the suggestion. We are using Storefront. I had already tried that but it didn't make any difference. I think it's because desktop viewer is set to false in the webconfig file anyway so I'm not sure that setting will have any effect. Desktop Viewer is not recommended for XenApp only XenDeskop apparently.

Marco Zimmermann Members

Marco Zimmermann
  • 402 posts

Posted 22 March 2017 - 03:42 PM

Hi Cindy,

 

is using DesktopViewer not an option for you?

You can set

HKLM\SOFTWARE\Wow6432Node\Citrix\XenDesktop  FSOMode=dword:1

to always launch in fullscreen and hide switch to local client in toolbar.

 

Marco