Jump to content


Photo

Session Recording causes Image preparation finalization Failed error

Started by Todd Dunwoodie , 15 March 2017 - 07:08 PM
2 replies to this topic

Todd Dunwoodie Members

Todd Dunwoodie
  • 17 posts

Posted 15 March 2017 - 07:08 PM

I am running XD 7.11 on AWS.  I am deploying several Windows 8.1 images with VDA 7.11.  Image preparation works fine until I install Session Recording.  Once SR agent is installed I get the "Image Preparation Finalization Failed" error.  The InternalErrorMessage: Image Preparation did not complete.  Status 'NotSet'.

Has anyone else seen this?  I have tried uninstalling VDA, deleting c:\programdata\citrix, and reinstalling VDA.  I have tried SR agent 7.13 but get the same issue.  

 

I have also tried imageprep logging but it only appears to show a timeout, no particular errors.

 

 



Todd Dunwoodie Members

Todd Dunwoodie
  • 17 posts

Posted 17 March 2017 - 02:48 PM

I was able to fix this.  I had to set the Citrix Session Recording service to delayed startup.  I was then able to push the image to catalogs.  I also tested and Session Recording is working correctly.



Paul Howard Citrix Employees

Paul Howard
  • 66 posts

Posted 21 March 2017 - 01:59 PM

Hi, Todd.

 

An issue with MCS image preparation related to MSMQ (hence session recording) was discovered and fixed in the 7.12 release. It matches the symptoms that you describe. You would need to be using 7.12 or later of the Citrix VDA to have the fix.

 

All the best,

Paul.