Jump to content


Photo

Server 2016 UPM & Start Menu...

Started by Phil Taylor , 21 February 2017 - 11:33 PM
6 replies to this topic

Phil Taylor Members

Phil Taylor
  • 16 posts

Posted 21 February 2017 - 11:33 PM

I've been fighting the start menu in a server 2016 XenDesktop 7.12 environment for what feels like an eternity! its starting to feel like one problem is fixed and another breaks.

 

I am currently stuck at a point were this could stop this project in its tracks. I now have the profile deleting at log off and all settings roaming, however the customer would like the ability to customize the tiles, so to allow this to sync

 

AppData\Local\TileDataLayer\Database

 

however this allows tile roaming but then the start menu search feature stops working, and the only way to reliably get this working is to exclude the above! 

 

Has anyone come across this and managed to resolve? Server 2016/UPM seem to just be full of bugs and issues, and it feels very much like this combination is just not production ready!

 

 



Goran Plavsic Members

Goran Plavsic
  • 6 posts

Posted 22 February 2017 - 09:07 AM

Hello Phil,

 

we have the same troubles on Server 2016 with UPM 5.5 and 5.6 on different environments. The issues are as follows:

 

- Loading of start menu very slow

- Sometimes users can't load start menu (it is empty or not complete loaded)

- Pinned apps are sometimes not available, sometimes users have other apps pinned automatically (like server manager, mstsc, ..)

- search in start menu is sometime working and other times the searched apps are not listed

 

We tried different scenarios:

- with start menu redirection and without redirections

- different settings in the UPM policies

 

We opened yersterday a case and I hope we can solve the issue asap.



Andrew Sommerer Members

Andrew Sommerer
  • 67 posts

Posted 28 February 2017 - 06:43 PM

I'm working on the same thing as well and having issues with Server 2016. In my setup I opted for the Group Policy Start Layout to provide users with a preconfigured partial tile Start menu. This appears to work smooth initially but after several logins on the same machine all the pins disappear which seems odd since I'm using the Group Policy to apply some of the pins.

 

I know in the XenDesktop 7.13 release there was something in the UPM 5.7 that was supposed to address the Start Menu, but am not certain if it actually fixes the issue. I also recall that CarlStalhood updated his site carlstalhood.com with some information in regards to the Start menu and tiles that I'm testing right now to see if that fixes my issue. Might be worth glancing at. I know he has a wealth of knowledge out there that he keeps fairly up-to-date.



Phil Taylor Members

Phil Taylor
  • 16 posts

Posted 17 March 2017 - 05:04 PM

I've tested 5.7 with VDA version 7.13 and things are greatly improved. The Start menu search also appears to be solid and working but on with profiles created after the 5.7 & 7.13 update. If the users profile is reset this corrects the problem, but i would rather clear this out the exiting profiles, anyone have any ideas why this might live?



Jason Simes Members

Jason Simes
  • 3 posts

Posted 22 March 2017 - 06:12 AM

Hi Guys,


​This might help someone out there, yes the 2016 StartMenu is extremely buggy, mostly due to the TilelayerDatabase and the Packages Folder located in Appdata\local.

​It appears that this database corrupts very easily, or the Start menu has issue's accessing or activating the Shell Experience or Cortana Components, you can see these errors in the Applications and Service Logs > Microsoft > Windows > Apps > TwinUI/Operational, this is where the freezes come from.

 

My best and most consistent scenario is the following, Exclude Appdata\Local, more importantly the packages and tilelayerdatabase, Grab a working copy of the tilelayerdatabase and place this in the appdata\local, this way its never synced back, to make this a little more solid add the XML start layout policy.

​I do still get occasional freezes 4 seconds, but the experience is consistent and search still works.

 

Hope this helps someone.

 

Fyi, I'm using 5.7 and 7.13

 

 



Domenic Alvaro Members

Domenic Alvaro
  • 44 posts

Posted 24 March 2017 - 12:31 AM

I'm using UPM 5.7 and XenApp 7.13 on Server 2016 and issues with the Start menu are definitely an issue for me.

 

For me, the Start menu may or may not work at all.  Sometimes I see the start menu, but no tiles.  Obviously, this is a widespread issue.

 

The UPM notes state that there are known issues with the Start menu, but the workarounds don't appear to resolve the issue for me.

 

I'm just wondering if any of you have feedback from Citrix about whether this is being actively investigated and what sort of timeframe we're looking at.

 

Thanks,

 

Domenic



Dennis Reimer Members

Dennis Reimer
  • 16 posts

Posted 24 March 2017 - 08:06 AM

Same issue here. We have several customers with this issue and no real solution (except using classic shell start menu). I have heard from one of our Citrix contacts, that Citrix is working on this issue, you can open a Support Ticket with reference to Issue-ID (UPM-377). 

 

To be fair, from my point of view it´s not a Citrix issue. The Windows 10 and Server 2016 Startmenu is really hard to administer. 

 

Regards

 

Dennis