Jump to content


Photo

PVS Target Device x64 Upgrade From 7.8 to 7.12

Started by Simon Hess , 02 February 2017 - 04:55 PM
6 replies to this topic

Simon Hess Members

Simon Hess
  • 5 posts

Posted 02 February 2017 - 04:55 PM

Upgrade fails right after the beginning of the installation and rolls back any customization. No on-screen error message is being presented. I have reverse-imaged the target device golden image according to several best-practice articles. The previous upgrade from 7.1 to 7.8 did not cause any problems during the installation. Please find attached the installation log file for further investigation. Ideas, suggestions, anything?



Simon Hess Members

Simon Hess
  • 5 posts

Posted 02 February 2017 - 05:10 PM

As mentioned the attached log file. Sorry for the inconvenience.

Attached Files



Carl Stalhood CTP Member

Carl Stalhood
  • 11,954 posts

Posted 02 February 2017 - 07:22 PM

Maybe this? https://theorypc.ca/2016/04/12/silent-install-of-citrix-pvs-target-device-software/



Simon Hess Members

Simon Hess
  • 5 posts

Posted 03 February 2017 - 08:04 AM

That does not do the work for me. PowerShell throws the following error message during the installation: "PVS-Device_x64.exe exited with error code 1603."



Sacha Thomet CTP Member

Sacha Thomet
  • 209 posts

Posted 03 February 2017 - 09:38 AM

Is you PVS Server already 7.12?



Simon Hess Members

Simon Hess
  • 5 posts

Posted 03 February 2017 - 09:40 AM

Yes, PVS Server & Console is already on version 7.12.



Simon Hess Members

Simon Hess
  • 5 posts

Posted 03 February 2017 - 01:01 PM

Although this is not best practice, I have performed an in-place update of the Target Device and the VMware Tools. To clarify I created a new version of the vDisk and updated the software directly. This procedure worked like a charm, no error messages whatsoever. 

 

However, the original problem persists. If I boot into the VHD as described in Carl's Reverse Image documentation, the PVS TS software can be uninstalled, but it is not possible to install it again. I have tried both versions, 7.8 as well as 7.12, same error.