Jump to content


XA 7.11 - two instances of a Published App launch for 5 seconds then disconnect

Started by David Dunt , 26 January 2017 - 04:10 PM
3 replies to this topic

David Dunt Members

David Dunt
  • 1 posts

Posted 26 January 2017 - 04:10 PM



I've experienced a very strange issue while deploying a new XA 7.11 environment. Basically when a users launches a published application (i.e. Notepad) the application will launch successfully but will then disconnect 5 seconds later for no reason. A disconnect session can be seen in Studio/Director.

Further troubleshooting I found that when published app is launching it opens 2 instances of the published application before disconnecting. (Attached) I'm not sure if this is causing the disconnect?


Being trawling throw the forums for a while now trying fixes, added all the usual regkey timeouts settings etc.. to try resolve issue but nothing has worked so far. It affects all published apps and published desktops, tried multiple different VDAs on different OS etc... Nothing in the event logs :-z


Anyone seen this before?


DDC - 7.11

SF - 3.6

VDA - 7.11 (tried 7.12 same issue)

XenServer 7

klspro001 Members

Maryann Hanley
  • 2 posts

Posted 19 April 2017 - 05:56 PM

Just wanted to see if you found a fix for this. We are having the same issue on some of our VDAs after deploying from a template. 2012 R2 7.11, two instances of an app appear then disappear and the session goes to disconnected.

Joe Brozzetti Members

Joe Brozzetti
  • 180 posts

Posted 19 April 2017 - 06:54 PM

Probably a long shot but you can try setting the multi-click timeout in the web config to a longer setting, something like 30 seconds just for testing.


<userInterface autoLaunchDesktop="false" multiClickTimeout="30"



Does it happen with Web and Full Receiver?

Alex Corelis Members

Alex Corelis
  • 2 posts

Posted 19 April 2017 - 07:02 PM

I had this issue, which appears to be caused by templating and using the dell KACE agent.  Checking the userinit registry key had two entries.  Removing one solved this for me.


reference: http://www.freetechanswers.com/2010/04/citrix-applications-opening-twice-when.html

Also tagged with one or more of these keywords: Duplicate Instances, xa7.11