Jump to content


Photo

PVS - Server 2016 - UEFI - BlueScreen on Boot (CVhdMp.sys )

Started by Panteraa , 06 January 2017 - 06:35 PM
8 replies to this topic

Panteraa Members

Wolfgang Germ
  • 31 posts

Posted 06 January 2017 - 06:35 PM

Hello,

 

I'm jut playing around in my lab with XA7.12, Server 2016, PVS 7.12 & UEFI.

The lab is running on Hyper-V.

 

I want to get a Server 2016 Golden-Image.

 

I have created a Gen.2 VM (UEFI), disabled SecureBoot, installed Server 2016, joined the domain and installed the PVS-target-device software.

I have captured the image without problems. I add the vDisk to a Gen.2 VM and boot it. The VM stops with a bluescreen displaying the Error "CVhdMp.sys - System Thread Exception not handled". (see the screenshot)

 

BootError.PNG

 

What i have tried on Capture-Machine:

- Disabled the Windows Firewall

- Disabled Windows Defender which is included in Server 2016

- Disabled IPv6 (DisabledComponents = ff)

- Disabled all Offloading on NIC

- Disabled Task-Offload through registry

...

 

What am I missing?

 

Thank you



Carl Fallis Citrix Employees

Carl Fallis
  • 984 posts

Posted 06 January 2017 - 07:48 PM

PVS only support Gen 2 VMs when you are using the XDSW.  You can not just use any Gen 2 VM it has to be created using the XDSW, there are ways to get around this but I am not going to try to explain it here.  Try creating the VM using XDSW.



Panteraa Members

Wolfgang Germ
  • 31 posts

Posted 06 January 2017 - 08:59 PM

Just had a look on the Wizard.

I think I am not able to run this in my lab ... :(



Carl Stalhood CTP Member

Carl Stalhood
  • 11,935 posts

Posted 06 January 2017 - 10:16 PM

How to Manually Create Hyper-V GEN2 Provisioning Services Target Devices - https://support.citrix.com/article/CTX216823

 

Also see https://theorypc.ca/2016/12/30/lets-make-pvs-target-device-booting-great-again-part-1/



Panteraa Members

Wolfgang Germ
  • 31 posts

Posted 06 January 2017 - 10:40 PM

Thank you, I will have a look at this.

 

In the meantime I switched back to the old method. (Gen.1 VM with legacy nic)

Compared to capturing the Gen.2 VM before the performance is laughable ;-)

The Gen.2 VM got captured in about 5-10 min.



Panteraa Members

Wolfgang Germ
  • 31 posts

Posted 07 January 2017 - 09:40 AM

The Target-Device finally booted up with the magic of the "pvsgen2.ps1" script.

The performance is great.

 

Thanks for pointing me in the right direction.



Øyvind Åsebøstøl Members

Øyvind Åsebøstøl
  • 9 posts

Posted 30 January 2017 - 01:51 PM

I have the same problem only I'm running XenServer 7.0 with all the latest patches including patch 25. I've set up a clean 2016 vm and run the imaging wizard. I've tried creating both vhd and vhdx. The imaging works fine, but when I try to boot a vm on this image i get the same bluescreen  with the error CVhdMp.sys - System Thread Exception not handled.

Any ideas ? With Xenserver there is no Gen1 / Gen2 ?

 

Funny thing is I have a working image based on 2016 and pvs 7.11 and xenserver tools version 7.1.814, which works fine. .

I'm creating a new image to get the xentools upgraded.

 

Øyvind



SKlopp Members

Stefan Klopp
  • 57 posts

Posted 30 January 2017 - 05:50 PM

Did you install the xenserver-tools before or after the pvs target device driver?

As far as I remember it is important to install the xs-tools, which install the nic-driver, before.

What else did you do before you captured the image?



Anjali a Members

Anjali a
  • 2 posts

Posted 09 May 2017 - 06:34 PM

I am also struggling with capturing the vdisk for Gen2 machine (mater image running on Hyper-V 2012 R2) but after running the imaging wizard but when I try to boot the machine with BDM disk, server is connecting to PVS server , shows the vdisk but gets into BSO "PC ran into problem...." and keeps on rebooting. Have also tried with https://support.citrix.com/article/CTX216823 which adds PVS streaming NIC to the Machine but same error. I was able to boot it on POC but getting failed in Prod implementation. 

 

Provisioning Service 7.12 with XenDesktop 7.12 -All Windows 2012 R2 environment.