Jump to content


Office license error after upgrade to VDA 7.9

Started by Steven Blomme , 15 September 2016 - 11:46 AM
53 replies to this topic

Steven Blomme Members

Steven Blomme
  • 23 posts

Posted 15 September 2016 - 11:46 AM



Recently I've upgraded the VDA from 7.8 to 7.9 on a number of servers in our production enviroment, to fix the following bug (a known fixed issue in VDA 7.9):

The "Auto-create client printers" policy might fail to set default printers correctly in a published application and Microsoft XPS Document Writer is set as the default printer.




Sadly after the upgrade another issue presented itself.
At random times, when opening a Microsoft Office program the users would get the error shown in the attachment 'license-error.png'.


After some research I noticed that the user gets this error whenever the Software Protection service crashes.
The service seems to reach its startup time-out of 30 seconds and crashes.


Eventually I used ProcMon to see why this service needs such a long time to start.
I noticed a lot of references to the folder c:\windows\system32\catroot and I saw this for up to 30 seconds. See also the attachment 'procmon.png'.


I then restored a production server with VDA 7.8 from our backup and saw that when I used procmon there were no references to this catroot folder at all.
So for some reason the after the installation of VDA 7.9 the software protection service scans the catroot folder at startup, resulting in a crash of the service because the time-out of 30 seconds is reached.


To make sure there was no difference between the restored server and a server in our production environment I downgraded our servers back to VDA 7.8 and now the license error does no longer occur. Also the catroot folder does not show up in procmon (in reference to sppsvc.exe) anymore.



Has anyone else run into this problem?

Any help will be greatly appreciated :)!

Attached Thumbnails

  • license-error.png
  • procmon.png

Carl Stalhood CTP Member

Carl Stalhood
  • 11,940 posts

Posted 15 September 2016 - 11:53 AM

Same problem on VDA 7.11?

Steven Blomme Members

Steven Blomme
  • 23 posts

Posted 15 September 2016 - 12:13 PM

Same problem on 7.11. 



Raphael Hoff Members

Raphael Hoff
  • 10 posts

Posted 15 September 2016 - 12:22 PM

Hey Steven,

i recognized exakt the same Issue after upgrading our farm from XD 7.6 to XD 7.9 same with the PV Services, unfortunately i also upgraded and updated our VDI Masterimage with the new MS Updates and Fixes.So I was not sure about the cause of this Issue.

After an investigation i located, that the MS Updates changed the Version of sppsvc.exe,however our Antivir Tool (Trendmicro/Deepsecurity) prevent the start operation of the SoftwareProtectionService.

After deactivating the AVTool, their was no issue anymore with the KMS registration.




Steven Blomme Members

Steven Blomme
  • 23 posts

Posted 15 September 2016 - 12:32 PM

Hi Raphael,


we have tried the setup without AV and the same problem. We have the problem on completely new installed servers.


Server + VDA 7.8 -> is ok but has print issue


Server + VDA 7.9 -> fixes print issue but generates office license problem


Server + VDA 7.11 -> same problem as in 7.9


Remove VDA 7.9 and go back to 7.8 resolves the office license problem again..


Citrix support says we have to contact Microsoft...


On wich VDA version are you running?



Raphael Hoff Members

Raphael Hoff
  • 10 posts

Posted 15 September 2016 - 12:41 PM

Hi Steven,


we are running on Version


Do you have this Issue with any other services?

Steven Blomme Members

Steven Blomme
  • 23 posts

Posted 15 September 2016 - 01:02 PM

Hi Raphael,


The issue does not seem to occur with any other services (as far as I know).

Just to be clear (because I just saw that I did not specify this) this is on a Server 2012 R2 with VDA for Server OS.

CLB ICT Members

  • 2 posts

Posted 20 September 2016 - 03:16 PM


right down to the ProcMon observations.


Every few service starts (or when it was stopped long enough, so it seems), the service is doing some kind of iteration of everything in the catroot folder. I've not been able to pin down what exactly triggers it, or why it does so.


It's a big problem for our users; I've opened a case, hope they find a solution for this soon.

Steven Blomme Members

Steven Blomme
  • 23 posts

Posted 21 September 2016 - 10:35 AM



Thanks for your response, good to know I'm not the only one with the issue.

Currently I also have a case open. If I hear anything I will let you know.

Marco Zimmermann Members
  • #10

Marco Zimmermann
  • 403 posts

Posted 12 October 2016 - 12:54 PM

Hi guys,


we also updated 7.5 to 7.9 - when a user loggs in there is a ~20s black screen.

Procmon also shows thousands of queries to \catroot - Folder in this time.


Please let me know if you got a solution.




Chris Conkright Members
  • #11

Chris Conkright
  • 3 posts

Posted 12 October 2016 - 02:09 PM

This also happened to us after the upgrade from 7.7 to 7.9.  We had a snapshot we could rollback to, thankfully. Just replying in case someone gets an answer from Citrix.  I haven't had a chance to call yet about this.  I have had too many other production bugs that they have been fixing.  :sigh: I long for the days of the simple Secure Gateway and XenApp 6.5.

Marco Zimmermann Members
  • #12

Marco Zimmermann
  • 403 posts

Posted 12 October 2016 - 02:43 PM


can you please test a logon with appxsvc and wsservice disabled?


Set these keys to dword: 4




Reboot your server.


This is NOT a solution, i just want to know if thats the cause for these delays.



Ludwig Riess Members
  • #13

Ludwig Riess
  • 5 posts

Posted 18 October 2016 - 11:21 AM

Same issue in this topic: XA 7.6 Deployment Failure Error : Image Preparation Office Rearm Count Exceeded


Hey Steven Blomme, CLB ICT

any news regarding your open case?

Steven Blomme Members
  • #14

Steven Blomme
  • 23 posts

Posted 22 October 2016 - 12:03 PM

@Marco, thank you for the suggestion.
I will try to test this later today and will send you an update.


@Ludwig: The case has been escalated and I got a question for more logs earlier this week.
I will try to send them the logs as quickly as possible so they can further analyze this.



I've also been able to test out the new VDA 7.6 CU2, and at first sight I do not see any catroot references when using procmon.

I will try to test this new VDA in our live environment later this week.
With some luck this will finally fix our original printer issue and not cause the office license error or any other problems instead.

Steven Blomme Members
  • #15

Steven Blomme
  • 23 posts

Posted 22 October 2016 - 01:42 PM


The office issue is not resolved by disabling the mentioned services.

Peter Doesberg Members
  • #16

Peter Doesberg
  • 2 posts

Posted 13 December 2016 - 02:27 PM

is there an fix  for the office license problem with the VDA 7.9?? 


  • #17

  • 37 posts

Posted 13 December 2016 - 06:18 PM

We were experiencing a very similar problem in our environment, turned out the issue was actually on our KMS server. It needed a special key that had to be installed through a different management tool so that the server was able to authenticate Office2013 clients. Windows (7 and 10) authentication was working correctly and the Office 2013 key was listed in the main KMS management app on the server. Just FYI.

Douglas Holdgrafer Members
  • #18

Douglas Holdgrafer
  • 23 posts

Posted 04 January 2017 - 05:14 PM

Has anyone found a solution to this? We are encountering the same problems with the black screens at logon as well as Office activation issues due to the Software Protection Service. 



Manbinder Pal Singh Citrix Employees
  • #19

Manbinder Pal Singh
  • 826 posts

Posted 04 January 2017 - 05:21 PM

Have you tried 7.12 VDA which is the latest release as of today? See if it fixes.

Douglas Holdgrafer Members
  • #20

Douglas Holdgrafer
  • 23 posts

Posted 05 January 2017 - 03:34 PM

The license error was resolved using this MS article:




It increased the timeout period allowed for the Software Protection service to start. 


We are still having issues where the AppDisk gets stuck on "creating" after we install Office on the base image though. I believe at this point it is unrelated to the activation issues for Office since the slmgr errors aren't in the PVD logs any longer. Right now we are using a snapshot without Office to create AppDisks. I don't really want to do this since certain integration points occur with Office and I'm not sure if it may cause other problems down the line for add-ins, etc. if we install applications without Office on the base when profiling the AppDisk.