Jump to content


Photo

Citrix receiver for iOS and Thursby PIV reader TSS-PK7

Started by James Hill , 28 July 2016 - 07:28 AM
7 replies to this topic

James Hill Members

James Hill
  • 4 posts

Posted 28 July 2016 - 07:28 AM

When I try to add a profile in Citrix Receiver, after I enable "use smart card", I get the prompt (please connect your smart card reader to continue). I used the same Veterans Affairs website to load a profile successfully to log in via domain/user/pass. My card reader works with Thursby's Sub Rosa (3.0.0), emulating IE 11 browser and I can log in via PIV, but I can't run the applications because they require Citrix to run, so I'm stuck.

Mark Young Citrix Employees

Mark Young
  • 106 posts

Posted 28 July 2016 - 02:04 PM

Hello James,

 

Can you please send us the receiver debug logs for you failed connection. Instructions are in the lnk below

 

Also, can you please answer the following:

 

What version of iOS are you running?

What version of Citrix receiver are you using?

Does this issue occur if you use the R1 receiver (located in the App Store)?

 

 

I am looking forward to helping you resolve this issue.

 

Thank You,

Mark



Mark Young Citrix Employees

Mark Young
  • 106 posts

Posted 29 July 2016 - 02:20 PM

Hello James,

 

Please test CR Receiver 7.0.2 that was released to the App Store yesterday. 

Kindly advise if you are still experiencing the connectivity issues you described in your first post. 

 

Thank you



James Hill Members

James Hill
  • 4 posts

Posted 04 August 2016 - 10:59 AM

Upgrading did not work. Where is the link to provide the debug data? I know how to do it through iTunes, but not while the card reader is using the lightning port, so I will need some instructions.



Mark Young Citrix Employees

Mark Young
  • 106 posts

Posted 08 August 2016 - 02:08 PM

James,

 

Please use the below link for instructions on how to gather receiver logs. 

 

http://support.citrix.com/article/CTX136380

 

 

Thank You



William Picek Members

William Picek
  • 3 posts

Posted 04 August 2017 - 11:24 PM

I have this same issue works in Sub Rosa but Citrix doesnt see it so guessing the TSS PK7 isnt supported?



William Picek Members

William Picek
  • 2 posts

Posted 11 August 2017 - 02:35 PM

So I actually got this to work, if you use SubRosa and go the Citrix front end page you can select the Citrix application and an open with will popup and from there can select open with Citrix Recevier the only issue is it passes your authencation session but wont pass you certificates pass the subrosa due to Citrix not supporting the Thursby SDK.

Anyway to support the Thursby SDK inside of Citrix?

James Hill Members

James Hill
  • 4 posts

Posted 12 August 2017 - 02:24 PM

The VA recently upgraded the VPN service it was using and I found similar successes that William also experienced. And also like William, I also was not able to open the "apps" either. On the desktop computer, this process follows with a PIN prompt, then it seems to log into the VPN server and prompts for a PIN again before opening the "app."