Jump to content


Photo

Sessions Freezing with Receiver 4.4.0.8014

Started by Matthew Dodd , 16 February 2016 - 08:11 AM
69 replies to this topic

Best Answer Etienne Coppin , 28 September 2016 - 08:30 PM

I confirm after 1 week of usage on my laptop (connection through Internet & Netscaler only) no more freezing issue on my laptop with 4.5. Now i will work exclusively one week on my thin client (through direct Wan connection). If freezes occurs through the Wan and not through Internet connection, it's probably network related somewhere ......

Matthew Dodd Members

Matthew Dodd
  • 69 posts

Posted 16 February 2016 - 08:11 AM

Anyone noticing sessions freezing with the 4.4.0.8014 Windows Receiver client?

 

We've seen this gradually increasing when connecting to XenApp 6.5 servers, and it's more likely to happen at larger resolutions.

 

It's now turning up across a number of Windows clients (known to be Windows 10, possibly Windows 7 but not confirmed).

 

Is it just us?



Sacha Thomet CTP Member

Sacha Thomet
  • 208 posts

Posted 16 February 2016 - 08:55 AM

I cannot confirm any inconvenience with Receiver 4.4 according freezing. I work from a Win7 Device on a Win10 VDI on which I start VDI's and XenApp 6.5 Applications. 



Carl Stalhood CTP Member

Carl Stalhood
  • 11,931 posts

Posted 16 February 2016 - 01:31 PM

Internal directly to the VDA? External through NetScaler Gateway? Or both?

Cindy Oakley Members

Cindy Oakley
  • 3 posts

Posted 17 February 2016 - 08:01 PM

I have run into this same freezing problem with Receiver 4.4 only.  We have published an application and if we enter a portion of the application that uses high resolution maps it will freeze up the Receiver.  Even if I am in Windows Remote Assistance (which is also a published application of ours we utilize to shadow our users), it will freeze up my Receiver just viewing their session, but their old version of Receiver is still working just fine on their end in the actual application with high resolution maps.  

 

I can reproduce this over and over on both Windows 7 and Windows 10. 

 

We run everything through a NetScaler Gateway with XenApp 6.5.



Stefan Wendrich Members

Stefan Wendrich
  • 215 posts

Posted 18 February 2016 - 04:27 PM

Hi,

please, open also a case by Citrix and reference to our case SR# 70786775. Citrix needs much more traces.
The case is by the development team of receiver 4.4, now.

Can you please assist us in capturing below information:
1. Though case documentation state issue occurs with Windows 7 / Receiver 4.4 have we tested this scenario with Windows 8 / Receiver 4.4 on same or different workstation ?
2. Can you please provide hardware information for Windows 7 machine
3. If you are using multiple adapters, please provide their make and model.
4. HDX Monitor Reports and logs for receiver 4.3 and 4.4
5. Receiver logs from 4.3 using receiver diagnostic tool.
6. Three sets of CDF Traces from XA server – one while using receiver 4.3, second while using receiver 4.4 in a working scenario and last with using receiver 4.4 in a non-working scenario.

For receiver 4.3
· Run HDX Monitor and point it towards XA server on which session is established.
· Go to HDX Monitor Settings and Logging - Configure it with C:\Hdxmonlogs.txt.
· Close and reopen HDX Monitor. Make sure it is pointing towards correct XA server.
· Open Receiver for diagnostic tool and configure settings with trace level as Verbose, log size 500 and select all modules.
· Open CDF Control on XA server, go to options and select multiple sequential logs. Please select all modules under trace categories.
· Start tracing on XA server using CDF Control and on client machine using receiver for diagnostic tool.
· Run SAP GuiXT application.
· Once application has opened, stop tracing on client as well as on XA server.
· Go to HDX monitor > click generate Report > Save Report.
· Close HDX monitor and rename C:\Hdxmonlogs.txt to C:\Hdxmonlogs_4.3.txt.

Felix Wueest Members

Felix Wueest
  • 166 posts

Posted 01 March 2016 - 02:37 PM

Hi

Same Problem here.

Published Applications on XenApp 6.5 HRP6, connected by Netscaler 10.5.60.7 ond Storefront 2.6 and also on XenDesktop 7.6, VDA 7.6.300 (same Netscaler, Storefront Versions).

Can be reproduced when you start IE11, Google maps in Satellite mode, zoom in/out -> freeze.

Application must be completed on the local TaskManager, AppCenter has no Connection.

Local Eventviewer:

Error 1002; Application Hang; The program wfica32.exe version 14.4.0.8014 stopped interacting with windows and was closed. .....

Stefan, any news from your Case 70786775 ?

 

Regards, Felix



Matthew Dodd Members

Matthew Dodd
  • 69 posts

Posted 01 March 2016 - 02:58 PM

We're on HRP04 for what it's worth, along with hotfix XA650R03W2K8R2X64024.

 

I hadn't noticed eventlog messages but hadn't looked for them either.

 

Regards

Matthew



Stefan Wendrich Members

Stefan Wendrich
  • 215 posts

Posted 01 March 2016 - 05:30 PM

Hi Felix,

 

sorry we have no new news. Our customer has no time to collect the traces. The users are angry and dont want go back to receiver 4.4.

 

Can you contact citrix and reference to my case number ?



Felix Wueest Members

Felix Wueest
  • 166 posts

Posted 02 March 2016 - 07:14 AM

Good Morning Stefan

 

We have no Support Agreement with Citrix. So we have to contact a Citrix Partner.

 

.... we go back to 14.3.100.10



JAMES GREENSMITH Members
  • #10

JAMES GREENSMITH
  • 8 posts

Posted 06 April 2016 - 12:48 PM

I logged a call with Citrix on this . They're working on a fix but there is no ETA. It is an issue that was fixed in 4.3/4.3.100

For now the only workaround is to downgrade. Recommendation is to use the Receiver clean up utility then install the legacy version.

 

I could easily get it to break with a  PDF. It will crash when browsing high res images, or anything detailed.

 

This was after I tried with a new securegateway server, storefront server and netscaler.

It happens whenever you are using a secure connection to citrix it seems. 



Timothy Welbourn Members
  • #11

Timothy Welbourn
  • 30 posts

Posted 06 April 2016 - 07:27 PM

My team has an open case with Citrix on this issue too.

 

We can reproduce the freezing when both are true using 4.4.0.8014:

-ICA traffic is passing through an Optimal Gateway

-Session Reliability is enabled

 

If only one of the above is true, sessions work fine.

 

-Tim



Bob Brumm Members
  • #12

Bob Brumm
  • 6 posts

Posted 11 April 2016 - 11:57 AM

I had similar issues with 4.4 locking up screens within applications for Windows 10 machines, give Citrix disconnect false messages etc.  Uninstalled 4.4 and ran the Receiver cleaning utility, rebooted and installed 4.3.100 and the issues stopped. 4.4 Has issues on Windows 10 machines. Noted in ticket 71046610.



Ole Christian Strand Members
  • #13

Ole Christian Strand
  • 4 posts

Posted 13 April 2016 - 10:29 AM

We have the same problem with receiver 4.4. and Xenapp 6.5 RP6
But this only happens when connecting through netscaler gateway.

We have Netscaler version:NS10.5 60.7.NC
Downgrade of receiver helps but brakes HDX
 



Andreas Schulz Members
  • #14

Andreas Schulz
  • 37 posts

Posted 14 April 2016 - 01:08 PM

Hi,

 

we have the same problem at one of our customer sites (XA 6.5 HRP6). With Receiver 4.4 there are a lot of users with session freezes. Currently we are testing with Receiver 4.3.100.

 

Best regards,

Andreas



Etienne Coppin Members
  • #15

Etienne Coppin
  • 83 posts

Posted 19 April 2016 - 07:55 PM

Same issue here with our xenapp 6.5 farm. Never got any display issue with receiver 4.3.x but with 4.4 randomly, we have the session starting to display white blocks, session is stuck. disconnect/reconnect and it's working again. Reverting to stable 4.3.1 release awaiting 4.4.1   ;)



Pieter Verbrugge Members
  • #16

Pieter Verbrugge
  • 8 posts

Posted 27 April 2016 - 11:24 AM

We experience the exact same issue

 

Xenapp 6.5 R06

Netscaler Gateway

 

We also noticed it only happens when using published applications, not with published desktop.

We reverted back to version 4.3.1



Mark Lininger Members
  • #17

Mark Lininger
  • 40 posts

Posted 27 April 2016 - 11:31 PM

HI Stefan - 

I ran into this issue on one of our clients.  I might be able to get time to reproduce and provide traces, but we don't have a support agreement directly.  Do you have another method for them to be submitted and instructions?  I'd be happy to assist to get this issue resolved.



Felix Wueest Members
  • #18

Felix Wueest
  • 166 posts

Posted 28 April 2016 - 08:22 AM

Hi all - Citrix published yesterday a new Receiver 4.4.1000 - let's test.



Matthew Dodd Members
  • #19

Matthew Dodd
  • 69 posts

Posted 28 April 2016 - 09:03 AM

No difference for me - locked up 15 minutes after upgrading, looks the same issue as before. Rolled back to 4.3 again.

 

Aagh.



Cindy Oakley Members
  • #20

Cindy Oakley
  • 3 posts

Posted 28 April 2016 - 03:13 PM

4.4.1000 still freezes with detailed images on our published application.  Hoping for 4.4.2 soon with a fix.