Jump to content


Photo

ns.log message - platformRateLimitPktDrop

Started by Steve Brinkworth , 26 February 2015 - 03:58 PM
8 replies to this topic

Steve Brinkworth Members

Steve Brinkworth
  • 5 posts

Posted 26 February 2015 - 03:58 PM

Hi All

 

Whilst troubleshooting a different problem we noticed some entries in our ns.log files that state:

 

Feb 25 12:55:55 <local0.crit> xxx.xxx.xxx.xxx 02/25/2015:12:55:55 GMT netscaler-vpx-instance-name 0-PPE-0 : EVENT Message 2398521 0 :  "1513 packets dropped due to licensed throughput rate being reached"

 

Feb 25 12:55:55 <local0.info> xxx.xxx.xxx.xxx 02/25/2015:12:55:55 GMT netscaler-vpx-instance-name

0-PPE-0 : SNMP TRAP_SENT 2398522 0 :  platformRateLimitPktDrop (platformRateLimitPacketDropCount = 1513, platformLicensedThroughput = 1000, sysIpAddress = xxx.xxx.xxx.xxx)

 

We have had no reports of problems with the application but are concerned about these log messages which are occurring quite frequently.

 

The VPX has an allocated throughput of 1000Mbps and a packets per second rate of 1,000,000 so are sumising that the 'platformLicensedThroughput = 1000' relates to the allocated throughput.

 

However looking at the reporting tool on the VPX we can see peaks in traffic of up to 150Mbps and 18,000 packets per second but nothing like the allocated amounts above.

 

We are running VPX instances on an SDX 11500 appliance

 

Any help or advice would be appreciated.

Many thanks

Steve

 



Olivier BAUDRY Members

Olivier BAUDRY
  • 1 posts

Posted 14 April 2015 - 10:11 AM

Hi Steve,

 

I'm experiencing same issues  /error messages when a request is sent to a load balancer hosted on VPX.

Did you find a solution or the root cause?

 

Many thanks

Olivier



Steve Brinkworth Members

Steve Brinkworth
  • 5 posts

Posted 15 April 2015 - 11:34 AM

Hi Olivier

 

No not yet, I have a support case open with Citrix which has recently been escalated.

 

I'll post back here if they come up with anything useful!!

 

Cheers

Steve



Gavin Herbert Members

Gavin Herbert
  • 13 posts

Posted 20 April 2015 - 10:44 AM

Hi Steve,

 

Be good to hear the response from Citrix, am getting Discards on some of my interfaces - could be related?

 

Have a great day for now bud.

 

Gavin



Kalpesh Padhiyar Members

Kalpesh Padhiyar
  • 2 posts

Posted 21 April 2015 - 01:56 PM

HI Steve, as per my knowledge NS 1000 VPX Max Throughput is 1000Mbps and NS VPX3000 have 3Gbps the issue many in network or maybe with configure issue for application

I glade know what is the issue with your NS VPX once you get update from Citrix support team please update on this.



Simon Simcic Members

Simon Simcic
  • 68 posts

Posted 13 January 2016 - 03:24 PM

Did you solve this? I am getting similar errors on a SDX 11500 appliance. 



Steve Brinkworth Members

Steve Brinkworth
  • 3 posts

Posted 13 January 2016 - 04:18 PM

This issue was caused by the reporting tool in the GUI not giving a true reflection of the throughput of the VPX instance.

 

The instance was allocated a throughput of 1000Mbps however there were occasions when the traffic exceeded this and those packets were dropped ‘due to licensed throughput rate being reached’.

 

Using the nsconmsg command on the particular newsslog file for the time the error occurred with  ‘-g allnic_tot_rx_mbits’ clearly showed the rate/sec exceeding the 1000Mbps allocated throughput.

 

We have since increased this and no longer receive the errors.

 

Hope this helps

Steve



Simon Simcic Members

Simon Simcic
  • 68 posts

Posted 14 January 2016 - 12:40 PM

Ok, thank you for the info. 

 

The correct syntax for the nsconmsg is then:

 

/netscaler/nsconmsg -K /var/nslog/newnslog -g allnic_tot_rx_mbits

 

correct?

 

BR, 

Simon 



Simon Simcic Members

Simon Simcic
  • 68 posts

Posted 14 January 2016 - 02:43 PM

I uploaded the support bundles to TAAS, and I cannot see anywhere near the throughput limits defined at the time of the issue. Is it possible that the packet count was exceeded?