Jump to content


Photo

Install Dell OpenManage 7.4 on XenServer 6.5

Started by Andrej Petkovski , 13 February 2015 - 09:49 PM
6 replies to this topic

Andrej Petkovski Members

Andrej Petkovski
  • 8 posts

Posted 13 February 2015 - 09:49 PM

Hello everyone,

 

I have successfuly installed Dell OpenManage 7.4 on XenServer 6.5 and I would like to share my steps with others. This was done before XenServer 6.5 became a GA release, it could be done easier once the repos become available, but this way defenitely works.

 

1.

Login to your console through SSH like ssh root@YOUR-XEN-SERVER-IP

2.

Add the Dell repository

To do this run this command:
wget -q -O – http://linux.dell.com/repo/hardware/latest/bootstrap.cgi | bash

3.

Install lockfile
OpenManage needs a binary called ‘lockfile’ which can be found in the ‘procmail’ package and seems to be working. Execute these commands to install the binary:
yum –enablerepo=base –disablerepo=citrix install procmail
cp /usr/bin/lockfile /tmp/
yum remove procmail
mv /tmp/lockfile /usr/bin/lockfile

4.

Install srvadmin-all
To install the OpenManage software run this command:
yum –enablerepo=base –disablerepo=citrix install srvadmin-all

5.

Add a firewall rule
Before we can access the web-interface we need to add a rule to the firewall and restart iptables:
vi /etc/sysconfig/iptables
Add this line before the REJECT line at the bottom:
-A RH-Firewall-1-INPUT -m state –state NEW -m tcp -p tcp –dport 1311 -j ACCEPT
Restart iptables:
service iptables restart
Start the services

6.

To start the services run this command:
/opt/dell/srvadmin/sbin/srvadmin-services.sh start

7.

Access the web-interface
To access the web-interface open your browser (IE, Firefox or Safari, chrome doesn’t work) and go to:

https://YOUR-XEN-SERVER-IP:1311/

You can now login with your XenServer root login and password.

 



Dirk Roedl Members

Dirk Roedl
  • 4 posts

Posted 26 February 2015 - 11:07 AM

Hi Andrej,

 

nice tutorial. Does it work with the PERC H200 RAID Controller ?

 

regards,

 

Dirk



Andrej Petkovski Members

Andrej Petkovski
  • 8 posts

Posted 27 February 2015 - 03:07 AM

Hi Dirk,

 

Mate what you mean will it work with H200?

As long as you have a Dell PowerEdge server you can install OpenManage, regardless of PERC version.

If you are asking will XenServer 6.5 work with H200, you have to check online for it's supported controllers.

 

Thanks



Sandy Williams Members

Sandy Williams
  • 114 posts

Posted 01 June 2015 - 06:00 PM

Not working for me, tried the Dell repository above and tried http://linux.dell.com/repo/hardware/Linux_Repository_14.12.00/bootstrap.cgi

 

I got Error 404: Not found

Error: Cannot retrieve repository metadata (repomd.xml) for repository: dell-omsa-indep. Please verify its path and try again



Andrej Petkovsi Members

Andrej Petkovsi
  • 1 posts

Posted 01 June 2015 - 09:02 PM

Sorry, moved away from XenServer, too much trouble to be running production.

 

Cheers



Alan Lantz Members

Alan Lantz
  • 6,989 posts

Posted 01 June 2015 - 09:09 PM

Sandy, sounds like you aren't getting out to the Internet or DNS isn't cooperating on your host. Andrej, sorry to hear that XenServer didn't meet your expectations. I've been using XenServer in production for six or seven years (version 3.3)  and can't imagine anything else. And its come a long way.....

 

--Alan--



Saiid Paryavi Members

Saiid Paryavi
  • 21 posts

Posted 10 July 2015 - 08:12 PM

Hello All,

 

This is what I did and it finally worked for me:

 

1. Install the Dell repo:

 

wget -q -O - http://linux.dell.com/repo/hardware/Linux_Repository_14.12.00/bootstrap.cgi | bash

 

2. Install components:

 

yum install srvadmin-all

 

3. Switch the port the OpenManage listens on:

cd /opt/dell/srvadmin/etc
sh autoconf_cim_component.sh -p 5986
/etc/init.d/openwsmand restart
/etc/init.d/sfcb restart

 

4. Edit /etc/sysconfig/iptables and, if it doesn't already exist, add this:

 

 -A INPUT -m tcp -p tcp –dport 5986 -j ACCEPT
 

5. Restart iptables

 

service iptable restart

 

6. Install Dell ServerAdmin on a compatible Windows Workstation/Server

 

7. Launch Dell ServerAdmin on the Windows PC and login with these coordinates:

 

host name: <remote-xenserver-host>:5986
user: root
pwd: your root pwd

check "ignore certificate warnings"

 

 

Hope this helps some of you out there.