Jump to content


Photo

Xen Server 6.1 - xen tools installation problem

Started by David Hymers , 13 May 2014 - 03:54 PM
3 replies to this topic

David Hymers Members

David Hymers
  • 22 posts

Posted 13 May 2014 - 03:54 PM

I have a Windows server 2008 R2 VM which is running SQL 2012, it is running in a xen server 6.1 pool.  I uninstalled the xen server tools from the server in order to troubleshoot an issue with the VM connecting to our SAN properly.  However now I am unable to install the tools back on.  The installation is going in a constant loop where I run the install, I get the message 'Waiting for drivers to initialize', which stays on the screen for several minutes (see capture 1).  The server then reboots, and I log in again, and the process repeats trying to install the tools again.  I came across a posting of someone who had a similar problem and he did the following to fix it:

 

- disable all sql services

- uninstall xen tools from program files

- search registry for Citrix tools references and delete entries

- reboot

- try installing the tools again.

 

I've tried this but it just keeps going round in a loop again each time I try it.  I've checked the windows logs and there doesn't appear to be anything out of the ordinary.  

 

XenServer Tools installer and XenServer guest agent are showing as installed in Programs & Features.  Also in services Citrix Xen Guest Agent is started, as is XenServer Windows installer.

 

When the server starts up again it shows "Xen Server tools not installed", and it tries installing the tools again (see capture 2).  Unfortunately I have no snapshot of the server to revert to, any ideas on how to get the xen tools installed? this is driving me crazy..

 

 

 

Attached Thumbnails

  • Capture 1.JPG
  • Capture 2.JPG
  • Capture 3.JPG


James Cannon Citrix Employees

James Cannon
  • 4,402 posts

Posted 13 May 2014 - 04:33 PM

Hi David,

 

We essentially need to troubleshoot a Windows issue. Microsoft has a great tool for this, which you probably already use: msconfig

 

Once you log in, run msconfig, choose "Selective startup", then go to Services tab, hide all Microsoft and disable all but XenTools. Next, show all services and disable Microsoft SQL. Do the same on the startup tab. Reboot and hopefully this will allow you to proceed. If you have any antivirus, you will want to uninstall it as it probably has a network filter driver, so stopping AV services is not enough.

 

I am hoping you made a snapshot before the XenTools uninstall, as it is good to do so before any system change.



David Hymers Members

David Hymers
  • 22 posts

Posted 14 May 2014 - 09:09 AM

Many thanks James, that worked!



James Cannon Citrix Employees

James Cannon
  • 4,402 posts

Posted 14 May 2014 - 05:28 PM

Glad to hear all is well.