Jump to content


Photo

Exchange 2010 RPC Timeout issue

Started by Carl Behrent , 03 March 2014 - 03:42 AM
7 replies to this topic

Carl Behrent Members

Carl Behrent
  • 309 posts

Posted 03 March 2014 - 03:42 AM

NetScaler 10.0 Build 73.5

Exchange 2010

 

We are having intermittent timeout issues with the RPC LB VIP, to replicate the issue we can open a new Outlook message, click on "To" to see the GAL and it errors.

 

Our Exchange RPC timeouts are configured as default (15mins).

 

The RPC LB VIP has a Persistence time out (Method and Persistence tab) of 150mins (was 2mins initially).

The RPC LB Service Group has Idle Timeouts (Advanced tab) of Client=9000secs and Server=9000secs

 

It appears to definitely be something with the NS config as if we bypassed the NS for a couple of days it didn't appear to be an issue.



Paul Blitz Members

Paul Blitz
  • 3,864 posts

Posted 04 March 2014 - 12:00 PM

The idle timeouts shouldn't really affect you, that's all to do with (on the server side) when things go quiet, and it wants to start shutting down unused backend connections.... similar for the client, it's kiiling off any "dead" client connections.

 

The persistence affects making sure a connected session keeps connecting to the same backend server, and the persistence time on NS should be a bit higher than that on the exchange. We had a similar issue, the Exhange timeout was 15 or 20 minutes, like yours, so we set the Netscaler persistence to 30 mins, and that fixed the issue.

 

So, in principle, you're going about it right....



Carl Behrent Members

Carl Behrent
  • 309 posts

Posted 16 July 2014 - 09:04 PM

We resolved this issue by creating a custom TCP Profile and bound it to the RPC LB VIP.



Jude Xavier Members

Jude Xavier
  • 3 posts

Posted 13 October 2014 - 02:50 AM

Hi Carl,

 

We are experiencing similar issue. What values did you set on the custom TCP profile? We have exchange 2010 environment.

 

Cheers,

Jude



Carl Behrent Members

Carl Behrent
  • 309 posts

Posted 13 October 2014 - 03:36 AM

Create this custom TCP Profile and attach to your RPC LB Vserver.

 

https://masterxen.wordpress.com/2015/08/11/exchange-rpc-timeouts-when-using-citrix-netscaler/

Attached Thumbnails

  • Capture.PNG


Jude Xavier Members

Jude Xavier
  • 3 posts

Posted 13 October 2014 - 04:14 AM

Hi Carl,

Thanks for the quick response. I was doing a quick comparison of this custom profile with the default one. Is there any reference guide you have got to explain on what basis this profile was made. I just need to justify with my management before I introduce this change.

 

I have to thank you for your timely help and the willingness to help us.

 

Cheers,

Jude



Jude Xavier Members

Jude Xavier
  • 3 posts

Posted 13 October 2014 - 06:02 AM

Hi Carl,

 

I just found out  the load balancing vip also holds Exchange OWA, Activesync, RPC and Outlook anywhere. Will it cause any problems if I apply the tweaked TCP profile to the specific load balancing VIP?

 

Cheers,

Jude



Carl Behrent Members

Carl Behrent
  • 309 posts

Posted 13 October 2014 - 08:17 PM

I got that fix from another forum post, the poster had contacted Citrix Support and it was their recommendation to use that custom TCP Profile.

 

We have a separate LB VIP for each of the Exchange services as per Citrix recommendations so we only applied the TCP Profile to the RPC LB VIP.

 

Hard to say if it will effect other services but unlikely. The option that mainly fixes this issue is the "Keep-alive probes"