Jump to content


Photo

CTRL key sticking

Started by Richard McClain , 13 January 2014 - 02:25 PM
70 replies to this topic

Peter Grayson Members
  • #21

Peter Grayson
  • 73 posts

Posted 18 March 2014 - 10:25 AM

Citrix need to release this fix now, we have a XenDesktop farm with over 500 licenses. Those license are paid for, we can't use them properly because the receiver doesn't work. Its totally wrong to ask customers to have to pay for an overpriced support contract in order to obtain a fix for a broken product.



Peter Grayson Members
  • #22

Peter Grayson
  • 73 posts

Posted 20 March 2014 - 03:39 PM

Can we have some info from Citrix on when a fix for this will be on general release please?! 



Daniel Bader Members
  • #23

Daniel Bader
  • 5 posts

Posted 25 March 2014 - 12:09 AM

I'm also having this issue.  Has anyone been able to get a hold of the hotfix?  



Jonathan Leighton-Hoggett Members
  • #24

Jonathan Leighton-Hoggett
  • 5 posts

Posted 25 March 2014 - 09:09 AM

We signed up for a support agreement but are currently greeted with "We’re sorry, the system could not process your request." when attempting to open a case.



Daniel Bader Members
  • #25

Daniel Bader
  • 5 posts

Posted 25 March 2014 - 10:32 AM

We signed up for a support agreement but are currently greeted with "We’re sorry, the system could not process your request." when attempting to open a case.

 

If they get you working please let us know how to fix it.  :)



Peter Grayson Members
  • #26

Peter Grayson
  • 73 posts

Posted 26 March 2014 - 08:08 AM

Like wise, if you can help us out that would be great



Peter Grayson Members
  • #27

Peter Grayson
  • 73 posts

Posted 27 March 2014 - 11:42 AM

I get issues with 12.1 with the monitors too, weird artifacts on the screen etc. 



Gary Singh Members
  • #28

Gary Singh
  • 1 posts

Posted 08 April 2014 - 10:04 PM

Thought i'll mention as others are getting similar issues.

 

We're recently rolled out HP Thin t610 with HP firmware 4.4 - It came with citrix icaclient-12.1.6 however we upgraded it Receiver 13 Linux as 12.1 as it won't let me launch applications via Netscaler Web Interface and only work via XML brokers as i think doesn't have PNagent browser settings in it. Anyways after upgrading we are getting weird issues - Users keyboard translation wont work properly, Sticky keys and outlook email multi selection using mouse wont work properly untill you press ctrl key, session screen freeze because of sticky keys... however no of these issue exists with 12.1 only issue it does work via NS WBI.

 

Looks like Citrix will have to release a fix pretty quickly as this is a pain for users n IT support team. I'll open a support ticket so at least they are aware what issues we are facing.



Peter Grayson Members
  • #29

Peter Grayson
  • 73 posts

Posted 10 April 2014 - 08:53 AM

I've bought a support contract, I can't wait any longer. 12.1 doesn't work well with XenDesktop 7,1 we get capslock latency. version 13 doesn't suffer with the same latency, but has this nightmare of a sticky key issue.

 

I'm hoping to get the hotfix today



Jonathan Leighton-Hoggett Members
  • #30

Jonathan Leighton-Hoggett
  • 5 posts

Posted 10 April 2014 - 04:49 PM

I've bought a support contract, I can't wait any longer. 12.1 doesn't work well with XenDesktop 7,1 we get capslock latency. version 13 doesn't suffer with the same latency, but has this nightmare of a sticky key issue.

 

I'm hoping to get the hotfix today

 

 

We tried that too, still waiting for a reply to the ticket after almost a week.



Peter Grayson Members
  • #31

Peter Grayson
  • 73 posts

Posted 11 April 2014 - 01:33 PM

I've got the fix, logged a case yesterday. Took a week to get the contract in place though. I'm testing version 13.0.2 of the receiver now



Jonathan Leighton-Hoggett Members
  • #32

Jonathan Leighton-Hoggett
  • 5 posts

Posted 15 April 2014 - 03:15 PM

I've got the fix, logged a case yesterday. Took a week to get the contract in place though. I'm testing version 13.0.2 of the receiver now

 

Any news? We're still without reply :(



Peter Grayson Members
  • #33

Peter Grayson
  • 73 posts

Posted 16 April 2014 - 06:55 AM

Yes. its not a hotfix per-say, its version 13.0.2 of the receiver. It works, no more problems with sticky keys, the whole thing seems much faster to me too 



Richard McClain Members
  • #34

Richard McClain
  • 3 posts

Posted 16 April 2014 - 12:53 PM

How does a non-support normal user get this new version - 13.0.2? The Citrix Receiver download page for linux still only shows version 13.0.



Peter Grayson Members
  • #35

Peter Grayson
  • 73 posts

Posted 16 April 2014 - 02:11 PM

You need a valid support contract we had to buy one to get the fix



Michael Pekarik Members
  • #36

Michael Pekarik
  • 118 posts

Posted 18 April 2014 - 03:56 PM

Richard, do you have a SR number to reference for the fix?



Richard McClain Members
  • #37

Richard McClain
  • 3 posts

Posted 18 April 2014 - 07:05 PM

No. I sure that my employer has a Citrix contract. But I would have to involve the Help Desk and the company does not really support linux on desktops. So it would be a hassle. I was just hoping that Citrix would make it available for download.



Dmitriy Ermakov Members
  • #38

Dmitriy Ermakov
  • 1 posts

Posted 24 April 2014 - 12:53 PM

Sticky keys are still a problem on Ubuntu 14.04 LTS even with receiver version 13.0.2... Have checked this yesterday and rolled back to 12.1.



Giuseppe Passino Members
  • #39

Giuseppe Passino
  • 3 posts

Posted 24 April 2014 - 07:26 PM

How difficult can this possibly be to fix? It's almost embarassing that Citrix is not able to fix a simple bug in 4 months.



Rajeev Sethumadhavan Members
  • #40

Rajeev Sethumadhavan
  • 55 posts

Posted 25 April 2014 - 11:15 AM

Same issue for me. 

 

I have to stick with receiver 13.0 because with 12.1 receiver i cant multiple monitor spanning to work.

 

Have anyone got multiple monitor work successfully with 12.1 receiver?

 

Thanks