Jump to content


Photo

Cannot Type the @ Character in XenApp Sessions when using citrix Reciver for HTML5 ver 1.1

Started by Thomas Värmfors , 19 February 2013 - 10:04 PM
13 replies to this topic

Thomas Värmfors Members

Thomas Värmfors
  • 5 posts

Posted 19 February 2013 - 10:04 PM

Hi!

I have a problem in a XenApp 6.5 environment with the StoreFront 1.2 and Citrix Reciver for HTML5 ver 1.1. The problem is that "Alr Gr" key on the keyboard does not work.
Uses Swedish keyboard layout and character like @ use that combination. If I try the Ascii combination for eg @ (Alt 64) it works.

Anyone experienced the same problem? Have tested in Google Chrome and Firefox. The same problem.

Edited by: thomas.varmfors@atea.se on 2013-feb-19 17:06



Santosh D Tilagul Citrix Employees

Santosh D Tilagul
  • 50 posts

Posted 20 February 2013 - 07:05 AM

Hi Thomas,

Apologies for the inconvenience.

To understand the environment better, are you using Mac ?

--
Santosh T



Thomas Värmfors Members

Thomas Värmfors
  • 5 posts

Posted 20 February 2013 - 07:30 AM

Hi Santosh!

Thanks for the reply.

I'm using the following components in the environment.

NetScaler 10 with Access Gateway
StoreFront 1.2
XenApp 6.5
Windows 7
Windows 8
Citrix Reciver 3.3
Citrix Receiver for HTML5 1.1
Chrome
Firefox
Internet Explorer 10

I saw the thread about the problem with the ipad and to set the registry value IgnoreRemoteKeyboardLayout. Have not tested it and would rather not do it either because that would affect the whole environment.

Regards Thomas

Edited by: thomas.varmfors@atea.se on Feb 20, 2013 7:00 AM



Santosh D Tilagul Citrix Employees

Santosh D Tilagul
  • 50 posts

Posted 04 March 2013 - 06:33 AM

Hi Thomas,

In your environment, if it is complete Swedish ENV (both server as well as client), then the issue would not occur.
But in another scenario, if you have English ENV but using a Swedish keyboard or vice versa, this issue could occur.

Could you please let us know what is the scenario in your environment?

--
Thanks,
Santosh T

Edited by: santoshdt on 04-Mar-2013 01:35



Thomas Värmfors Members

Thomas Värmfors
  • 5 posts

Posted 04 March 2013 - 09:23 AM

HI!

The Server environment is a Windows 2008 R2 Enterprise. Eng language with Swedish regional settings and location with Swedish keyboard layout.

Client side is Windows 7 SP1 Eng, Windows 8 Eng language with Swedish regional settings and location with Swedish keyboard layout.

The only Alt Gr combination that is working is £(Alt Gr + 3) €(Alt Gr +5).

It´s hard to explain but I cannot be the only one with this issue? If this is a problem when can we expect a hotfix for this?

/Thomas



Bart Petroons Members

Bart Petroons
  • 3 posts

Posted 11 May 2015 - 07:40 AM

HI!

The Server environment is a Windows 2008 R2 Enterprise. Eng language with Swedish regional settings and location with Swedish keyboard layout.

Client side is Windows 7 SP1 Eng, Windows 8 Eng language with Swedish regional settings and location with Swedish keyboard layout.

The only Alt Gr combination that is working is £(Alt Gr + 3) €(Alt Gr +5).

It´s hard to explain but I cannot be the only one with this issue? If this is a problem when can we expect a hotfix for this?

/Thomas

Hi Thomas,

 

Did you ever find a solution for this problem?

 

I am experiencing the same kind of issue with my setup:

 

Server 2012 eng with dutch belgian regional settings

Client windows 7 eng with dutch belgian regional settings

 

Altgr is not working for @, but works fine for €

 

Best regards,

Olivier



BART JACOBS Members

BART JACOBS
  • 198 posts

Posted 28 August 2015 - 09:29 AM

Same issue with the newly announced CWC WebApps (basically HTML5 receiver hosted by Citrix)

 

no @ when typing



BART JACOBS Members

BART JACOBS
  • 198 posts

Posted 28 August 2015 - 09:55 AM

On the same client I can't type @ when running CWC HTML5 WebApp but I can type @ connected to a server in our datacenter running the html5 receiver.

 

So I guess it comes down to the server having "Belgian Dutch (Period)" installed or not



Vidhesh Ramesh Citrix Employees

Vidhesh Ramesh
  • 81 posts

Posted 18 September 2015 - 01:45 PM

Bart,

 

Which browser are you using? Is the browser set to the same language?

 

--VR



lallau olivier Members
  • #10

lallau olivier
  • 17 posts

Posted 20 February 2017 - 03:54 PM

Hello

 

I've the same problem with firefox only : we use receiver html5 and only with firefox when a user use th ekey 'Alt Gr', then we can't use other keys. The only solution is to kill citrix session, live our application or unlock the keyboard with 'Alt + Alt Gr'.

 

Did you find a solution ?

 

Thanks a lot

Olivier



DISI LRI Members
  • #11

DISI LRI
  • 13 posts

Posted 18 May 2017 - 10:40 AM

Hello Olivier,

 

I had the same problem with Firefox and the receiver HTML5.

It's solved for me since Firefox v53.0.2.

 

SC



DISI LRI Members
  • #12

DISI LRI
  • 13 posts

Posted 18 May 2017 - 06:04 PM

I forgot to say, you must first reset your firefox configuration.
With menu help "?" and from the Help menu choose "Troubleshooting Information" and click the Refresh Firefox button in the upper-right corner of the Troubleshooting Information page.

 

 

best regard,

SC



DISI LRI Members
  • #13

DISI LRI
  • 13 posts

Posted 18 May 2017 - 08:38 PM

Sorry it's not solve with "Refresh Firefox" this problem back after restart Firefox.

 

For solve it, in PREFS.JS file of your Firefox delete all lines with
user_pref("extensions.e10s

and insert this 2 lines
user_pref("extensions.e10s.rollout.hasAddon", false);
user_pref("extensions.e10sBlockedByAddons", true);

or
user_pref("extensions.e10s.rollout.hasAddon", true);
user_pref("extensions.e10sBlockedByAddons", true);



DISI LRI Members
  • #14

DISI LRI
  • 13 posts

Posted 19 May 2017 - 04:31 PM

citrix receiver HTML5 doesn't work with multi-prossus mode of Firefox !