Jump to content


Photo

Receiver 11.4 (Mac) - International Keyboard Layout Issue

Started by Rene Lochmann , 12 September 2011 - 07:41 PM
10 replies to this topic

Rene Lochmann Members

Rene Lochmann
  • 4 posts

Posted 12 September 2011 - 07:41 PM

It appears that Version 11.4 of the Receiver for Mac still does not properly recognize and handle *international keyboards*. I have a German keyboard and use Snow Leopard and Citrix for accessing my firm's systems. Most of the German special character (like ü, ä, ö, ?) do not work properly or are a the wrong places.

The German keyboard only properly works if I change the keyboard layout on the Mac from German to US style. Of course, then I have the wrong keyboard when working in Mac Windows.

This issue is known since version 11.2. *Version 11.1 was the last version everything just worked fine*. I am surprised that Citrix is not capable addressing and resolving this issue. Any hints for resolving the issue from my end are highly appreciated.

Best regards,
Rene

Edited by: Rene Lochmann on 12.09.2011 15:41



JPM Steeman Members

JPM Steeman
  • 3 posts

Posted 17 September 2011 - 08:27 AM

Same problem for me in The Netherlands. I get a German keyboard instead of the international one. Still using 11.1 as solution.



Rene Lochmann Members

Rene Lochmann
  • 4 posts

Posted 17 September 2011 - 09:15 AM

I think I have the solution. I played around with the Config file of the Citrix Receiver and changed the keyboard layout from "KeyboardLayout=(User Profile)" to "*KeyboardLayout=German*". The Config file can be found in "/Users/[User]/Library/Application Support/Citrix Receiver". I have copied the entire config file content below.
<div></div>
<div>Rene
</div>
<div><div></div>
<div><div>;******************************************************************
</div>
<div>;
</div>
<div>;<span style="white-space: pre" class="Apple-tab-span"> </span>Config - Client workstation configurations for Citrix ICA Client.
</div>
<div>;
</div>
<div>;<span style="white-space: pre" class="Apple-tab-span"> </span>Copyright Citrix Systems, Inc., 1990 - 2004. All rights reserved.
</div>
<div>;
</div>
<div>;******************************************************************
</div>
<div>[WFClient]
</div>
<div>DrivePathC=
</div>
<div>DriveEnabledC=No
</div>
<div>DriveReadAccessC=2
</div>
<div>DriveWriteAccessC=2
</div>
<div>DrivePathB=
</div>
<div>DriveEnabledB=No
</div>
<div>DriveReadAccessB=0
</div>
<div>DriveWriteAccessB=1
</div>
<div>DrivePathA=
</div>
<div>DriveEnabledA=No
</div>
<div>DriveReadAccessA=0
</div>
<div>DriveWriteAccessA=0
</div>
<div>ClientDrive=No
</div>
<div>ClientPrinter=On
</div>
<div>ISVersion=601
</div>
<div>BrowserProtocol=HTTPonTCP
</div>
<div>BrowserTimeout=1500
</div>
<div>DisableSound=False
</div>
<div>DisableClientAutoQuit=False
</div>
<div>UpdatesAllowed=True
</div>
<div>MaximumCompression=On
</div>
<div>KeyboardTimer=0
</div>
<div>MouseTimer=0
</div>
<div>MouseDoubleClickTimer=0
</div>
<div>KeyboardLayout=German
</div>
<div>KeyboardType=(Default)
</div>
<div>UseKotoeriShortcuts=False
</div>
<div></div>
<div>LastTabSelected=Keyboard
</div>
<div>[Thinwire3.0]
</div>
<div>DesiredColor=4
</div>
<div>DesiredVRES=768
</div>
<div>DesiredHRES=1024
</div>
<div>PersistentCacheEnabled=Off
</div>
<div></div>
</div>
</div>



JPM Steeman Members

JPM Steeman
  • 3 posts

Posted 18 September 2011 - 10:45 PM

So according to your reply we should use U.S. International for an U.S. International keyboard and Dutch for the Dutch keyboard. I will give it a try. To be continued. Thanks.



Rene Lochmann Members

Rene Lochmann
  • 4 posts

Posted 19 September 2011 - 09:51 AM

At least from my end the explicit and manual setting to the "German" keyboard layout worked. I do not know, though, what needs to be inserted for other languages. For other users, it may be helpful if the Citrix team could provide for a list of the precise wording of all available languages to be inserted ("German", "Dutch"?, "French"?, "Swedish"?, etc.). In the long run, of course, the Citrix team should fix this so that the string "(User Profile") reads out the proper keyboard layout automatically.

Best,
Rene



JPM Steeman Members

JPM Steeman
  • 3 posts

Posted 19 September 2011 - 06:04 PM

It works for me as well. A shame that Citrix did not fix it.



Siegfried Zeilinger Members

Siegfried Zeilinger
  • 1 posts

Posted 03 October 2011 - 09:37 PM

Thank you, this saved my day!



Alejandro Artiles Members

Alejandro Artiles
  • 14 posts

Posted 11 October 2011 - 02:36 PM

Thanks very much. Works for me with 'Spanish'

Best regards



Alejandro Artiles Members

Alejandro Artiles
  • 14 posts

Posted 11 October 2011 - 02:39 PM

Any similar solution for iPad ?



Stephan Lang Members
  • #10

Stephan Lang
  • 78 posts

Posted 19 April 2012 - 11:54 AM

I'm looking also for a solution for this behaviour on the ipad...
http://forums.citrix.com/message.jspa?messageID=1632717#1632717

but i've found nothing yet... any workarounds available?
thx



Erik Nijhuis Members
  • #11

Erik Nijhuis
  • 1 posts

Posted 20 August 2012 - 01:31 PM

Here is a list with KeyboardLayout variables: http://support.citrix.com/proddocs/topic/plugin97-java/java-parameters-keyboard-layouts.html

This is for the Java plugin, the list could be the same for the Mac Receiver. Changing it to "US-International" fixed the problem on a Dutch Mac with international keyboard.