Jump to content


Please wait for the Local Session Manager

Started by Shaun Orr , 26 July 2011 - 02:44 PM
33 replies to this topic

Shaun Orr Members

Shaun Orr
  • 5 posts

Posted 26 July 2011 - 02:44 PM

Thank you for taking the time to review the issue below. I appreciate any help that can be offered.

I have a single 2008r2 server with xenapp 6 installed in a domain.

Mix of 2003 DC and 2008r2 DC
2008r2 web server for web interface
Proile Management 3.2.2 installed
Roaming profiles set to share with Everyone/Full Control (for testing)
Published Notepad.exe and a Desktop
Created a test user with no AD TS Profile settings

Roaming profiles are working as expected. They create off the correct Default profile and store to the network share. Furthermore they delete off the local machine at logoff.

If I attempt to launch the notepad published application, the user hangs at the "Please wait for the Local Session Manager" screen for about 2 minutes and then it disappears. If I watch the Task Manager on the TS server I can see the user starts the 'taskhost.exe' and 'TSTheme.exe' processes. After the attempt times out, these processes terminate on the server and the locally cached profile is deleted. Notepad never comes up.

If I attempt to launch the published desktop, it also hangs at the 'Please wait for the Local Session Manager' screen for about 2 minutes, but then brings up the desktop.

If I add the user to the administrators group both the published notepad app and the desktop work. Additionally, under this condition the login time is about 8 seconds rather than 2 minutes.

Thank you again for your comments.

Shane Brennan Citrix Employees

Shane Brennan
  • 96 posts

Posted 26 July 2011 - 03:30 PM

Hi there

Ensure that the users you are testing with are members of the remote desktop user's group and that they can launch a RDP session to the machine.

Confirm they have the Log on locally and connect to this computer from a network right

Shaun Orr Members

Shaun Orr
  • 5 posts

Posted 26 July 2011 - 04:27 PM

Shane, Thank you for your suggestions.

I confirmed that the test user is a member of the Remote desktop user group and that they have Log on Locally enabled. When attempting to launch an RDP connection with this user, it behaves the same way. Sticks on "Please wait for Local Session Manager" for a couple of minutes and then eventually brings up the desktop. If the user is added to Domain Administrators, the desktop comes up almost immediately.

Published applications still do not launch.

Shaun Orr Members

Shaun Orr
  • 5 posts

Posted 04 August 2011 - 02:09 PM

Additional information:

After trying various things, I deleted the GPO for the OU that this server is in and recreated it. I added only the following:

Enforced: No
Link Enabled: Yes
Active write back: Enabled
Enable Profile Man: Enabled
Path to user store: Enabled (\\xxxxx\xxx\%username%)
Process logons of local Admins: Disabled
Delete Locally cached profiles at logoff: Enabled
Template profile: Enabled ( \\xxxxx\xxx\default)

I then went to the xenapp server and did a gpupdate /force which was successful.
I logged in as a test user and all published applications worked. Furthermore, all profile settings in the GPO above worked. The profile created successfully from the default in the correct share and deleted the cache at logoff. I performed this test with multipul applications and they were all successful.

Then I rebooted the xenapp server and the original problem resurfaced. If I set Link Enabled to No, do a gpupdate /force on the xenapp server, then set it back to Link Enabled: Yes and do another gpupdate /force on the xenapp server it will suddenly work again, but any reboot to the server will bring it back to the original problem.

Any help would be appreciated.

Peter Brook Members

Peter Brook
  • 3 posts

Posted 16 September 2011 - 04:55 AM

I had this problem and found it was caused by a Citrix/TS-incompatible printer driver. Logging on as an administrator on the server console showed a program on the Taskbar "Program(s) or device(s) requesting attention". Clicking on this brought up an Interactive Services Detection box that then brought up the printer properties of an autocreated user printer!

The actual prompt itself was coming from PrintIsolationHost.exe and once the printer properties box was closed on the server console the problem went away but came back every time the user tried getting into the properties of their printer again. Getting rid of that driver solved the problem permanently.

I suggest double-checking what print drivers are in use, especially if you're using autocreated client printers, and ensuring they're all TS compatible.

Rodrigo Pimenta Members

Rodrigo Pimenta
  • 39 posts

Posted 10 November 2011 - 04:32 PM

Same issue here! xenapp 6.5.

if user has admin privileges, its Work!!

i will disable my citrix profile management GPO.. and test!


Ian Anderson Members

Ian Anderson
  • 10 posts

Posted 17 January 2012 - 08:08 AM

I have the same issue, regardless if the user is an admin or not.

Renaming the AppData directory in the user's profile and having it auto-created from default user 'fixes' the issue. But this is not a real fix as we loose all the info in the AppData directory and then the problem resurfaces again within a few days.

Had a look at http://support.microsoft.com/kb/980568 but this doesn't apply W2K8 R2.

Does anyone have a fix for this?

Ian Anderson Members

Ian Anderson
  • 10 posts

Posted 17 January 2012 - 02:26 PM

I have found that the logon is hanging while running TSTheme.exe. If I rename this file (after taking ownership, etc.) the logon deley while waiting for the Local Session Manager no longer occurs.

I can't find any definitive explanation of what the TSTheme.exe file is for so I'm investigating whether or not my "fix" has any serious side effects.

I'll post my findings back here.

Asrar Guna Members

Asrar Guna
  • 132 posts

Posted 19 January 2012 - 07:00 AM

Using terminal services manager in Windows 2003 server to manage Windows 2008 servers causes the problem.


Either close the Windows 2003 terminal services manager every few hours or use Windows 2008 terminal services manager to manage windows 2008 servers


Asrar Guna
"Darkest Skies have the Brightest Stars..."

Ian Anderson Members
  • #10

Ian Anderson
  • 10 posts

Posted 19 January 2012 - 08:40 AM

I have been sent two hotfixes by MS to address this issue:-


We are applying them today I will come back and say whether or not they worked.

Asrar Guna Members
  • #11

Asrar Guna
  • 132 posts

Posted 19 January 2012 - 09:12 AM


have you applied any hotfixes on your XenApp infrastructure? Check http://support.citrix.com/article/CTX129229 or try Hotfix Rollup Pack 1 for Citrix XenApp 6 for Microsoft Windows Server 2008 R2.

Asrar Guna
"Darkest skies have the brightest Stars..."

Ian Anderson Members
  • #12

Ian Anderson
  • 10 posts

Posted 19 January 2012 - 09:22 AM

Thanks for the message Asrar.

We're running XenApp 6.5. I haven't seen any hotfixes for 6.5 that address the symptoms described.

Christian Tinello Members
  • #13

Christian Tinello
  • 22 posts

Posted 03 February 2012 - 09:42 AM

Hi to all guys,
i would like to share with u my troubleshooting regarding this problem, cause doing some test i find what's the file is causing all that things.

I explain my situation:
i have a dc with win2k8 r2
xenapp 6 on win2k8 r2 SP1 + Hotfix Roll up Pack 1 + other ctx hotfix other microsoft hotfix

Like you i have that, when i create a new user and try to logon , i get Please wait for the Local Session Manager
and after all the user can't connect.
So after some testing , i went to delete recursively all files 1 by 1 in the AppDate\Local folder.
Surprise i find that filename UsrClass.dat in AppData\Local\Microsoft\Windows was causing this problem.
So i try to rename it into .OLD and voilà the user can connect.
After that i try to create a new user from AD and i got the same result Please wait for the Local Session Manager. So this time i went to rename the UsrClass.dat into C:\Users\Default\AppData\Local\Microsoft\Windows and finally for all new user i create , they were able to login .
For all those existing user , i just simply rename the UsrClass.dat in AppData\Local\Microsoft\Windows .

It seems that it's get corrupted or wrong the usrclass.dat and you must hato to recreate it.
In my case i got UsrClass.dat of 512 KB and after have to recreate it , it was 256 KB.
I just compare the two files with winmerge and there were numerous differences between them.
However i can't explain where the new usrclass.dat file been created after i have rename the usrclass.dat from

Maybe Citrix or someone who is skilled can help us, cause this is annoying thing.

I hope you find this useful

Thank You

Edited by: Christian Tinello on 3-feb-2012 10.48

Michelle Moses Citrix Employees
  • #14

Michelle Moses
  • 2 posts

Posted 15 February 2012 - 02:11 PM

I am working in a XenApp 6.5 environment with Desktop Experience installed. When User Profile Management is enabled, I see a 120 second delay at "Please wait for the Local Session Manager..." for regular users. Administrators do not have this same delay. I have confirmed that TSTheme.exe is causing the delay because if I kill the process during a user's login, there is no delay. By default, "Users" have "Read" and "Read & Execute" NTFS permissions to C:\Windows\System32\TSTheme.exe. I have found that simply removing "Users" from the list, resolves the 2 minute delay. I have not yet found any adverse side effects as a result of unassigning Users permission to TSTheme.exe.

Georgios Pletsis Members
  • #15

Georgios Pletsis
  • 20 posts

Posted 16 February 2012 - 09:28 AM

I have installed a XenApp 6.5 on 2008r2 as well User Profile Management 4. I faced similar problems :
My published applications sometimes did not launch (citrix receiver window disappeared after "Please wait for the Local Session Manager " message )
or there was sometimes a huge delay ( 2-3 minutes ) .

I followed Michelle's solution and the problem seem to be fixed.

Edited by: gpletsi871 on 16 Φεβ 2012 4:31 πμ

Jason Richards Pagh Members
  • #16

Jason Richards Pagh
  • 22 posts

Posted 21 February 2012 - 11:18 PM


Microsoft has provided a fix for the hang that should prevent you from having to take away the permissions. But that was a good idea!


Carl Stalhood CTP Member
  • #17

Carl Stalhood
  • 11,935 posts

Posted 05 March 2012 - 09:08 PM

I just fixed an issue with the same symptoms. A different administrator used SysPrep to modify the Default User Profile. However, the permissions inside the usrclass.dat file were incorrect and thus caused the 2 minute delay.

To fix it, I went to c:\users\default\appdata\local\microsoft\windows and deleted the usrclass.dat file.

Matthew Pinnell Members
  • #18

Matthew Pinnell
  • 10 posts

Posted 08 March 2012 - 11:27 AM


A customer of mine has the exact same issue, and the Microsoft KB2661001 hotfix didn't resolve but the deletion of the Default profile usrclass.dat did. Did you manage to find out which permissions specifically were incorrect, i'm keen to repair the file rather than globally deleting it across the customer global infrastructure.

Paul Kushlan Members
  • #19

Paul Kushlan
  • 2 posts

Posted 21 March 2012 - 08:51 PM

Just had this same issue. Deleting / Renaming the file: c:\users\default\appdata\local\microsoft\windows and deleted the usrclass.dat resolved the issue.

Paul Quirk Members
  • #20

Paul Quirk
  • 14 posts

Posted 02 April 2012 - 08:47 AM

Userclass.dat fixed for me too