Jump to content


Photo

NIC driver for Windows PE

Started by rudi schoeble , 20 March 2011 - 11:34 PM
57 replies to this topic

rudi schoeble Members

rudi schoeble
  • 18 posts

Posted 20 March 2011 - 11:34 PM

We use ShadowProtect to do P2V conversions and test our backup & restore procedures. This involves booting a new VM using a Windows PE ISO image which then connects to a network share containing our backup image files and restores them to the new VM drives.

It works fine, however copying the backup image files is very slow. Once the VM is restored and Xentools is installed copying the same images is considerably faster. I suspect the NIC driver that the Windows PE environment uses may be the issue. The PE environment does provide the opportunity to load custom NIC drivers and I'd like to try the driver used with Xentools as a test, however I can't find a .inf file that the WIndows PE environment is looking for.

Any ideas on where or how I could obtain the NIC driver .inf file used by Xentools?

Thanks



Kirk Kosinski Citrix Employees

Kirk Kosinski
  • 2,532 posts

Posted 21 March 2011 - 02:08 AM

Hi, Rudi. If you use 7-Zip to open xensetup.exe on the XenServer Tools ISO, you will find the driver files (including INF). The network driver files should be the ones that start with "xennet" (see screenshot).
!xennet.png!

Let us know if you succeed in adding these to your Windows PE image (I'm curious to know myself). If your issue is resolved, mark the thread as answered and posts as helpful or correct.
___
{color:#555555}Kirk Kosinski{color} !http://www.linkedin.com/favicon.ico!
{color:#999999}MCITP: EA / VA / EDA7, VCP 4, CCA{color}

Attached Files



Alex Wallner Members

Alex Wallner
  • 1 posts

Posted 21 March 2011 - 06:36 PM

I have the same problem

wiht HP BL 460c G7 and Symantec Backup Exec System Recovery (Win PE, Vista) and 10 GB Emulex NC 553i

I have a support Call at Symantec but no solution.

to import the xen driver does not work, winpe loads the realtek driver, when i load de BUS - Bluescreen

The Problem ist only on the HP G7 Server with the 10 GB Emulex Cards, no Problem on HP G5

Edited by: awallne974 on 23.03.2011 04:22



James Rostron Members

James Rostron
  • 8 posts

Posted 30 March 2011 - 12:18 PM

I'm also having exactly the same problem as awallne974, HP BL460c G7 running XS 5.6 FP1

Symantec (SRD) System Recovery Disk (Win PE) loads the Realtek driver and I'm unable to get connectivity.
I have tried the Xen drivers as suggest above to no avail and all listed HP drivers for the BL460 do not work.

Symantec support even created me a custom SRD without the Realtek drivers included but this also doesn't work.



Lars B. Members

Lars B.
  • 2 posts

Posted 26 May 2011 - 09:23 AM

Dear Kirk,

You are right! These are the drivers we need. Thanks for that! But, sadly, it is no solution. Something is missing!

A normal driver-insert and -load on start process of the Windows PE Image (VistaPE/Win7PE) *don't make any advantage*. The NIC communication is very slow. It seems that the drivers are not totally load (Realtek are still active?)

I think some *Windows-Registry entries have to change additionally*. Maybe the Xen NIC-bridge has to be configured, or something else?

Kirk, do you have some information about that? Or maybe someone else has an idea?

Best regards,
b0mmel



Lars B. Members

Lars B.
  • 2 posts

Posted 06 June 2011 - 06:43 AM

Maybe someone have some answers? It is really tricky...



Joachim Schreibmaier Members

Joachim Schreibmaier
  • 1 posts

Posted 25 July 2011 - 07:02 PM

Has somebody a workarround to restore images with BESR and the HP Proliant 460c G7 hardware? Does System Recovery 2011 resolve the problem?

Maybe somebody has an hint?

Best Regards,

Joachim



Darren Friedrich Members

Darren Friedrich
  • 124 posts

Posted 12 October 2011 - 06:37 AM

Hello, did anyone manage to resolve this? We're using Deployment Workbench to image VM's hosted on XenServer 6.0 with BL460c G7 hardware. It uses WinPE to to boot. Fails to connect to image share. When I bring up a command prompt I cannot connect to any shares on any server APART from share hosted on VM's on the the same XenServer host.
It's definitely a XenServer nic driver issue as we had similar issues with VM's we exported from our old XenServer 5.6 host (could not join domain, could not connect to shares) and only until we installed XenServer tools would it work.
I've tried to include the xennet drivers extracted from XenServer Tools in the WinPE image but no luck.

Thanks.

Edited by: Darren Friedrich on 12/10/2011 2:37 AM



Stefan Dietzel Members

Stefan Dietzel
  • 3 posts

Posted 12 October 2011 - 06:43 AM

We're searching for a solution too. Till now we find out, that the issue is based on the Realtek network driver. All drivers you can download doesn't work, but the Realtek driver that is integrated/build-in in a SCCM WinPE by default works fine.

So it is more important for us to bring the PV driver for storage up and running, because without that driver the writing performance is very poor!

Best regards,
Stefan



Darren Friedrich Members
  • #10

Darren Friedrich
  • 124 posts

Posted 13 October 2011 - 01:38 AM

Thanks for the information Stefan. I tested winpe on bare metal BL460c G7 and with the updated BL460c G7 nic drivers it worked fine.

I'm going to log a call with Citrix.

Thanks.



Darren Friedrich Members
  • #11

Darren Friedrich
  • 124 posts

Posted 26 October 2011 - 05:29 AM

Just an FYI - I logged a call with Citrix but because WinPE is not a supported OS they said they probably would not have a solution for me.



Cristi BODNARIUC Members
  • #12

Cristi BODNARIUC
  • 5 posts

Posted 25 November 2011 - 10:59 AM

Hello everyone,

I am also trying to create a WinPE image with PV drivers inside.
It seems that only adding the drivers (offline using dism or online using drvload.exe) is not enough.
I have also made a compare file (using regshot before and after xensetup.exe /S /norestart ) and made the registry and file system changes, but I get an image which boots and hangs on "Starting Windows" (it's a 3.0 version - Windows 7 x86).

Any other ideas? It could save some time.

Thanks,
Cristi



Darren Friedrich Members
  • #13

Darren Friedrich
  • 180 posts

Posted 01 December 2011 - 04:57 AM

Hello Cristi,

When you boot with the WinPE image can you confirm if the PV drivers are loading successfully?

ipconfig /all

Thanks,
Darren.



Cristi BODNARIUC Members
  • #14

Cristi BODNARIUC
  • 5 posts

Posted 01 December 2011 - 09:34 AM

Hi Darren,

As I said, the image is loading, but it hangs on "Starting Windows" screen.
I have some other ideas, I'll let you know if I get a working WinPE with PV drivers.

The basic idea is to capture a WinPE image just after running xensetup.exe /norestart, but the only thing I'm afraid of : Windows 7 required a second reboot when I installed XenTools on Windows 7 Enterprise x86.



Darren Friedrich Members
  • #15

Darren Friedrich
  • 180 posts

Posted 05 December 2011 - 04:31 AM

Success!

Citrix provided me with an exe which injected the pvs drivers into the winpe wim.

I am successfully loading winpe image with pvs drivers loaded and can successfully map a network drive now.

Thanks Aaron in support for his persistence with this!

Please ask Citrix Tech Support to refer to ticket# 60635026 if you wish to obtain the exe.

Thanks!



Cristi BODNARIUC Members
  • #16

Cristi BODNARIUC
  • 5 posts

Posted 05 December 2011 - 08:47 AM

That's good news, do you think that it is possible for you to send me the .exe?
Many thanks,
Cristi



John Sadie Members
  • #17

John Sadie
  • 7 posts

Posted 09 December 2011 - 11:49 PM

Would also love to get this exe. As an extra note, I have installed a VM (Win7) into Citrix Xen Server (V5.6 or V6), and then loaded Xen Tools into that VM. I then used that VM to do a backup and restore of a second partition of that same VM, using Storagecraft V4.1.5, and I still got slow restores. I have eliminated any source slowness, and it is definitely just the way Storagecraft software talks to Citrix Xen Server, during restores. Another issue I am trying to prove/disapprove, is whether the slow restores are caused by the actual driver Citrix Xen Server uses for the Adaptec RAID controllers I am using (2402, 2405, 5405). When I install VMWare ESXi on that same hardware, my restores are 13x faster. (39MB/s vs 3MB/s). Any help will be appreciated. Will post further info when available.



John Sadie Members
  • #18

John Sadie
  • 7 posts

Posted 16 December 2011 - 03:01 AM

Today received latest Adaptec RAID drivers for Citrix Xen Server 6, from Adaptec, who was very helpful.

This is quite unlike my experiences with CISCO, who totally refused to help me get any firmware updates for my CISCO IP Phones, even though I was willing to pay for support. But that is another story.

Unfortunately, the new Adaptec drivers made no difference. So I am back to trying to get the LAN drivers from Citrix, who are also quite unwilling to help, as they claim this EXE is "untested", even though I was willing to accept the risk of an "untested" solution, and to test it myself. All this EXE really does is to swap a slow 100MB tested driver, for another faster 1GB driver, without rebooting - how risky could that really be?

To their credit, Storagecraft did help me tremendously, but this is an issue with the WIN PE 7 that Shadowprotect runs on. There even are drivers on the recovery CD for Citrix, but no matter what I do, it just keeps using the slow RTL8139 driver.

So, if anybody has that EXE, or can tell me how to force Shadowprotect to LAN the Citrix drivers, I will be most grateful. Please . . . . . . .



Darren Friedrich Members
  • #19

Darren Friedrich
  • 180 posts

Posted 16 December 2011 - 03:11 AM

If anyone would like the exe and instructions to inject the PV drivers please PM me.

To the people I've already sent it to, a thank you is not too much to ask is it?



John Sadie Members
  • #20

John Sadie
  • 7 posts

Posted 16 December 2011 - 03:50 AM

Darren, sorry to be stupid, but what is is PM?

Any chance to email that to me - johns@intralan.co.nz.

Thankyou in advance, and I will thank you afterwards as well.

It has been a problem for me for months, now.