Jump to content


Photo

After Reverse Image unable to change Computer Name

Started by Scott Curtsinger , 10 March 2011 - 10:39 PM
25 replies to this topic

Scott Curtsinger Members

Scott Curtsinger
  • 122 posts

Posted 10 March 2011 - 10:39 PM

Has anyone seen an issue with Windows 7 where after they have reverse imaged a vDisk they are unable to update the computer name.

The virtual machine boots fine however I had intended to rename that workstation to something else. I went through the process of removing it from the domain and then renaming the workstation. However each time I try to do this after the reboot the Domain and Workgroup fields become greyed out. I'm wondering if this is the behavior of XenConvert or a step that I a missing.

Attached is a screenshot of the fields greyed out. I have restarted the vm multiple times.

Attached Files



James Nixon Members

James Nixon
  • 63 posts

Posted 12 March 2011 - 04:08 PM

Someone may have an easier resolution but when this happened to me a while ago I had to run Sysprep which allowed me to change the name properly.



Scott Curtsinger Members

Scott Curtsinger
  • 122 posts

Posted 14 March 2011 - 05:17 PM

Thanks James,

I tried sysprep thinking that would fix the problem but it didn't.



Pete Clewlow Members

Pete Clewlow
  • 20 posts

Posted 12 April 2011 - 08:00 AM

Did you ever come up with a solution for this. I have the same problem renaming 2003 Server?



Padraig Sweeney Citrix Employees

Padraig Sweeney
  • 1,461 posts

Posted 13 April 2011 - 07:16 AM

So you're reverse imaging and booting directly from the hard disk?

- Padraig.



Anthony Green Members

Anthony Green
  • 13 posts

Posted 28 October 2011 - 04:31 PM

same problem here... windows 2008 r2. Dont know if this is the exact same prob but i can rename the computer to some extent... it changes the hostname but the %computername% value remains as it was before the rename. Server manager shows the old name and displays a message saying the server needs a reboot. Its like the process does not complete fully but never finishes even after reboots.



Thomas Daugaard Members

Thomas Daugaard
  • 10 posts

Posted 22 December 2011 - 12:22 PM

Any news in this case?
We are also seeing this issue.

/Thomas



Thomas Daugaard Members

Thomas Daugaard
  • 10 posts

Posted 18 January 2012 - 10:53 AM

Bump...
Anyone, from Citrix reading?
This is still an issue and we have no solution.

/Thomas



Uwe Klaas Members

Uwe Klaas
  • 157 posts

Posted 18 January 2012 - 03:37 PM

Search the Registry for the former computername and replace it with the new one.
After that you'll be able to change the domain or computer group membership.

Cheers,
Uwe



Raza Rehman Citrix Employees
  • #10

Raza Rehman
  • 114 posts

Posted 22 January 2012 - 08:41 PM

I may not have understood the issue completely, But I want you to try followings.

1.Shutdown VM
2.From PVS console Right Click on VM and Delete The AD Account
3. Go to AD and Create VM account Manually.
4. From PVS Console Right Click On VM and reset the account
5. Logon to the VM as Local Admin and join the domain.

See if this works.

Thanks.



Gabi Schuetz Members
  • #11

Gabi Schuetz
  • 72 posts

Posted 18 December 2012 - 01:25 PM

Same problem here.
Imported PVS VHD disk to XenServer for updating the PVS Target Device Software. But I'm not able to change the computername or to join domain. Workgroup or domain field are greyed out.

I recently was able to set a new computername and it's displayed as computername, but when I run %computername% its still the old name.

I already tried to uninstall the PVS target software and also reinstalled the xentools. Same problem.

Need help quickly, is there any solution now?



hashif vp Members
  • #12

hashif vp
  • 1 posts

Posted 28 March 2013 - 10:55 AM

I am also having the same issue....it happens as soon as i put network enabled. removed all the ctirix apps from ARP but still the issue is persists.

Hashif vp



Shannon Adams Members
  • #13

Shannon Adams
  • 1 posts

Posted 16 April 2013 - 03:32 PM

I am having the same problem also.

I reversed image the server, then uninstalled Target device. Every time I try to rename the server then reboot I get an error message stating "Device Manager is running in read only mode" and device manage is showing the old name.

When I check "Computername" from a command prompt it show the old hostname. However when showing properties on my computer it shows the new name.



Lucien Roelofs Members
  • #14

Lucien Roelofs
  • 13 posts

Posted 19 April 2013 - 09:26 AM

Same problem to me, after reverse from provisioning disk to local disk, not able to change computername or to join domain, (greyed out).
I deleted the Client for Microsoft Networks, rebooted, than added the client.
Works perfectly for us.



Lucien Roelofs Members
  • #15

Lucien Roelofs
  • 13 posts

Posted 19 April 2013 - 09:52 AM

Sorry, responded too soon, still did not work.
Now I have renamed my server 2008r2 in the registry, replaced servername to a different name, and can join again. Succes guys!



Lieven Van de Walle Members
  • #16

Lieven Van de Walle
  • 27 posts

Posted 30 April 2013 - 02:12 PM

Solved by (after sysprep/changing computername) => changing the values in
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ComputerName.

regards,

Lieven



Yann Michalak Members
  • #17

Yann Michalak
  • 191 posts

Posted 20 June 2013 - 09:03 AM

- Same Problem here with PVS 6.1 HotFix 016V2.

- Other Problem :

after when creating machine account from the PVS console ... The machine does not have the right hostname

:-(



Yann Michalak Members
  • #18

Yann Michalak
  • 191 posts

Posted 20 June 2013 - 12:26 PM

Once the vdisk readonly ... hostnames are of this type : see attachment

Attached Files



Yann Michalak Members
  • #19

Yann Michalak
  • 191 posts

Posted 20 June 2013 - 12:29 PM

hostnames are of this type : MAC ADDRESS



Yann Michalak Members
  • #20

Yann Michalak
  • 191 posts

Posted 20 June 2013 - 05:05 PM

All DONE ;-) : How to.......here