Jump to content


Photo

SIlent install PVS Target Device Software

Started by Barry Schiffer , 24 November 2010 - 11:31 AM
9 replies to this topic

Barry Schiffer Members

Barry Schiffer
  • 76 posts

Posted 24 November 2010 - 11:31 AM

I'm trying to do a silent installation of the PVS 5.6 SP1 target device software with RES Wisdom.

On a 64 bits W2K8R2 installations seems to be ok but the "Citrix Virtual Harddisk enumerator PVS" device in device manager is not working. Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

Tried to do the installation with a cmd and a powershell action.

Powershell Script
$installer = "c:\TEMP\PVS\PVS_Device_x64.exe"
$cmd=[System.Diagnostics.Process]::Start($installer,'/s /v"/passive"')
$cmd.WaitForExit()

CMD "c:\TEMP\PVS\PVS_Device_x64.exe" /s /v"/qn"

Both actions work when i start them on the server with the same credentials



Barry Schiffer Members

Barry Schiffer
  • 76 posts

Posted 24 November 2010 - 11:32 AM

FYI having this problem with PVS 5.1 SP2 and 5.6 as well



Chad pyle Citrix Employees

Chad pyle
  • 14 posts

Posted 15 June 2011 - 03:41 PM

Check to see if the following registry key exists:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\CFsDep2

If it does not, go to C:\Program Files\Citrix\Provisioning Services\drivers, right click on cfsdep2.inf and choose install.
Reinstall the driver for the Citrix Virtual Hard Disk Enumerator PVS through device manager, using C:\Program Files\Citrix\Provisioning Services\drivers\cvhdbus2.inf as the driver file.



Andreas Mariotti Members

Andreas Mariotti
  • 20 posts

Posted 19 July 2011 - 01:25 PM

Same issue here. In my point of view this is a Citrix MSI setup bug. This issue occurs when the setup is executed with a software depyloment service instead of an interactive user, see this thread for more details. http://forums.citrix.com/thread.jspa?threadID=283490&tstart=0
Btw the way, same issue with the 6.0 Beta :-(



Corné Bogaarts Members

Corné Bogaarts
  • 43 posts

Posted 13 October 2011 - 12:13 PM

I did both (install CFsDep2 and cvhdbus2), but it doesn't help. I still get the 'vDisk is not available.'-error.

The problem is solved as soon as the PVS Target software is installed using the GUI, instead of via command line.

Edit:
For XenApp 6.5 this is solved in a different way: install XenApp with de commandline parameter '/install:XenApp,_PVDeviceFeature_' (http://support.citrix.com/proddocs/topic/xenapp65-install/ps-install-command-line.html).

Corné

Edited by: bogaartc on 14-okt-2011 6:59



Oliver Woell Members

Oliver Woell
  • 69 posts

Posted 14 June 2012 - 08:24 AM

Hello all,

I have the same problem here and did some troubleshootings. Yes the registry key above is missing.

The error can be reproduced with the following command:

PSEXEC.EXE -s -d "Mycommand.cmd"

In "Mycommand.cmd" I put the following command:

CMD /S /C ""%SWDepot\PVSAgent 5.6 SP1\PVS_Device_x64.exe" /S /v"/qn /norestart /l d:\logs\PVSAgent.log""

We already tested with PVS56, PVS56SP1, PVS6, PVS6.1.

Last week I opened a case at Citrix since the problem can now be reproduced without having a SCCM environment.

Regards
Oliver



Frank Vandebergh Members

Frank Vandebergh
  • 245 posts

Posted 12 November 2012 - 06:40 AM

Hi Oliver, did you get any further with that support case ? A customer has the same issue, and copying the driver files first doesn't help either.



Matthew McCarron Members

Matthew McCarron
  • 8 posts

Posted 27 November 2012 - 10:31 PM

This works for PVS 6.1, not sure if it will help...

XenApp 6.5 w/ slipstreamed CPVS61E001 (replace files in XA6.5_2008R2_ML\Provisioning Services\Device with those in CPVS61E001\Device)

"XenApp Server Setup\bin\XenAppSetupConsole.exe" /install:XenApp,PVDeviceFeature /exclude:XenAppEnhancedDesktopExperience /logfile:C:\Windows\Temp\XenAppSetupConsole.log

CPVS61E004
xcopy %~dp0BNIStack6.sys "C:\Windows\System32\Drivers" /Y
xcopy %~dp0PVS6.1_hf313632_32bit_manifest.md5 "C:\Program Files\Citrix\Provisioning Services" /Y

CPVS61E007
xcopy %~dp0CVhdBusP6.sys "C:\Windows\System32\Drivers" /Y
xcopy %~dp0PVS6.1_hf284511_32bit_manifest.md5 "C:\Program Files\Citrix\Provisioning Services" /Y

Repair VHD Enumerator Driver (PVS)
xcopy /S /E /Y "C:\Program Files\Citrix\Provisioning Services\drivers\CFsDep2" C:\Windows\System32\Drivers\*.

Restart Computer



Robin Harwood Members

Robin Harwood
  • 10 posts

Posted 16 May 2014 - 08:55 AM

Just as an FYI, I just had this problem with PVS 7.1 (as well as the 002 target device update software). The same fix did the trick though.

 

Robin



Trentent Tye Members
  • #10

Trentent Tye
  • 27 posts

Posted 12 April 2016 - 10:05 PM

If anyone is curious, I figured out the root cause of the failure to correctly install/uninstall the PVS Target Device software:

http://trentent.blogspot.ca/2016/04/silent-install-of-citrix-pvs-target.html

 

The root cause is CFSDEP2 is a file system filter driver that requires an interactive session to be successfully installed/removed.  You can use PSEXEC -i -s parameters to start a interactive SYSTEM session to execute the installation/removal.  This appears to be a Microsoft limitation as executing the install using 'rundll32.exe' doesn't work unless you are an interactive session.