Jump to content


Photo

CTRL Key Stuck

Started by Jamie Harrison , 17 November 2010 - 02:12 AM
31 replies to this topic

Jamie Harrison Members

Jamie Harrison
  • 38 posts

Posted 17 November 2010 - 02:12 AM

Hi,

We have recently deployed a XenApp 6 farm to around 60 odd users. We've discovered an issue where users intermittantly discover that their CTRL key is "stuck", and when they try to type on the keyboard they end up triggering various behaviour equivalent to holding CTRL and pushing those keys. It also exhibits the same kind of behaviour with the mouse - selecting multiple files etc.

We've seen and confirmed that one way this seems to occur is when a shadower ends shadowing a session by pressing the trigger keys CTRL + *. The user that was being shadowed then has the CTRL key stuck. However, we've also been having this behaviour where +no shadowing is involved+, and the first time we hear from the user is when they can't figure out what their keyboard\mouse is doing.

I know also of the long-term issue with the RDP client, but RDP isn't technically in play here, or at least the RDP client.

Has anyone else had similar behaviour, or can anyone provide any tips? These servers are pretty generic - XenServer VM's with Server 2008R2 (fully patched), Citrix XenApp 6 with hotfix 1 and 3, and a few other odds and ends like Office 2007, Flash, Adobe Reader, and that's about it.

Thanks in advance



James Rankin Members

James Rankin
  • 76 posts

Posted 09 December 2010 - 10:11 AM

I have seen much the same thing exhibited on a fairly similar setup, except switch VMWare for the XenServers. I've also seen one user who managed to get her £ to stop working, to the extent where she was having to use the ASCII key code to put it in (and she worked in Finance).

I was wondering if it was a problem to do with Citrix Profile Manager. Are you using this as well?



NICOLAS LIN Members

NICOLAS LIN
  • 38 posts

Posted 30 December 2010 - 09:49 AM

We're experience the similar issue, but instead of XenApp6, we're running XenApp 5.0 (xenserver). This issue happened randomly. And yes, we have citrix profile managment implemented in our environment.



Michael Manico Members

Michael Manico
  • 81 posts

Posted 30 December 2010 - 04:27 PM

We have this issue all the time, and we do NOT have citrix profile manager. For us, it's our Wyse winterm's cheap keyboards that seem to cause the issue. We have a user hit there control key each about 5 times when it happens, and it clears it up. Are you all using wyse winterminals?!?! We have had it on 4.0 4.5 and now 6.



James Rankin Members

James Rankin
  • 76 posts

Posted 05 January 2011 - 01:37 PM

We use Chip PCs, but for the record, they have skanky cheap keyboards as well. However it also happens occasionally to users who have expensive shiny keyboards, so I am not convinced it is merely a keyboard issue.



Jamie Harrison Members

Jamie Harrison
  • 38 posts

Posted 10 January 2011 - 04:52 AM

Hi,

Sorry for the delay replying to this.

We don't use Citrix Profile Manager, and have only recently begun the upgrade from PS4 to XenApp 6 and haven't seen this issue in our PS4 farm. Unfortunately for us we have been getting this issue on almost every kind of client device as well (Wyse, XP, Linux, etc). I even had this occur myself when logged in remotely through our Gateway using a Mac client, so that rules out client devices or keyboards for us, unless I'm missing something common to them all.

We are still a bit stumped with this issue and would appreciate any other suggestions or advice.

Cheers



Robin Marchant Members

Robin Marchant
  • 22 posts

Posted 10 January 2011 - 12:50 PM

We are in the process of moving users from a XenApp 5 farm to a XenApp 6 farm. Again the setup is generic at this stage, citrix not installed in a VM but fully patched with Citrix patches 2, 3, 10, 17 and 26.

We have had no issue with the CTRL key under XenApp 5 but for most users moved to the new system the CTRL key supposedly 'sticks' for the first few logon's. Usually logging off and on again resolves the issue but clicking the CTRL key repeately doesn't seem to.

We are using a mix of Wyse winterms (S10 and V10L) with version ThinOS 6.5.0_30 but also Citrix Online plugin ver 12.1 has also experienced the issue.



Karst van der Wal Members

Karst van der Wal
  • 52 posts

Posted 11 January 2011 - 08:49 AM

I deployed the shadow taskbar to my application engineers to shadow users (it has some disadvantages, but a few nice advantages like the ability to quit a shadowed session without leaving the users behind with this problem.



Allen Kyle Members

Allen Kyle
  • 47 posts

Posted 25 January 2011 - 03:30 AM

I don't have this issue at user logon, but I have it about 60%+ of the time when I assist a user by shadowing their session. The combination of CTRL* to end the session leaves them unable to type. They can sometimes tap the control key a few times to clear the issue. Other times they have to log off and back on. It's annoying.



Karst van der Wal Members
  • #10

Karst van der Wal
  • 52 posts

Posted 25 January 2011 - 07:13 AM

This issue should be fixed, but in the meantime we are using the Citrix shadowbar where you can close a shadow session in a different way not leaving the user behind with a sticky ctrl key being pressed.

p.s. I started to prefer the shadowbar all together cause you can have multiple shadow sessions and you don't lose the ability to switch to you own desktop on the fly.



Daniel Marceau Members
  • #11

Daniel Marceau
  • 1 posts

Posted 15 February 2011 - 01:06 PM

Hi!

We are also having this issue at several customers now.
This "bug" appears in Remote Desktop / Tsadmin as well when using the remote control feature.

They are also complaining that the shadow taskbar is not meeting their requirements and are making things more complex.

Im hoping we could find a hotfix soon for this or the possibility to end a shadow session some other way.

Some of our customers are disabling "notify on" when shadowing because users get confused alot.
This setting also removes the "stop shadowing" windows that appears during shadow.

Even if we recommend them to let the user be informed and accept the shadow they want to run it this way

Im thinking of contacting Citrix support and try to get some support...

BR
André



Mathias Vandendriessche Members
  • #12

Mathias Vandendriessche
  • 3 posts

Posted 24 February 2011 - 04:30 PM

we're experiencing the same issue when we shadow a user. We don't use profile manager.
A solution would be nice.
Thanks



Tom Bonnarens Members
  • #13

Tom Bonnarens
  • 3 posts

Posted 11 March 2011 - 08:03 AM

Anyone tried this?

http://support.microsoft.com/kb/978829

Not applicable to our environment though, we run xenapp 6 machines on xenserver 5.6.
Ending a shadow session via the "stop shadowing" button works as expected whereas any combination of CTRL+hotkey leaves the user's session with a stuck CTRL key...

Edited by: tombonnarens on 11-mrt-2011 3:04



Sean Barraclough Members
  • #14

Sean Barraclough
  • 1 posts

Posted 18 March 2011 - 02:29 AM

Hi guys,
i've been in contact with citrix for this issue and have been provided a private hotfix.

Will test it out

Cheers



Jamie Harrison Members
  • #15

Jamie Harrison
  • 38 posts

Posted 18 March 2011 - 02:42 AM

Hi,

Are you able to provide the reference number or CTX number for the hotfix? Not after the hotfix from you, just the reference number would be good in case I can get Citrix to provide the same hotfix.

Cheers



Graeme Dunkley Citrix Employees
  • #16

Graeme Dunkley
  • 6 posts

Posted 18 March 2011 - 11:53 AM

Hi Jamie,

This fix can be found using this KB article: http://support.citrix.com/article/CTX128043

It contains the following fix: Terminating a shadowed session from the Delivery Services Console using a key combination can cause users to loose keyboard and mouse control of their session.

[From XA600W2K8R2X64040][#248234]

Kind regards,

Graeme



Stephen Claeys Members
  • #17

Stephen Claeys
  • 13 posts

Posted 22 March 2011 - 10:23 AM

Tried the hotfix XA600W2K8R2X64040 but the sticky CTRL key after closing the shadow with the CTRL+* combination remains a problem.
Other possible solutions? Shadow bar is not an option.



Lucien Roelofs Members
  • #18

Lucien Roelofs
  • 14 posts

Posted 25 March 2011 - 02:22 PM

Hello there,
Our compay is experiencing the same annoying problemen, after ctrl + * to end a shadowing session, de ctrl is stuck. Sometimes users can gain control over the ctrl key by pressing several times on this key.
Most of the time it works, but sometimes users must logoff after shadowing
I hope a Citrix expert will pickup this problem, because it's since a long time the problem is there, seems that a lot of people (according to several forums) having the same issues !!!

Kind Regards,
Lucien



Mathias Vandendriessche Members
  • #19

Mathias Vandendriessche
  • 3 posts

Posted 18 April 2011 - 07:49 AM

We've installed the hotfix from Graeme Dunkley and it solved the problem.
However we were forced to ask our citrix partner to logon and get the fix. Isn't this hotfix public?



James Rankin Members
  • #20

James Rankin
  • 76 posts

Posted 18 April 2011 - 11:11 AM

Hotfix 040 has resolved this problem for us also