Jump to content


Photo

Mounting CIFS ISO is Failing

Started by Jason Robinson , 16 December 2009 - 03:48 PM
10 replies to this topic

Best Answer Kyle Bassman , 17 December 2009 - 08:49 PM

My bad dude...didn't see you tried IP already. Well, in the console of your xenserver itself, you can add your DNS servers. I did this during the build process, and have no issues with DNS.

I know that you have an IP and a name of course for your cluster, so using that should work, but it obviously cant resolve the IP address. Check out the settings of your XenServer host to see what you got.

Jason Robinson Members

Jason Robinson
  • 157 posts

Posted 16 December 2009 - 03:48 PM

I am really stumped by this one and hopefully someone can help me out.

I originally had all of my ISO's located in a shared folder on a single server. Had absolutely no problem adding the share to XenServer. Now I setup a clustered file server and now I cannot add the ISO's. I get this error in XenCenter:

Unable to mount the directory specified in device configuration request

All of the permissions are correct. I can still mount ISO's from my single server where they were originally stored but any attempt to mount from the clustered file server will not work.

Is this not supported? I can't fathom a reason why it wouldn't be. I have been through a bunch of threads with similar problems and none of the suggested fixes seem to work. I am not much of a Linux person so it is possible I messed something up within the command line.

Any help would be appreciated.



Richard Colley Members

Richard Colley
  • 112 posts

Posted 16 December 2009 - 10:08 PM

Well, you need to try a few simple troubleshooting exercises:

Login to one of your xen servers (dom0, not domU) and then:

ping <FILESERVER>

where you replace <FILESREVER> with the hostname or IP address of your new fileserver.

Did this work? If not, perhaps you have basic network connectivity or firewall issues. There is a chance the next step will still work, so give it a try anyway.

smbclient -L //<FILESERVER>

That may prompt for a password, try just hitting enter. Did it show a list of shares on your fileserver? If not, try:

smbclient -L //<FILESREVER> -U <user>

(replace <user> with a user with permissions to access the fileserver). Did you see a list of shares?

If that doesn't work, but the ping did, then I would say you definitely have some sort of firewall issue.

If that all works, try:

mount -o user=<user>,pass=<pass>,dom=<dom> //<FILESREVER>/<share> /mnt

(Replace <user>, <pass>, <dom>, <FILESERVER>, <share> with appropriate values). If you get no error, do:

ls -l /mnt
umount /mnt

Do you see files on the share?



Jason Robinson Members

Jason Robinson
  • 157 posts

Posted 17 December 2009 - 02:22 PM

This doesn't make any sense to me at all.

Firewall is disabled via Group Policy and there is nothing on the network that prevents access. This clustered file server serves all of my users and there are no access problems at all except with XenServer.

When I ran the smbclient on XenServer I get:

session setup failed: NT_STATUS_LOGON_FAILURE

I am at a loss.



Kyle Bassman Members

Kyle Bassman
  • 527 posts

Posted 17 December 2009 - 08:40 PM

In XenCenter, make sure to use the FQDN of the cluster name.



Jason Robinson Members

Jason Robinson
  • 157 posts

Posted 17 December 2009 - 08:44 PM

If I can't do it by IP address why would I be able to do it by FQDN?

I tried it anyway for giggles and got:

DNS lookup failed: the given hostname could not be resolved

But that is probably due to the fact that I have no idea how to get XenServer to use DNS and that is why I am using IP addresses.



Kyle Bassman Members

Kyle Bassman
  • 527 posts

Posted 17 December 2009 - 08:49 PM

My bad dude...didn't see you tried IP already. Well, in the console of your xenserver itself, you can add your DNS servers. I did this during the build process, and have no issues with DNS.

I know that you have an IP and a name of course for your cluster, so using that should work, but it obviously cant resolve the IP address. Check out the settings of your XenServer host to see what you got.


Best Answer

Marc Litalien Members

Marc Litalien
  • 31 posts

Posted 17 December 2009 - 08:50 PM

Hi Jason,

I had to put my username in this format in order to connect the CIFS share:

domainname.blah.blah\username

The username alone was not enough.

Or if you dont have a domain, use the server name where the share resides, servername\username.

HTH,



Kyle Bassman Members

Kyle Bassman
  • 527 posts

Posted 17 December 2009 - 08:52 PM

Good call. Yes, I had to check the box, and enter the same in as well.



Jason Robinson Members

Jason Robinson
  • 157 posts

Posted 17 December 2009 - 08:52 PM

Actually, we had changed the IP address of our DNS servers and the old IP address was still in XenServer. So inadvertantly you solved my problem. Once I changed the IP address of the DNS servers in XenConsole I was able to add the CIFS ISO Library.

Thanks, I feel stupid now.



Kyle Bassman Members
  • #10

Kyle Bassman
  • 527 posts

Posted 17 December 2009 - 08:57 PM

Even with my domain name and DNS IP's entered @ build...I still use the FQDN when adding my ISO CIFs. No mater how you find the fix, it's always good. You got a good way of updating Provisioning Server vDisks to newer versions of the target device software (.i.e. 5.1) ?



Tom Sheckells Members
  • #11

Tom Sheckells
  • 2 posts

Posted 13 September 2017 - 11:10 PM

When I set up Xenserver 7.2, mapping the CIFS shares was a headache. After lots of Googling I found a command line method to do the mount. Then, I played around a little and tried this:

 

UserName:  MyNasID,dom=corp,vers=3.0

Password:    *******

 

MyNasID is the AD domain ID I set up for the storage array. The "corp" is my domain id (like in corp\Teranas), and the final critical part is add the vers=3.0. Once I put the UserName in that way, I could mount the CIFS shares. Just FYI, since I was doing mounts for ISOs it wanted a directory of ISO files. I had to use a 3 part name, like \\computername\sharename\directory name. This was because I had my ISO files categorized into Windows version shares, Centos Linux shares, FreeBSD Linux shares, and so on. 

 

Good Luck and HTHs....