Jump to content


EdgeSight for XenApp Agent Uninstall Fails

Started by Guest , 19 September 2008 - 08:50 AM
3 replies to this topic

Guest Members

  • 64 posts

Posted 19 September 2008 - 08:50 AM


I'm attempting to uninstall the EdgeSight for XenApp Agent from my Windows 2003 XenApp Server.

I've tried using Add/Remove programs, and running the .msi file directly, both options result in the same outcome which is as follows:

The dialog for the installation appears and I get two options
1) Repair
2) Remove

If I pick Remove, it appears to do something and then suggests a reboot is required.

After rebooting, the entry still appears in Add/Remove Programs and I can repeat the above steps forever.

Looking in Program Files it would appear to have removed most of the installation files (I have to admit, having tried this a few times, and manually removing files as well, I'm not sure which aspects the uninstall routine actually removed)

My issue really, is that I'm not able to re-install the Agent.

Running the 'repair' option doesn't appear to do anything either.

What are the steps I need to perform to manually remove the agent completely so that I can re-install it cleanly.

Kind regards


Edited by: Simon Jackson on 19-Sep-2008 09:51

PS: I should add that this is EdgeSight 5.0

Vincent Papoz Citrix Employees

Vincent Papoz
  • 390 posts

Posted 19 September 2008 - 09:13 AM

Hi Simon,

I would do the following:

1 - Check that the following 3 services are not present:

Citrix End User Experiencing Monitoring,
Citrix System Monitoring Agent
Firebird Server - CSMInstance

2 - Make sure there is no "System Monitoring" folder under "Documents and Settings\All Users\Application Data\Citrix"

3 - Check Program Files\Citrix for any content related to Edgesight:

System Monitoring

4 - Check registry: HKLM\Sw\Citrix for

System Monitoring


Guest Members

  • 64 posts

Posted 19 September 2008 - 10:49 AM

Hi Vincent

I have deleted the following entries if they existed

HKLM\software\Citrix\System Monitoring

C:\Program Files\Citrix\EUEM
C:\Program Files\Citrix\System Monitoring

C:\Documents and Settings\All Users\Application Data\Citrix\System Monitoring

I then tried the uninstall of the agent again
After a reboot I'm still left with the following service (though it is set to manual and not running)
Citrix End User Experience Monitoring

At this stage an attempted re-installation still prompts me for

Guest Members

  • 64 posts

Posted 19 September 2008 - 10:51 AM


I've fixed it....
I tried doing the following, to send you a log of what happened.....
msiexec /uninstall edgsightzaagent.msi /l logfile.txt

And this command line actually worked, and successfully removed the service

I am now able to re-install again...

It's weird that using Add/Remove components and selecting remove, doesn't call the same routine.....
Maybe this is something you could fix?