Jump to content


Photo

Continuosly disconnect to Citrix

Started by Jose Luis Romero Tapia , 31 May 2007 - 09:33 PM
3 replies to this topic

Jose Luis Romero Tapia Members

Jose Luis Romero Tapia
  • 2 posts

Posted 31 May 2007 - 09:33 PM

Hi team, since a couple weeks we have a problems with some clients, this continuosly disconnects and reconnects by Citrix server. This issue was fixed temporarily deleting a key of windows registry HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing.
But, before a couple hours the problems come back and the registry key back to appears.
A user with this problems uses other laptop and the problem persists, even when this laptop didnt have the problem in the past.
Thanks for your support.
Regards.



Konrad Ruess Members

Konrad Ruess
  • 2,808 posts

Posted 03 June 2007 - 05:09 PM

Hi and welcome to the forums!

The registry key you are mentioning has definitely nothing to do with the described problem. These values will always 'come back' to the client as soon as the 1st user successfully establishes a terminal server session because that subkey hosts the MS TS license information (TS CAL). Without that, no TS session would be possible.

Disconnects usually are caused by:
- network timeouts (mainly WAN / WLAN issues)
- high server load (CPU, disk)
- bad TCP stack or TCP settings
- firewall session timeouts

Have a look at:

WWAN Optimization WP:
http://support.citrix.com/article/CTX101602

Session disconnects:
http://support.citrix.com/article/CTX113351

You might want to try enabling TCP keep-alive or a increase TCP retransmission counter. Smaller ICA packet size might also be an option.

But 1st of all, analyse your environment (wireshark, etc) to find the root cause.

BfN, Konrad

By the way: Assigning points to your questions (and rewarding them at the end of course) attracts more readers and helpers, too... ;)



Jose Luis Romero Tapia Members

Jose Luis Romero Tapia
  • 2 posts

Posted 04 June 2007 - 02:18 PM

Thank you very much.



Konrad Ruess Members

Konrad Ruess
  • 2,808 posts

Posted 04 June 2007 - 02:39 PM

de nada.