Jump to content


Photo

Bluescreen - error 1003 - vdtw30.dll

Started by Paul Mainstone , 19 April 2007 - 09:34 AM
31 replies to this topic

Paul Mainstone Members

Paul Mainstone
  • 13 posts

Posted 19 April 2007 - 09:34 AM

Hi

I am getting Blue screens quite frequently through the day on some of my PS4.5 servers which hosts a desktop to about 60 users. The STOP error is;

(1003)

Error code 1000008e, parameter1 c0000005, parameter2 bfabd940, parameter3 b8810aa0, parameter4 00000000.

It seems to be the vdtw30.dll driver causing the problem

I have tried disabling speedscreen, but still randomly blue screens.

Any ideas?

Thanks Paul



Ron Broaddus Members

Ron Broaddus
  • 1 posts

Posted 02 May 2007 - 06:22 PM

similar problem but diff version of Pres
we have 3 server farm, all HP DL360 G3 running Win 2003 R2 Server and Citrix Pres v4 with latest hotfix.

finally caught a blue screen that showed

vdtw30.dll

as the supposed culprit. Only 1 of the 3 servers is having a problem and the problem started as a user was trying to access a specific webpage - we have not been able to duplitcate except 1 time directly after the user problem where I accessed the webpage while logged-in as the Administrator on the server console. SPLAT!

Since that time, last week, the problem recurs regardless of number of users on the server (between 5 - 20). Use is fairly standard among users. Not able to tell if crashes are coincidental with continued access of the webpage.



Paul Perine Members

Paul Perine
  • 1 posts

Posted 23 May 2007 - 04:05 AM

Got the same issue as TOM.

Farm is eight MF4 x64 on Windows 2003 SP1 x64
Servers randomly crash with vdtw30.dll and iexplore.exe displayed in the minidump.
All systems have IE6.

Have latest Hotfixes installed with no resolution.

Any ideas Citrix?



Mark Taylor Members

Mark Taylor
  • 4 posts

Posted 07 June 2007 - 07:07 PM

Same Issue here

*****************************************************************************

Bugcheck Analysis

*****************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 8E, {e0000017, bfa7a295, ba854d98, 0}

*** ERROR: Module load completed but symbols could not be loaded for vdtw30.dll
Page efe37 not present in the dump file. Type ".hh dbgerr004" for details
Page efdeb not present in the dump file. Type ".hh dbgerr004" for details
Probably caused by : vdtw30.dll ( vdtw30+3c295 )

[From Hotfix MPSE300W2KR03][#106798]

35. Servers on which SpeedScreen Browser Acceleration was enabled would unexpectedly restart at periodic intervals with memory dumps indicating the vdtw30.dll video driver to be at fault. The issue occurred due to improper error handling when older clients, which do not support ThinWire2 mode, were connected to the servers in ThinWire1 mode.

From PS3 is was supposedly fixed but now, Running PS4.0 R03 on Windows 2003 R2 with sp2
No word from Citrix yet on this problem in PS4.0....

Message was edited by: martay



Administrator Administrators

Administrator
  • 2 posts

Posted 12 July 2007 - 05:20 AM

Looks like there is a combined hotfix that should sort this out for 4.0 servers.

http://support.citrix.com/article/CTX113512

5. Servers might experience a kernel trap (Stop 8e) when accessing vdtw30.dll.

[From PSE400R03W2K3020][#159637, 160429]



Aaron Peters Members

Aaron Peters
  • 1 posts

Posted 01 August 2007 - 06:31 PM

Did anyone ever get a response on a fix for this? Curretnly running the x64 version of PS 4 on Windows 2k3. This problem is killing our farm.



Administrator Administrators

Administrator
  • 2 posts

Posted 01 August 2007 - 06:45 PM

Same problem, but on X86 2003 SP2.
Solved with PSE450W2K3021 and, if not installed 3021, with R01.

If you are talking about PS4 and not PS45, wrong forum :-).



Administrator Administrators

Administrator
  • 2 posts

Posted 30 August 2007 - 05:41 AM

R01 for X64 Win2003 has this listed as fixed.

http://ctxex10.citrix.com/article/CTX112619

Mind you it was listed as fixed in two hotfixes POST R03 for PS4.0 so who knows whether it actually is fixed ;)



Administrator Administrators

Administrator
  • 2 posts

Posted 26 September 2007 - 07:50 PM

I'm having the same problem. Windows x86 2003 R2 w/ SP2 on PS4.5

Several times a day the server blue screens with:
STOP: 0x0000007E - vdtw30.dll

I have installed:
PSE450W2K3015
PSE450W2K3021
PSE450W2K3R01 - Roll Up
PSE450R01W2K3011

It will blue screen with only one or multiple users. Sometimes hours apart or only minutes.

Any ideas?



Harry Kleinsmit Members
  • #10

Harry Kleinsmit
  • 5 posts

Posted 15 October 2007 - 03:16 PM

Same prob here.
*.dmp file always refers to vdtw30.dll, but every different hotfix version does not seem to help.
Anybody any ideas?
Speedscreen is off, everone is on version 10 or 10.1 cliënt and today we started off with 2 crashes.



Chad Sanders Members
  • #11

Chad Sanders
  • 11 posts

Posted 16 November 2007 - 03:54 PM

Has anyone resolved this yet? I have Citrix 4.5 with roll up 1. I have 2 servers crashing with the dump pointing to vdtw30.dll. The crash is the 7E exception. I would appreciate any help.



Harry Kleinsmit Members
  • #12

Harry Kleinsmit
  • 5 posts

Posted 21 November 2007 - 10:11 PM

Just Finished installing a seccond Citrix server in order to get some much needed redundancy.
Guess what?
After the first cliënt moved to nr 2 it also crashed :-(

So a working vdtw30.dll would be great!*

* or other working sollutions off course.

Tia David



Alan Osborne Members
  • #13

Alan Osborne
  • 501 posts

Posted 23 November 2007 - 09:23 AM

New hotfix available that mentions vdtw30.dll here:

http://support.citrix.com/article/ctx115275

Cheers,

Alan Osborne
President
VCIT Consulting - providing Small and Medium businesses with a complete virtual computer system - delivered over the web and available wherever you go.
web: www.vcit.ca
blog: www.remote-desktop.ca



Jeff Whitehead Members
  • #14

Jeff Whitehead
  • 181 posts

Posted 28 November 2007 - 03:17 AM

I have a customer experiencing this issue on 4 different servers. All dump files point to vdtw30.dll with exception 0x0000007E. The servers are all 64-bit.

R01 and all hotfixes including the most recent two PSE450R01W2K3X64019 and PSE450R01W2K3X64020 are installed and we are still experiencing the issue.

Anybody found a fix for this yet?

Thanks in advance,
Jeff



Alan Osborne Members
  • #15

Alan Osborne
  • 501 posts

Posted 28 November 2007 - 05:35 AM

So PSE450R01W2K3035 doesn't fix the problem?



Alan Osborne Members
  • #16

Alan Osborne
  • 501 posts

Posted 28 November 2007 - 05:36 AM

Oops, sorry Jeff, just noticed you are running x64...



Harry Kleinsmit Members
  • #17

Harry Kleinsmit
  • 5 posts

Posted 28 November 2007 - 08:34 AM

Hi Alan,

Our 2 Citrix servers are 32bit and I have (as soon as I saw the description in the hotfix and got over the initial stages of sheer joy) applied the 35 hotfix.
However one of the servers already crashed again the next day. So it does not appear to have fixed the bug.
Just to be sure I re-applied the hotfix on that server and will update this threat when needed.

David



Alan Osborne Members
  • #18

Alan Osborne
  • 501 posts

Posted 28 November 2007 - 09:00 AM

Hi,

Looks like other folks have hacked this by copying the original vdtw30.dll file from the CPS 4.5 CD to replace the one installed by R01:

http://support.citrix.com/forums/thread.jspa?forumID=137&threadID=92578&start=15&tstart=0



Chad Sanders Members
  • #19

Chad Sanders
  • 11 posts

Posted 28 November 2007 - 02:20 PM

I have tried all of these tips and nothing has worked so far. I have experimented with many versions of the .dll file and we are still getting bluescreens.



Harry Kleinsmit Members
  • #20

Harry Kleinsmit
  • 5 posts

Posted 12 December 2007 - 08:47 AM

Same here,
On one of the servers I replaced the .dll with the original, because I couldn 't remember if I had done that already, but nope not a better week.
By now I bringing one of the servers back to PS4, after 2! months of crashes the cliënts and I have had it with 4.5. I would love to start 2008 with a stable server.

David