Jump to content


Photo

PVS 7.8 DedicatedDumpFile.sys being created

Started by Rombout Baas , 20 April 2017 - 12:36 PM
2 replies to this topic

Best Answer Carl Fallis , 20 April 2017 - 07:21 PM

The bnistack can automatically configure this for the same drive as your cache drive, this should have been disabled by default but it is turned on in PVS 7.8 (and later releases).  You can disable this by adding the following registry key to the target device (while in private image mode to make sure it persists):

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\bnistack\Parameters

 

                                       EnableDedicatedDumpFile DWORD 0 

 

then reboot and it should not create the dedicated dump file, make sure you have deleted the original.

 

Carl

Rombout Baas Members

Rombout Baas
  • 4 posts

Posted 20 April 2017 - 12:36 PM

We are streaming Windows 2008R2 with XenApp 6.5 with rollup 7.
Provisioning software 7.8
With all our golden images we see a "dedicateddumpfile.sys" file on the persistent drive D:
 
This has been posted before, but none of the suggested ideas worked for us.
 
 
What we tried
 
Virtual memory settings:
Manual setting the page file on the persistent drive D:
tried: Dedicated page file with min=6144 and max=6144
tried: System managed size
tried: No paging file
 
Registry settings tried:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl
tried: CrashDumpEnabled = 3
tried: CrashDumpEnabled = 0
tried: deleted the key CrashDumpEnabled
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\bnistack
tried: EnableDedicatedDumpFile = 0
 
The registry settings have been tried with a reversed image. (as suggested in the previous post)
 
Through the GUI: "Write debugging information"
Set to "None"
Set to "Small Dump"
 
Size of the persistent drive D: (Our C: drive (streamed) is 80gig)
tried: 40gig
tried: 60gig
tried: 80gig
 
Within provisioning: Access mode
Cache in device RAM with overflow on hard disk (2048)
Cache in device RAM with overflow on hard disk (64)
Cache in device hard disk
Cache in device RAM (4096)
 
Only setting the image in private mode (access mode) and removing the key DedicatedDumpFile from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl works.
When the image is rebooted (acces mode is still private), the dedicateddump file will not return.
But when the image is put back to standard image (access mode) the dedicated dump file is back, also the registry key is back.

 



Carl Fallis Citrix Employees

Carl Fallis
  • 978 posts

Posted 20 April 2017 - 07:21 PM

The bnistack can automatically configure this for the same drive as your cache drive, this should have been disabled by default but it is turned on in PVS 7.8 (and later releases).  You can disable this by adding the following registry key to the target device (while in private image mode to make sure it persists):

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\bnistack\Parameters

 

                                       EnableDedicatedDumpFile DWORD 0 

 

then reboot and it should not create the dedicated dump file, make sure you have deleted the original.

 

Carl


Best Answer

Rombout Baas Members

Rombout Baas
  • 4 posts

Posted 21 April 2017 - 09:54 AM

Hi Carl,
 
Thank you for your help.
It works!
 
When I used EnableDedicatedDumpFile, I put it in the wrong location.