Jump to content


Photo

XenApp 7.12/13, Server 2016 desktop icons flickering

Started by Jan Krajcik , 10 April 2017 - 10:13 AM
16 replies to this topic

Jan Krajcik Members

Jan Krajcik
  • 11 posts

Posted 10 April 2017 - 10:13 AM

I wonder if anyone has seen the desktop icons flickering issue in combination of Server 2016, XenApp 7.12 or 13, redirected desktop?

 

We have already tried all suggested fixes out there on the internet, none of them has fixed it.

 

The icons mainly flicker when you open and browse folders.

 

In my testing I've noticed the flickering starts as soon as the VDA is installed and server rebooted. It happens in VM console, RDS and ICA sessions as well.

We also use UPM

 

Any ideas please?

 

Many Thanks,

 

Jan



Oliver Monigatti Members

Oliver Monigatti
  • 98 posts

Posted 12 April 2017 - 02:24 PM

Hi Jan

 

We have the same behavior on Windows Server 2016 with XenApp 7.11.086 and redirected desktop folder. We have also UPM 5.7.0.13003 active for users.

 

At the moment, we have found a way to reduce the problem or prevent it for the existing session.
If the user changes the option "Launch folder windows in a separate process" (activated or deactivated) in Windows Explorer, the flickering stop.

 

Does this option help you also?

 

So far we have not been able to narrow down the effective problem. I think we can probably exclude a redirect problem because we have the issue also with no redirect. UPM would still be possible or the Windows Server 2016 itself.

For XenApp, we have the problem from version 7.11 to 7.13.

 

Best regards,

Oliver



Panteraa Members

Wolfgang Germ
  • 19 posts

Posted 12 April 2017 - 05:09 PM

I can confirm this too.

I am preparing a unattended-installation for VDAs based on Server 2016 in my test-Environment (Hyper-V).

I use a original 2016 ISO. On the first task-sequence my program installs the pre-reqs. (windows-roles like RDS)

The second task-sequence installs XenApp VDA 7.12 or 7.13.

 

After this installation the Desktop-Icons (and original pinned-apps in taskbar too?) start flickering.

There is no folder-redirection or something special this time.

Looks very ugly to me ... and believe me ... when setting up my unattended-installation I have installed more than once ;-)



Jan Krajcik Members

Jan Krajcik
  • 11 posts

Posted 13 April 2017 - 07:15 AM

Thanks for your responses. Thought I was alone with this issue :).

 

I guess the scale of the problem depends on the end user noticing it (most likely if they have more desktop icons).

 

You're both right, it happens regardless of redirected desktop.

 

My colleague has noticed that even opening the Folder Options > View window and clicking OK without making any changes fixes the flickering for that session. Then it's back to flickering after log off / on.

 

This is a very strange behavior, and I hope Citrix will fix it soon.



Paul Mathews Members

Paul Mathews
  • 74 posts

Posted 13 April 2017 - 09:51 AM

We had a similar issue and we removed the 'Task View button' from the task bar. We found that using 'task view' would cause the issue.



Jan Krajcik Members

Jan Krajcik
  • 11 posts

Posted 13 April 2017 - 11:28 AM

Thanks Paul. Will give it a try.



Jan Krajcik Members

Jan Krajcik
  • 11 posts

Posted 13 April 2017 - 02:19 PM

Just tried removing the Task View button. Unfortunately it hasn't fixed it.



Florian Dürr Members

Florian Dürr
  • 8 posts

Posted 19 April 2017 - 08:44 AM

We had the same problems. our workaround was to disable preview handlers in preview pane in the folder options 



Jan Krajcik Members

Jan Krajcik
  • 11 posts

Posted 19 April 2017 - 09:13 AM

Thanks Florian.

 

I've just tried it. It works within user session, unfortunately the problem is back after log off / on.

 

It appears that any change made under Folder Options will temporarily fix it for the duration of user session.



Florian Dürr Members
  • #10

Florian Dürr
  • 8 posts

Posted 19 April 2017 - 09:22 AM

i created a gpo to set this for all users



Oliver Monigatti Members
  • #11

Oliver Monigatti
  • 98 posts

Posted 19 April 2017 - 03:08 PM

Hi Florian

Unfortunately, I could not solve it via Folder Preference (GPO Preference). Can you tell me how you solved it by GPO?

Many thanks!

Regards,

Oliver



Florian Dürr Members
  • #12

Florian Dürr
  • 8 posts

Posted 20 April 2017 - 06:39 AM

Hi Oliver

 

I did it with via Folder Preference (GPO Preference). uncheck Show preview handlers in preview pane and under Common: check Run in logged-on user's security context

 

Regards,

Florian



Jan Krajcik Members
  • #13

Jan Krajcik
  • 11 posts

Posted 20 April 2017 - 02:53 PM

Hi Florian,

 

I've tried the GPO config you recommend unfortunately the issue persists.

 

Regards,

 

Jan



Jan Krajcik Members
  • #14

Jan Krajcik
  • 11 posts

Posted 20 April 2017 - 03:17 PM

All my testing so far has been focused on using thin clients, RDS and VM console sessions. Using any of these the desktop icons flicker.

Just noticed that if I connect from a Windows 10 laptop with Citrix Receiver 4.6 or 4.7 installed, the icons don't flicker... How odd is that?



Florian Dürr Members
  • #15

Florian Dürr
  • 8 posts

Posted 20 April 2017 - 05:00 PM

How Looks it on user session? is the preview pane unchecked?



Oliver Monigatti Members
  • #16

Oliver Monigatti
  • 98 posts

Posted 21 April 2017 - 08:55 AM

Hi Oliver

 

I did it with via Folder Preference (GPO Preference). uncheck Show preview handlers in preview pane and under Common: check Run in logged-on user's security context

 

Regards,

Florian

Hi Florian

Thanks for your explanation. I have already implemented it just like you. Unfortunately, it does not work in my environment.
The setting is disabled by the GPO, so the GPO works perfect.

Regards,

Oliver



Florian Dürr Members
  • #17

Florian Dürr
  • 8 posts

Posted 24 April 2017 - 11:46 AM

Hi Oliver

 

i added a second setting in 

 

Hi Florian

Thanks for your explanation. I have already implemented it just like you. Unfortunately, it does not work in my environment.
The setting is disabled by the GPO, so the GPO works perfect.

Regards,

Oliver

 

i added a second setting: always show icons, never thumbnails

regards