Jump to content


Photo

XenServer 7.1 install errror: Failed to create root filesystem

Started by Morten Koppel , 09 March 2017 - 07:42 PM
8 replies to this topic

Morten Koppel Members

Morten Koppel
  • 4 posts

Posted 09 March 2017 - 07:42 PM

Reporting an error with XenServer 7.1 installation

 

- Error message: Failed to create root filesystem: mke2fs 1.42.9.... Images attached

- Verified via Ctrl+Alt+Fn that /dev/sda1 is present

- Hardware: HP DL160 G6, BIOS version 2013.07.01  Rev. A

- Image: XenServer-7.1.0-install-cd.iso , SHA-256 B6632FCDACFAD4F2053DF9B496A198A29D8672F664B87258425FB27B3D0DF880

   - Download checksum verified

   - Installation source verified

- Seems similar to http://discussions.citrix.com/topic/378250-xenserver-7-wont-clean-install/

 

 

 

Attached Thumbnails

  • 20170308_XenServer_install_error.jpg
  • 20170308_XenServer_install_retry_error.jpg


Tobias Kreidl CTP Member

Tobias Kreidl
  • 17,951 posts

Posted 09 March 2017 - 08:27 PM

Hi, Morten, and welcome first of all to the forum!

 

By any chance, is this a software RAID configuration (if so, it's not supported)?

 

-=Tobias



Morten Koppel Members

Morten Koppel
  • 4 posts

Posted 10 March 2017 - 08:23 PM

Hi Tobias, thank you.

 

- Server controller is in AHCI mode, no fakeraid is enabled

- Disks were previously tested with Xenserver 7 mdraid,  partitions deleted and disks quick formatted.

- I attached a screenshot. It was made right after the installation error appeared. Seems it finished making partitions: 

https://s13.postimg.org/7ce1fwwxj/20170308_Xen_Server_install_error_partitions.gif

 

Any thoughts?



Morten Koppel Members

Morten Koppel
  • 4 posts

Posted 12 March 2017 - 10:38 PM

Clean install did fine with 1TB disk, but not with 3TB. Also without creating local storage, no error appears with 3TB disks. Xenserver install/backend script can't handle creating local storage above 2TB?



Alan Lantz Members

Alan Lantz
  • 6,690 posts

Posted 13 March 2017 - 02:04 PM

Doesn't surprise me to have a 2TB limit, I don't have any local disks this large so I am not seeing this yet. Can you install XenServer without creating local storage then create the local storage post install ? 

 

--Alan--



Tobias Kreidl CTP Member

Tobias Kreidl
  • 17,951 posts

Posted 13 March 2017 - 03:27 PM

Can't access more than 3 TB initially or what you could do is to specifiy no local SR during the installation process and build one or more < 2TB local SRs manually later carved out of the remaining space.

 

-=Tobias



Hung Pham Members

Hung Pham
  • 94 posts

Posted 17 March 2017 - 04:17 PM

I am facing to the same problem, even with small disk like 160GB. During the installing preparation, I confirmed that the current data will be erased. But it seems that the installation process doesn't format the disk.

 

Any idea?

Thanks.



Morten Koppel Members

Morten Koppel
  • 4 posts

Posted 19 March 2017 - 09:41 AM

Found the reason of failure:

 

- didn't investigate deeply, but as Tobias mentioned in his earlier post, the main problem was that mdadm RAID blocks still existed on old HDD, softraid was not properly removed or disk not entirely wiped. XenServer install found them and listed as devices.

 

- solution was to remove mdadm RAID information from disk before the installation.



Tobias Kreidl CTP Member

Tobias Kreidl
  • 17,951 posts

Posted 20 March 2017 - 12:35 AM

Cool, glad you're back in business, Morten!

 

-=Tobias