Jump to content


Photo

Exception in 'update_vbds': Division_by_zero.

Started by Xavier Majoral Clols , 13 February 2017 - 10:16 AM
8 replies to this topic

Xavier Majoral Clols Members

Xavier Majoral Clols
  • 28 posts

Posted 13 February 2017 - 10:16 AM

Hi,

we have five dell machines as a XenServer 6.5 pool with all patches until XS65ESP1047

We are getting this message in xensource log file:

 

Feb 13 10:55:15 <my_host> xcp-rrdd: [debug|<my_host>|0 monitor|main|rrdd_main] Exception in 'update_vbds': Division_by_zero. Defaulting this value.
 

we thought it is related to some problem is storage, but we don't know where to start from.

We get the line in the master server each 5 seconds. Perhaps some kind of vbd information is corrupted.

 

Please, can anybody help us with this?

 

Thanks in advance.

 

Frank.

 



Boby John Members

Boby John
  • 725 posts

Posted 13 February 2017 - 04:18 PM

HI Xavier,

 

Can you check if you are able to see the disk performance data in XenCenter for the VMs? 



Xavier Majoral Clols Members

Xavier Majoral Clols
  • 28 posts

Posted 14 February 2017 - 06:40 AM

Hi John,

thanks for your answer. It seems like performance disk has fallen to 0 since yesterday. So you are in the right way.

What it can be?



konvikkt1 Members

kon vikkt
  • 774 posts

Posted 14 February 2017 - 11:42 AM

Hi John,

thanks for your answer. It seems like performance disk has fallen to 0 since yesterday. So you are in the right way.

What it can be?

AFAIK..as I experienced one. Sad part is, it was resolved automatically, so unable to figure out the root cause. 

May be a ticket with Citrix might help in resolving the issue. 



Xavier Majoral Clols Members

Xavier Majoral Clols
  • 28 posts

Posted 15 February 2017 - 08:40 AM

Thanks John for your answer.

 

Any Citrix guy could help us with this please?



Boby John Members

Boby John
  • 725 posts

Posted 16 February 2017 - 04:37 PM

Hi Xavier,

 

This seems to be a known issue , please report it to Citrix Support 



Xavier Majoral Clols Members

Xavier Majoral Clols
  • 28 posts

Posted 17 February 2017 - 07:18 AM

I would like to open a case but unfortunately we don't have a support agreement.

So I wondered if any advanced Citrix experienced user could help me with this.

 

Thanks



Xavier Majoral Clols Members

Xavier Majoral Clols
  • 28 posts

Posted 24 February 2017 - 09:47 AM

Hi,

today at 05:29 messages ended, no idea why, and I can see disk performance again.

It would be nice some Citrix person could tell us about this.

 

Thanks.



konvikkt1 Members

kon vikkt
  • 774 posts

Posted 27 February 2017 - 06:26 AM

I saw the exact similar thingy  but never saw that again unfortunately. :(