Jump to content


Photo

MAS 11.1 51.21 HDX Insight not working

Started by Rody Kossen , 06 January 2017 - 02:06 PM
22 replies to this topic

Rody Kossen Members

Rody Kossen
  • 59 posts

Posted 06 January 2017 - 02:06 PM

Hi,

 

I recently updated our MAS to build 51.21 ( from the previous 50 build ).

I noticed today that the HDX insight is not working any longer.

 

It displays 0 users. The Web insight and gateway insight are working. We also didn't change anything to the AppFlow settings.

I already tried to disable / enable AppFlow but this doesn't fix the problem.

Do you need to enable the general option NetScaler Gateway on the Appflow settings page?

 

Our NetScaler VPX is on version 11.1 build 50.10nc



Greg Ramsaran Members

Greg Ramsaran
  • 25 posts

Posted 30 January 2017 - 10:25 PM

We opened a ticket with Support on this. Not sure where the problem is yet, I'll keep you updated on this.



Rody Kossen Members

Rody Kossen
  • 59 posts

Posted 31 January 2017 - 12:37 PM

Hi,

 

 What XenDesktop version are you running?

 

I have also created a support case and they responded that XD7.8 ( which we are running ) is not compatible with NMAS.

They told me that I need to upgrade to 7.9 or higher but I'm not satisfied with that answer because the previous build was working correctly and upgrading is not that simple in large environments...



Greg Ramsaran Members

Greg Ramsaran
  • 25 posts

Posted 01 February 2017 - 02:00 PM

Hi Rody,

XD 7.12 on all components. NetScaler build is 11.1.50.10 nc.

There are way too many bugs on the latest version of MAS, I can't speak for the NS as it seems to be collecting and sending the data to MAS.



Rody Kossen Members

Rody Kossen
  • 59 posts

Posted 01 February 2017 - 02:06 PM

Hi Greg,

 

Strange.. That build worked for us with XD7.8 but the newer build 11.1 51.21 is not working.

According to Support the NMAS is not receiving the HDX session start from the VDA so it's not collecting data.

You are correct that is still a buggy product and it's not production ready.

 

We have also issues that some counters are not always working and things like GEO IP Maps are living their own live and deciding on their own if they want to work or not..



Vignesh Kumar Citrix Employees

Vignesh Kumar
  • 7 posts

Posted 08 February 2017 - 09:44 AM

Hello Rody,

 

There is a new release of NMAS 11.1-51.26 in which some of the critical bugs have been fixed. Please proceed to upgrade and let us know of any issue.s



Rody Kossen Members

Rody Kossen
  • 59 posts

Posted 09 February 2017 - 12:32 PM

Hello Rody,

 

There is a new release of NMAS 11.1-51.26 in which some of the critical bugs have been fixed. Please proceed to upgrade and let us know of any issue.s

 

Hi Vignesh,

 

I have updated to the latest release but it is still as buggy as it was...

All the counters are not working, even the normal Web monitoring is not working correctly.

 

NMAS is a very cool product but needs to make some steps in stability



Jeff Riechers Members

Jeff Riechers
  • 254 posts

Posted 09 February 2017 - 09:23 PM

I upgraded to 11.1-51.26, still no HDX data.



Ankur Pandita Citrix Employees

Ankur Pandita
  • 244 posts

Posted 10 February 2017 - 03:05 AM

Hello Jeff,

 

Can you disable ulfd mode  by executing below command and check if its working after disabling it on netscaler

 

command to execute to disable it on ns:

 

disable ns mode ULFD

 

--ankurp



Barry Schiffer Members
  • #10

Barry Schiffer
  • 5 posts

Posted 13 February 2017 - 12:02 PM

I have the exact same issue and disable ulfd fixed it. What does ulfd do? What do I miss now it's disabled?



Ankur Pandita Citrix Employees
  • #11

Ankur Pandita
  • 244 posts

Posted 13 February 2017 - 12:22 PM

Hello Barry,

 

Sorry to hear that you also encountered this issue.This is a known issue and will have a fix in future release.

 

--ankurp



Adrian Brugger Members
  • #12

Adrian Brugger
  • 24 posts

Posted 14 February 2017 - 07:07 AM

Disabling ULFD also fixed the issue for me with version 11.1 51.26


Helpful Answer

Matt Pinnell Members
  • #13

Matt Pinnell
  • 109 posts

Posted 14 February 2017 - 09:11 AM

Disabling ULFD also worked for us, support tell me this is tracked under Issue ID : 0675968 and due for a fix in the 12.0 release in early Q2.


Helpful Answer

Prince Prakash Citrix Employees
  • #14

Prince Prakash
  • 1 posts

Posted 14 February 2017 - 03:01 PM

Due to the issue with ULFD on this build the ica_sessions are not correctly processed and NMAS/Insight does not show HDX data. This is fixed in 12.0



Balint Karakai Members
  • #15

Balint Karakai
  • 4 posts

Posted 03 March 2017 - 03:16 PM

I disabled ULFD but it is still not working. And I get message: system has detected the ICA sessions that do not support logging, corresponding reposrts will not be available.



Carl Stalhood CTP Member
  • #16

Carl Stalhood
  • 11,621 posts

Posted 03 March 2017 - 03:26 PM

Mobile clients (iOS, Android) don't support AppFlow.



Balint Karakai Members
  • #17

Balint Karakai
  • 4 posts

Posted 03 March 2017 - 03:37 PM

Thanks for the answer Carl, but in this case no mobile clients are used. The following entry appears when I click the details: error during ICA fragments >> error while attempting to receive the entire packet.



James Kindon Members
  • #18

James Kindon
  • 4 posts

Posted 06 March 2017 - 11:13 PM

I'm chiming in here with the same issue also (NS 11.1.51.26) and MAS (11.1.52.13)

 

I also have zero detection of HDX via SOCKS -> CRVS on the internal front



William Lemons Members
  • #19

William Lemons
  • 3 posts

Posted 13 March 2017 - 02:59 PM

This appeared to fix our issue at first, but a couple weeks later we are back in the same situation. No HDX data...



Alvaro Niebuhr Members
  • #20

Alvaro Niebuhr
  • 19 posts

Posted 20 March 2017 - 09:14 PM

In the build 11.1.50.10 nc works fine?