Jump to content


Photo

PVS 7.6 Target Device Retries

Started by Steve Pledger , 16 March 2015 - 04:19 PM
4 replies to this topic

Steve Pledger Members

Steve Pledger
  • 32 posts

Posted 16 March 2015 - 04:19 PM

Hi Everyone,

 

We are currently running with 2 PVS 7.6 servers, and have reports that there are momentary freezes within the XenDesktop environment.  When investigating, I noticed an unusually high number of retries within PVS.  None of these retries occur during boot up, and gradually climb over the up time of the VM.

 

We are running XenDesktop 7.6 hosting VMs on both XenServer and VMware hypervisors.  All networking is done over 10Gbps with little to no latency (<1ms).  To give everyone an idea for the number of retries, I pulled the data from a couple of VMs.  

 

VM               Retries Days Hours ToThours Retry\Hr
vGPU-0016 11349   7       13       181          62.70165746
vGPU-0018 2032     1       10       34            59.76470588
vGPU-0022 10185   9       17       233          43.71244635
vGPU-0027 10240   5       16       136          75.29411765
vGPU-0030 7665     9       17       233          32.89699571
vGPU-0031 13463   9       17       233          57.78111588
vGPU-0032 12328   2       19       67            184
vGPU-0039 9830     5       21       141          69.71631206
vGPU-0042 407       2       16       64            6.359375
vGPU-0043 39         1       11       35            1.114285714
vGPU-0044 10014   8       23       215          46.57674419
vGPU-0053 2                    1         1              2
vGPU-0054 354       2       18       66            5.363636364


Carl Fallis Citrix Employees

Carl Fallis
  • 971 posts

Posted 16 March 2015 - 06:23 PM

Steve,

 

So these Vms are running on standard mode (not private?)?

 

    if you are running private mode then try the following registry key change and reboot (while in private mode)...

            HKLM\System\CurrentControlSet\services\Bnistack\Parameters

 

                        IosRequestThreads DWORD 2 , if this does not help try 1

If you are not using private mode, make sure that your hardware and operating system have RSS disabled (receive side scaling), we have seen this cause retries. 

 

Carl



Carl Stalhood CTP Member

Carl Stalhood
  • 11,139 posts

Posted 16 March 2015 - 08:01 PM

Are the PvS servers virtual? Are they running on VMware? If so, are they using VMXNET3 NICs?

Ravi Verma Members

Ravi Verma
  • 25 posts

Posted 13 May 2016 - 07:54 AM

Hi Carl, I am also facing same issue. There is a vDisk in standard mode and 40 target device. sometimes some target device retries intermittently. 

 

All target devices and PVS are running on xenserver 6.5. 

 

PVS/XD version is 7.6. OS is 2012 R2 

 

Please suggest 



Asif Shaikh Members

Asif Shaikh
  • 2 posts

Posted 10 February 2017 - 02:29 PM

hi, i have the same situation. VDIs are hosted on hyper-v ( 2k12 R2) and we use PVS.

 

the target device retries found amost 200+ ad most of the images.