Jump to content


Photo

New hostid with migration in cluster

Started by Jacco Wildeman , 20 September 2012 - 06:43 AM
2 replies to this topic

Best Answer Reinhard Teischl , 20 September 2012 - 07:46 AM

Hi,

this means that the MAC of the NIC is changing when you move to another host. This shouldn't be the case :) - do you manage your Hyper-V hosts with SCVMM? Steps i would suggest:

* assign a static MAC to your Netscaler VMs either through Hyper-V Manager or SCVMM

http://www.microtom.net/os-management/windows-management/hyper-v-vmm-mac-address-managment

http://blogs.technet.com/b/jhoward/archive/2008/07/15/hyper-v-mac-address-allocation-and-apparent-network-issues-mac-collisions-can-cause.aspx

Jacco Wildeman Members

Jacco Wildeman
  • 36 posts

Posted 20 September 2012 - 06:43 AM

Hello all. I have an Windows 2008R2 Hyper-v cluster with 2 netscaler VPX running on it. Each time one of the netscaler moves from cluster node, it get a new hostid. This would not be a problem, but then my license is not valid anymore and my netscaler stops functioning (because the licensed features are disabled. I then have to go to mycitrix, redownload a license file with the new host id, import this into the netscaler and reboot. Then everthing will function again. But this is not why I put the netscaler on a cluster. Can Anyone help me with this?



Reinhard Teischl Members

Reinhard Teischl
  • 1,845 posts

Posted 20 September 2012 - 07:46 AM

Hi,

this means that the MAC of the NIC is changing when you move to another host. This shouldn't be the case :) - do you manage your Hyper-V hosts with SCVMM? Steps i would suggest:

* assign a static MAC to your Netscaler VMs either through Hyper-V Manager or SCVMM

http://www.microtom.net/os-management/windows-management/hyper-v-vmm-mac-address-managment

http://blogs.technet.com/b/jhoward/archive/2008/07/15/hyper-v-mac-address-allocation-and-apparent-network-issues-mac-collisions-can-cause.aspx


Best Answer

Jacco Wildeman Members

Jacco Wildeman
  • 36 posts

Posted 20 September 2012 - 08:03 PM

Great!
Thanks, ofcourse! So simple, but it solved the problem.
Thanks again!