Jump to content


Photo

your app is not available, try again later

Started by Martin Langmaid , 06 September 2012 - 03:32 PM
17 replies to this topic

Martin Langmaid Members

Martin Langmaid
  • 2 posts

Posted 06 September 2012 - 03:32 PM

Hi Hoping someone may have seen this before.

I have been trying to configure an Access Gateway 5.0.4 in Access controller mode. I have managed to get the it so that I can log in to the gateway and see applications via the Web interface but when i click on any of the applications I get a message from citrix reciever saying "Your app is not available. Try again later."

I did test the appliance in appliance mode before configuring it with the Access Controller and it worked fine and applications started without error.

The biggest problem I have is that there are no errors on any of the boxes involved in the log in proccess so i don't really know where to look and would like some pointers please.

thanks



halvendira guru Members

halvendira guru
  • 14 posts

Posted 10 September 2012 - 01:35 PM

Please make sure XTE services is runing on STA server.



porress Members

Jose Bordetas
  • 15 posts

Posted 14 September 2012 - 02:02 PM

"Your app is not available. Try again later."

I have the same error message just in one of our machines, I have checked that service but it looks like it is running.
Any other suggestions?

Edited by: porress on Sep 14, 2012 3:02 PM



Daniel da Silva Members

Daniel da Silva
  • 12 posts

Posted 10 October 2012 - 04:18 PM

Hi,

I have the same issue. It works without the Access Controller and i get the message "Your app is not available. Try again later" with the AC.

Did you find something ?

Daniel



Daniel da Silva Members

Daniel da Silva
  • 12 posts

Posted 11 October 2012 - 04:02 PM

Solved for me !
I had wrong xenapp ip addresses configured on my "ICA access Control entry" on my Access Controller.
Have a look at this: http://support.citri...ontrol-tsk.html
Daniel



porress Members

Jose Bordetas
  • 15 posts

Posted 13 October 2012 - 04:47 PM

I think I restarted the IMA service and everything started working again, I hope it doesn't happen again but I dont really know what the issue was.
Thanks,

Edited by: porress on Oct 13, 2012 5:47 PM



Jeroen Van Hecke Members

Jeroen Van Hecke
  • 21 posts

Posted 17 October 2012 - 07:44 AM

We had the same error message; I've tried everything to fix it and finally found our cause:
The ICA listenere Protocol on the XenApp servers in our farm wasn't working as expexted.

We had 4 NICs in these virtual servers; 1 production, 1 for backup and 1 for administration; the 4th one was used during the setup.
ICA listener protocol was set to listen only on the first NIC: no problem
Because the fourth nic wasn't used; we've set it ti DHCP; disabled it and finally removed it in the virtual layer and this is the moment our problems started.
ICA listener Protocol was suddenly listening on NIC 2; I've set it back to NIC 1: still not possible to reconnect. Reconfigured it to "all nics with protocol": still not possible to connect.

I've added the virtual nic again; it got the same name as the removed one (which is normal behaviour); I've reconfigured ICA listener Protocol to listen on the first nic: problem solved.



Frederic LOUKA Members

Frederic LOUKA
  • 93 posts

Posted 18 October 2012 - 03:25 PM

Hello everybody,

I'm having the same problem and I'm unable to find a solution....
I'm using the CAG vpx express edition 5.0.4 and a xenapp 6.5 server.
I use the web interface authentification and created a site reserved for my cag.
I'm able to authenticate on my web interface but when I try to launch my app, I got the message
"Your app is not available try again later".....

Did anyone resolve the problem ?

Thanks !

Fred

Update: I found this logs:
192.168.0.45 - Notepad::[18/Oct/2012:23:01:37 00200]"" - - "" "" "SG-Traffic" "application not found" "192.168.0.43:1494" "SOCKS" "ICA ACL Check FAIL"



Nawir Bunai Members

Nawir Bunai
  • 205 posts

Posted 18 October 2012 - 10:17 PM

Where do you set that ICA Listener Protocol?
In my case. I encounter that "try again later" only if user access from non domain member pc
My server are only PVS+XenDesktop, not XenApp yet.
If not mistaken it complain about AD. I'll post the client side log later

thanks

Edited by: nbunai586 on Oct 18, 2012 6:18 PM



Chandresh Shah Members
  • #10

Chandresh Shah
  • 33 posts

Posted 22 October 2012 - 07:46 PM

Hello Guys

Even some of my users get the same error message. Problem is there is no pattern to it. It just comes up some time. I have no clue where to start from as it is hard to catch while one user gets it some are in and working without any issues
I am running Netscaller MPX5500 Access Gateway 9.3 on it, XenApp Enterprise 6.5 servers and client is the latest Citrix receiver 3.3

Has anyone any idea what is going on



Frederic LOUKA Members
  • #11

Frederic LOUKA
  • 93 posts

Posted 23 October 2012 - 09:05 AM

Hi Chandresh,
I found the solution to my problem.
I didn't have the proper license ! The audit logs are too generic.
By reading the console log (directly in the appliance console), I saw that this message appear:
"no platform license available".
I downloaded a license platform and now it works great !
In fact, I have two license:
- Access Gateway Platform => For unlimited ICA sessions (ICA Proxy)
- Access Gateway Universal Concurrent => For SmartAccess features and VPN features of a gateway

Maybe you need more license ?

Fred



Chandresh Shah Members
  • #12

Chandresh Shah
  • 33 posts

Posted 23 October 2012 - 02:42 PM

Fred

Thanks for the reply.
when you say need more Licenses where do we need them more??? At Netscaler level?? I have 5 user license but I was told by Citrix support and Pre Sales Engineer that those are more for management and if I actually used the device to do VPN or etc.. Which we do not use that way. Netscaler is purely acting as Access Gateway with unlimited ICA Proxies. Do I still need license for it??? When you turn on ICA Proxies actual licenses come from XENAPP server for the session so no need to worry about Netscaler(Access Gateway) License. Remember Access Gateway is running on top of Netscaler Device itself. It is built in there



Chandresh Shah Members
  • #13

Chandresh Shah
  • 33 posts

Posted 23 October 2012 - 03:59 PM

Hello Fred

I just found out one more thing in Netscaler MPX 5505 that I have both Platform Licenses that you mention are built in. Atleast that is what Citrix support says on web. If you defer from this then please share more info

Thanks in advance



JASON POYNER Members
  • #14

JASON POYNER
  • 144 posts

Posted 30 October 2012 - 02:43 AM

I came across this issue today and tracked it down to the Maximum Number of Users setting found under:
Access Gateway > Global Settings > Change Authentication Settings

Change the Maximum Number of Users to the value you require.



Royce Knight Members
  • #15

Royce Knight
  • 1 posts

Posted 05 December 2012 - 06:56 AM

We had this problem and tracked it down to a proxy server at the client location. We bypassed the proxy and could then connect.



Sunish Mannuel Citrix Employees
  • #16

Sunish Mannuel
  • 20 posts

Posted 05 December 2012 - 01:39 PM

This error occurs when you are trying to launch your app. Which means its the ICA connection that is not going through. A few things you can check,

1. What is the actual Xenapp server IP that AGEE is trying to contact to launch the App
2. See if you can telnet from AGEE on port 1494 or 2598 to the actual XenApp server
3. A trace should reveal if there is a connection being made or not.



kelly kate Members
  • #17

kelly kate
  • 2 posts

Posted 02 January 2013 - 11:24 AM

I too have accession issues after logging in to Access Gateway 5.0.4 and was searching for a valid solution to this issue. I find this discussion useful for the topics it covers about the related appliances. Even I wonder, which mode to set for the real login settings.
_________________________
Kelly Kate
kitchen tile backsplash ideas



Bartosz Kolodziej Members
  • #18

Bartosz Kolodziej
  • 34 posts

Posted 04 January 2013 - 08:36 AM

Where is this set in CAG Ent. 10 ? I have the same problem and I have no idea what should I set to be able to connect to XenApp farm...