Jump to content


Photo

Error 401 Token Invalid MS 2.2/Receiver 3.0

Started by Jamie Breedlove , 03 January 2012 - 11:47 PM
3 replies to this topic

Jamie Breedlove Members

Jamie Breedlove
  • 2 posts

Posted 03 January 2012 - 11:47 PM

This is my first client install of MS. I let the server auto create a token and saved the config. Then, I installed the receiver on a workstation specifying server location and token as install switches. When I attempt to check for updates I'm getting a login prompt for the MS. When I cancel out I get the message Error 401 Token Invalid in the Plug-in Status tab. Any thoughts on where I'm stumbling?



Jamie Breedlove Members

Jamie Breedlove
  • 2 posts

Posted 04 January 2012 - 04:12 PM

Tried the client install with two different system generated tokens without success. I tried a third time with a simple manual token and it worked. Strange. I'm going to try a more complexed manual token...



Christian Immke Members

Christian Immke
  • 5 posts

Posted 28 February 2012 - 01:45 PM

Thanks for the workaround



Harry Singh Members

Harry Singh
  • 101 posts

Posted 09 March 2012 - 04:43 PM

Is there any other information out there about this topic? I find it strange that in order to install a client delivered by MS you have to use two administrative credentials. One set to install the actual receiver, and the second set needs to be setup as Admin from within the MS console.

Nothing i seem to do with regard to the receiverupdater.msi, or xml file or changing the token to something "simple" works. I continue to get a 401 token error when i cancel out of the credentials promp receiver throws when attempting to install plugins.

The client apparently downloads a base "receiver.exe" file autogenerated by MS, then calls the receiverupdater.msi -- is that about right?

Installing the base receiver.exe as administrator is something we'll have to deal with, but i really need to get around the plugin requesting auth from the merchandising server once it tries to install plugins.

I used this forum as a reference guide, which is insightful but since there is absolutely no mention of this in Citrix eDocs, i suppose success is a relative endeavor.

http://forums.citrix.com/thread.jspa?threadID=294481

Resolved

Just as i finished typing this, i restarted the merchandising server after having uploaded the updated xml and msi files. Once i did that, the new receiver was delivered to a machine correctly. It didn't prompt me for the MS credentials to continue with the plugin installation. The only pre-requisite now is making sure the client is installed with ADMIN credentials.

Hope this thread can help others.

Best,

H

Edited by: Harry Singh on Mar 9, 2012 11:45 AM

Edited by: Harry Singh on Mar 9, 2012 12:11 PM