Jump to content


Photo

Error 2320 - LegacyLocalUserNameAndPassword

Started by Nuno SEQUEIRA , 03 November 2011 - 09:19 PM
2 replies to this topic

Nuno SEQUEIRA Members

Nuno SEQUEIRA
  • 58 posts

Posted 03 November 2011 - 09:19 PM

Hi all,

We have a new farm on XenApp 6.5 with older farm on XenApp 5.0.

All our Windows clients have installed Citrix Online Plug-in Full version 12.0.3

When we deployed XenApp 6.5 we had this error when accessing the same applications but on the new WI.

Error 2320 Citrix online plug-in Configuration Manager: No value could be found for (LegacyLocalUserNameAndPassword) that satisfies all lockdown requirements. The lockdown requirements in force may be conflicting.

This is wierd because I've updated the icaclient.adm for new receiver and there's a new entry for the SSON on all ICA Clients.

I've tried to use the old icaclient.adm, but it didn't work.

Solution:

1 - Update the clients to Citrix Online Plug-in Full or Citrix Receiver. This is painful because we have 2.000 windows clients all over WAN.

2 - Remove the registry keys LegacyLocalUserNameAndPassword that are in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown. This is painful because we have 2.000 windows clients.

Question:

- Is there a btter way of solving this?
- Any help / hint on this?
- Is this a bug from ICACLIENT.ADM and old Citrix Online Plug-in Full?

Thank you.

Kind regards,

NS



Andrea Giuliani Members

Andrea Giuliani
  • 1 posts

Posted 09 November 2011 - 03:46 PM

Hi,
I had your same issue (with Online Plug-in Full version 11.x) and resolved by editing the icaclient.adm.
I removed (or commented) the lines from 1527 to 1531, which sets LegacyLocalUserNameAndPassword in user profile, so that policy don't set that value anymore. I haven't found yet any other issue due to the lack of that registry parameter.
Regards,
Andrea



Jay Zhou Members

Jay Zhou
  • 1 posts

Posted 09 August 2012 - 03:41 AM

I got the same problem.
Environment: windows 2003 Domain server+ citrix server(citrix 4.5)+xp client(plugin 12).
I found citrix create some policies on Domain Server :the Default Domain Policy .Both computer setting and user setting have citrix components.
Set the Citrix Receiver->User authentication->Local Username and password to unsetting.Problem solved.