Jump to content


Photo

U232-P9 USB to Serial Converter

Started by Marilee Nason , 28 September 2011 - 04:02 PM
6 replies to this topic

Marilee Nason Members

Marilee Nason
  • 8 posts

Posted 28 September 2011 - 04:02 PM

Very New to all this but learning quickly.

I am having a major problem with these devices (u232-P9). The admin guide says they are tested and supported.

When I try to install the drivers per the instructions, nothing seems to happen. The instructions state I should see a new com port and a new usb adapter cable in the device manager, after a reboot. but they are not there. No, I have not tried this on a physical machine but will when I get back on site.

I have tried this on a brand new VM through XenCenter, Windows 7 and XP pro. I have tried it through a Xenith session as well.

Do I need to set some Citrix policies somewhere to allow for installs of this sort?

Should I be installing the drivers in ZenApp?

Please give as much detail as possible.
Thanks.
Sam Swari



Michael Obernberger Members

Michael Obernberger
  • 275 posts

Posted 28 September 2011 - 04:22 PM

Hi,

do you have USB Redirection enabled? Or do you see something if you plugin the adapter in the device manager that there is a new device?

Michael



Marilee Nason Members

Marilee Nason
  • 8 posts

Posted 28 September 2011 - 04:35 PM

Not sure about the Redirection. I am not on site, but will check on that first thing. We are using Wyse Xenith devices, but that really is irrelevant at this time because nothing happens even when creating a new master VM in XenControler. I have even tried the driver install on a machine through the Xenith device, all with no changes to the VM device manager.

How would I turn on Redirection in XenControler?

Again, following the instructions of the adapter, You install the drivers, Reboot the machine, than you should see the new com port and adapter(under USB section) in device manager. All of this is to be done before plugging in the adapter.

Now, on the Xenith, yes in the device, you do see the adapter and it moves depending on which port it is plugged into.



Michael Obernberger Members

Michael Obernberger
  • 275 posts

Posted 28 September 2011 - 04:44 PM

Here you go: http://blogs.citrix.com/2011/07/15/how-to-enable-usb-redirection-on-xendesktop-5/

Michael



Marilee Nason Members

Marilee Nason
  • 8 posts

Posted 28 September 2011 - 06:04 PM

Thanks for the link, now what about XenControler( I think) where you create the actual master VM? Or do I not install the drivers there, but rather after I add the VMs to XenDesktop Studio??

BTW, I am using XenServer to host the VMs if that makes any difference. I can get you the exact versions of all the software shortly.

Thank you all for your help.
Sam



Marilee Nason Members

Marilee Nason
  • 8 posts

Posted 29 September 2011 - 02:28 AM

Ok, here is my up date after messing around with this well into the night.

FWIW, the serial device is a 3M touchscreen with a serial interface. I am working with The 3M MicroTouch Drivers (MTD from here forward) The TS Monitor is Made by Stealth Computers. I am running XenServer 5.6 sp2, XenCenter Version NOT SURE, XenDesktop 5. I have upgraded the Xenith to 1.6x also. Maybe I should try one that is not upgraded.

After some advice and looking around on the XenDesktop forums, I found out about USB redirection and turned it on and created some rules that seem to be allowing some communication between the VM and the USB ports. Things got better but are not 100%.

So, now when I plug a USB device into the Xenith, both the Xenith and the VM actually see it. So, the issue now seems to be true/full communication.

I have both a Aten converter and one of the U232-p9s. From what I have read, the U232 device is the only one this is really supported by Wyse. Strangely, I seem to get closer to getting this working with the Aten, But neither one will actually activate the mouse cursor.

Both atapters have send and receive indicators on them. Both will flash to indicate that there is activity when you touch the screen. The Aten gets real active when the MTDs try and load where the U232 just does not seem to get all that excited.

Legacy versions of the MTDs with the Aten device, will actually show that they see the the touch screen. When I run the MTD calibration tool, it will actually act like it recognizes you touching the screen but still no mouse activation. This combination does work on a Physical machine.

With the U232 device, I can not get the MTDs to see the monitor in anyway shape or form. I really think this has to do with IRQs and IO addresses but can not get the adapters to show me where they are configured.

I will be going through the upgrade release notes for the Citrix software here for a while to see if it is worth attempting getting everything upgraded or just stay were we are for now.

Any Insight would be greatly appreciated.

Edited by: mnason on Sep 29, 2011 10:25 AM



Julian Botero Members

Julian Botero
  • 8 posts

Posted 12 September 2012 - 09:09 PM

Did you ever find a solution to this? I am currently trying to get a Wirless Sgnature Pad to work in my XenDesktop VM. I am using a converter and I do see the converter showing up as COM4 under Device Manager. However, I cant get sigpad to work. Just doesnt seem to transmit the data.