Jump to content


Photo

Citrix Viewer Crashing in Mac OS X Lion (10.7)

Started by Phil Labbe , 22 July 2011 - 04:35 PM
35 replies to this topic

Phil Labbe Members

Phil Labbe
  • 3 posts

Posted 22 July 2011 - 04:35 PM

I recently upgraded to Mac OS X Lion, and since upgrading, my Citrix Viewer crashes as soon as it starts to initialize. Sometimes the Citrix viewer window will actually launch, open, begin to render the app windows, but then crashes about 3 seconds into it.
I tried uninstalling and reinstalling the Citrix Online Plug-in (11.2) for Mac, then restarting, but the problem persists. I have attached the crash log.
Can anyone provide step-by-step instructions on how to resolve this, or confirm if this is an open issue?

Thanks

Attached Files



Matthew Junk Members

Matthew Junk
  • 22 posts

Posted 22 July 2011 - 07:42 PM

Have you tried deleting the Citrix cache? I'm not sure if uninstalling the client will actually do this. It's located in ./Library/Caches/com.citrix.receiver.mas/.



Dominic Esquibel Members

Dominic Esquibel
  • 1 posts

Posted 22 July 2011 - 10:22 PM

I am experiencing the same issue. I even wiped the mac and reloaded OSX Lion 10.7 cleanly and reloaded the citrix web plugin. After that I get the same results. Citrix crashes it did work once after some messing about but that was as good as it gets. I ended up reloading OSX 10.6 and Citrix is back in working order for now. Hope they come out with fix for this soon.

Dom



Phil Labbe Members

Phil Labbe
  • 3 posts

Posted 23 July 2011 - 03:15 PM

Yes, deleted the cache, uninstalled, reinstalled, restarted and no change. Have tried reinstalling 4 times, but no change.... Not sure if the error log yields any clues



Randall Pierce Members

Randall Pierce
  • 2 posts

Posted 25 July 2011 - 11:48 PM

Have you tried accessing through Firefox? With Safari after Lion upgrade, the citrix plugin is a non-starter- no evidence it even knows I am accessing citrix applications via the browser. However, with Firefox, it worked without a hitch- I started up FF and it asked if I wanted to enable plugin.



Dio Nunez Members

Dio Nunez
  • 1 posts

Posted 27 July 2011 - 03:30 PM

Not sure if this may help but I had a similar problem. You may want to confirm Safari is not set to 32-bit, which won’t work with the Citrix plugin.

Have to go ‘Get Info’ for Safari and uncheck ‘open in 32-bit mode’.

Just a thought.



Ryan Strauss Members

Ryan Strauss
  • 1 posts

Posted 29 July 2011 - 06:31 PM

Absolutely not a "solution", but as a temporary fix - when it crashes the first time and the OS X dialog pops up asking you to Report, Ignore or Relaunch, click "Relaunch" - this will just open the Citrix icon in the Dock. Then try relaunching the application through the Citrix Receiver or whatever Citrix desktop you're using and it should launch properly.

Pain in the neck, but until someone can release a fix...



Cynthia Zinakova Members

Cynthia Zinakova
  • 1 posts

Posted 06 August 2011 - 08:11 AM

I had the same issue. Reloading the plug-in did not resolve the issue. It also didn't make a difference when I used Firefox. I'm hoping they put a fix in quickly. Glad to know I'm not alone - spent hours trying to resolve.



Dustin Norman Citrix Employees

Dustin Norman
  • 132 posts

Posted 10 August 2011 - 03:10 PM

We are investigating this issue and it should only occur when launching via Safari. cynzin, if you get a crash when launching with Firefox, please post the crash report here.



John Lynch Members
  • #10

John Lynch
  • 238 posts

Posted 11 August 2011 - 03:00 PM

I got firefox working by removing all installed Citrix Clients and then via terminal going to: /Library/Application Support/Citrix and doing a "rm -d *" (make sure you know what you are doing and that you are in the right directory becuase this is a very powerful command). Then I reinstalled v11.2 and it worked. I didn't try installing any of the newer clients because I didn't have enough time.

Hope this info helps.

-John



EMIL VARONA Members
  • #11

EMIL VARONA
  • 3 posts

Posted 15 August 2011 - 09:07 AM

First off, I stumbled across this issue when I realized that my Mac Air was at almost full CPU. A quick search found the solution to be running this command on the Mac

sudo launchctl unload -w /Library/LaunchDaemons/com.citrix.agadminservice.plist

This fixed the CPU issue but killed my plug-in. I found that by selecting the Java plug-in, I was able to once again get connected. It's slower than molasses but it does work. BTW, make sure to install Java from Apple and do it before the receiver is installed to avoid other issues.

BTW, I'm running OSX 10.7 and Receiver 11.3.



Samuli Siren Members
  • #12

Samuli Siren
  • 1 posts

Posted 23 August 2011 - 10:56 AM

Had same problems and crashing with Safari. I just happened to try my citrix web access with Chrome and voila: I just worked right away. Chrome asked, if I have the Plug-in installed, I click no. It started to downloading the plug-in, but meanwhile my interface was already up and running. All fine, happily working :-)



Dustin Norman Citrix Employees
  • #13

Dustin Norman
  • 132 posts

Posted 24 August 2011 - 01:54 PM

The issue with the Citrix Viewer crashing when launching a session via Safari was caused by a bug in Safari on Lion. We have worked around the problem in the 11.4 release of Citrix Receiver for Mac which is available now in the Downloads section of citrix.com.



Matt Hamilton Members
  • #14

Matt Hamilton
  • 1 posts

Posted 27 August 2011 - 04:50 PM

Version 11.4 has not solved the problem, at least not on my machine. I have a macbook air running OS 10.7 (Lion). I was given this download and told "here, this works." No.

I'm attempting to access a database using a third party online portal (sorry if my vernacular is off here, just trying to be clear about what's going on), and when I do the viewer loads up, opens a window that I guess should be the virtual desktop, but it just remains a black screen, the dialog box sits there trying to connect, and it eventually times out and shuts itself down (or crashes, if this is what other users have experienced).

If anyone out there can give me a workaround, a version of this thing that actually works like it's supposed to, or any other advice, it would be appreciated. I was supposed to be up and running two days ago and this is costing me time and money on this project.



Phil Labbe Members
  • #15

Phil Labbe
  • 3 posts

Posted 11 September 2011 - 03:32 PM

Agree, 11.4 not working with Safari for me



Dustin Norman Citrix Employees
  • #16

Dustin Norman
  • 132 posts

Posted 12 September 2011 - 06:41 PM

plabbe75, does it work with if you try to launch with a different browser (like Firefox or Chrome)? What exactly is the behavior that you are seeing? If it does truly crash and show the Mac OS X crash dialog, please post the crash log here.



Jean-manuel Croset Members
  • #17

Jean-manuel Croset
  • 2 posts

Posted 26 September 2011 - 12:46 AM

Nothing works here. No 11.2 or 11.4. Still nothing in the app store. Is something going? We need a solution and now. We sold many installations to our Mac users and now they're just lost with no possibility to connect!

Could you please communicate on what are the problems, which platform and what are, if any, the workarounds?

We tried to uninstall several times, emptied the /Library/Application Support/Citrix and so on, but still no way to let this "*ç+"%*ç%"*% plugin run. Tried on XenDesktop & Kaviza, on 2011 MacBook Air with OS X 10.7 Lion stock (no upgrade).

Many thanks in advance

JM



Dustin Norman Citrix Employees
  • #18

Dustin Norman
  • 132 posts

Posted 26 September 2011 - 12:01 PM

simplyw, what behavior are you seeing? Is it crashing? Are you seeing an error message? Please reply with a crash log or screenshot of any errors. Thanks.



Shawn Dorman Members
  • #19

Shawn Dorman
  • 1 posts

Posted 28 September 2011 - 06:58 PM

I believe I am getting the same issue. I'm running 11.4 on Lion.

The first time I connect to my XP machine, things appear to be very fast. If I let the app sit for a while (not sure exactly how long it takes yet) and come back, log back in, and reconnect, the XP machine is completely unresponsive.

Thanks!
Shawn



Jean-manuel Croset Members
  • #20

Jean-manuel Croset
  • 2 posts

Posted 15 October 2011 - 10:18 PM

Hello and thank you for your answer. I'm sorry I reply that late, but I didn't get a notification the thread has been answered.

No, the plugin doesn't crash, but it starts, displaying "connecting to XXXXXX...." and after ca 30" it displays the error message attached ("Connection to server XXX.XXX.XXX.XXX failed - Error number: 51").

Any solution in the pipeline? It seems that at least MacBook Air running 10.7 natively (aka 10.7 delivered with the computer, no update) are concerned.

Thank you very much for your prompt answer.

Regards

JM

Attached Files